This CPE summary could be partial or incomplete. Please contact us for a detailed listing.

Summary

Detail
Vendor Adobe First view 2005-12-31
Product Flash Player Last view 2020-06-12
Version Type
Update  
Edition  
Language  
Sofware Edition  
Target Software  
Target Hardware  
Other  

Activity : Overall

COMMON PLATFORM ENUMERATION: Repartition per Version

CPE Name Affected CVE
cpe:2.3:a:adobe:flash_player:8.0:*:*:*:*:*:*:* 1012
cpe:2.3:a:adobe:flash_player:*:*:*:*:*:*:*:* 1011
cpe:2.3:a:adobe:flash_player:8.0.24.0:*:*:*:*:*:*:* 1010
cpe:2.3:a:adobe:flash_player:7.0.25:*:*:*:*:*:*:* 1010
cpe:2.3:a:adobe:flash_player:6.0.79:*:*:*:*:*:*:* 1010
cpe:2.3:a:adobe:flash_player:6.0.21.0:*:*:*:*:*:*:* 1009
cpe:2.3:a:adobe:flash_player:7.0:*:*:*:*:*:*:* 1009
cpe:2.3:a:adobe:flash_player:7.0.70.0:*:*:*:*:*:*:* 1009
cpe:2.3:a:adobe:flash_player:7.0.69.0:*:*:*:*:*:*:* 1009
cpe:2.3:a:adobe:flash_player:7.0.63:*:*:*:*:*:*:* 1009
cpe:2.3:a:adobe:flash_player:9.0.28:*:*:*:*:*:*:* 1009
cpe:2.3:a:adobe:flash_player:cs3:*:professional:*:*:*:*:* 1009
cpe:2.3:a:adobe:flash_player:*:*:pro:*:*:*:*:* 1009
cpe:2.3:a:adobe:flash_player:7.0.1:*:*:*:*:*:*:* 1008
cpe:2.3:a:adobe:flash_player:8.0.22.0:*:*:*:*:*:*:* 1008
cpe:2.3:a:adobe:flash_player:7.1.1:*:*:*:*:*:*:* 1008
cpe:2.3:a:adobe:flash_player:7.2:*:*:*:*:*:*:* 1008
cpe:2.3:a:adobe:flash_player:9.0.28.0:*:*:*:*:*:*:* 1008
cpe:2.3:a:adobe:flash_player:9.0.18d60:*:*:*:*:*:*:* 1008
cpe:2.3:a:adobe:flash_player:7.1:*:*:*:*:*:*:* 1008
cpe:2.3:a:adobe:flash_player:9.0.20.0:*:*:*:*:*:*:* 1008
cpe:2.3:a:adobe:flash_player:9.0.16:*:*:*:*:*:*:* 1008
cpe:2.3:a:adobe:flash_player:9.0.20:*:*:*:*:*:*:* 1008
cpe:2.3:a:adobe:flash_player:9.0.45.0:*:*:*:*:*:*:* 1008
cpe:2.3:a:adobe:flash_player:7.0.53.0:*:*:*:*:*:*:* 1008
cpe:2.3:a:adobe:flash_player:7.0.68.0:*:*:*:*:*:*:* 1008
cpe:2.3:a:adobe:flash_player:7.0.24.0:*:*:*:*:*:*:* 1008
cpe:2.3:a:adobe:flash_player:7.0.61.0:*:*:*:*:*:*:* 1008
cpe:2.3:a:adobe:flash_player:7.0.14.0:*:*:*:*:*:*:* 1008
cpe:2.3:a:adobe:flash_player:7.0.19.0:*:*:*:*:*:*:* 1008
cpe:2.3:a:adobe:flash_player:7.0.67.0:*:*:*:*:*:*:* 1008
cpe:2.3:a:adobe:flash_player:7.0.60.0:*:*:*:*:*:*:* 1008
cpe:2.3:a:adobe:flash_player:7.0.73.0:*:*:*:*:*:*:* 1008
cpe:2.3:a:adobe:flash_player:7.0.66.0:*:*:*:*:*:*:* 1008
cpe:2.3:a:adobe:flash_player:cs4:*:pro:*:*:*:*:* 1008
cpe:2.3:a:adobe:flash_player:8.0:*:pro:*:*:*:*:* 1008
cpe:2.3:a:adobe:flash_player:8.0:*:basic:*:*:*:*:* 1008
cpe:2.3:a:adobe:flash_player:cs3:*:pro:*:*:*:*:* 1008
cpe:2.3:a:adobe:flash_player:7.0.63:*:linux:*:*:*:*:* 1008
cpe:2.3:a:adobe:flash_player:8:*:professional:*:*:*:*:* 1008
cpe:2.3:a:adobe:flash_player:8:*:pro:*:*:*:*:* 1008
cpe:2.3:a:adobe:flash_player:7.0_r67:*:solaris:*:*:*:*:* 1008
cpe:2.3:a:adobe:flash_player:7.0_r67:*:*:*:*:*:*:* 1008
cpe:2.3:a:adobe:flash_player:mx_2004:*:*:*:*:*:*:* 1008
cpe:2.3:a:adobe:flash_player:*:*:basic:*:*:*:*:* 1008
cpe:2.3:a:adobe:flash_player:5:*:*:*:*:*:*:* 1008
cpe:2.3:a:adobe:flash_player:3:*:*:*:*:*:*:* 1008
cpe:2.3:a:adobe:flash_player:4:*:*:*:*:*:*:* 1008
cpe:2.3:a:adobe:flash_player:2:*:*:*:*:*:*:* 1008
cpe:2.3:a:adobe:flash_player:6:*:*:*:*:*:*:* 1008

Related : CVE

This CPE Product have more than 25 Relations. If you want to see a complete summary for this CPE, please contact us.
  Date Alert Description
9.8 2020-06-12 CVE-2020-9633

Adobe Flash Player Desktop Runtime 32.0.0.371 and earlier, Adobe Flash Player for Google Chrome 32.0.0.371 and earlier, and Adobe Flash Player for Microsoft Edge and Internet Explorer 32.0.0.330 and earlier have an use after free vulnerability. Successful exploitation could lead to arbitrary code execution.

8.8 2020-02-13 CVE-2020-3757

Adobe Flash Player versions 32.0.0.321 and earlier, 32.0.0.314 and earlier, 32.0.0.321 and earlier, and 32.0.0.255 and earlier have a type confusion vulnerability. Successful exploitation could lead to arbitrary code execution.

7.5 2019-09-27 CVE-2019-8075

Adobe Flash Player version 32.0.0.192 and earlier versions have a Same Origin Policy Bypass vulnerability. Successful exploitation could lead to Information Disclosure in the context of the current user.

9.8 2019-09-12 CVE-2019-8070

Adobe Flash Player 32.0.0.238 and earlier versions, 32.0.0.207 and earlier versions have a Use after free vulnerability. Successful exploitation could lead to Arbitrary Code Execution in the context of the current user.

9.8 2019-09-12 CVE-2019-8069

Adobe Flash Player 32.0.0.238 and earlier versions, 32.0.0.207 and earlier versions have a Same Origin Method Execution vulnerability. Successful exploitation could lead to Arbitrary Code Execution in the context of the current user.

8.8 2019-06-12 CVE-2019-7845

Adobe Flash Player versions 32.0.0.192 and earlier, 32.0.0.192 and earlier, and 32.0.0.192 and earlier have an use after free vulnerability. Successful exploitation could lead to arbitrary code execution.

6.5 2019-05-24 CVE-2019-7090

Flash Player Desktop Runtime versions 32.0.0.114 and earlier, Flash Player for Google Chrome versions 32.0.0.114 and earlier, and Flash Player for Microsoft Edge and Internet Explorer 11 versions 32.0.0.114 and earlier have an out-of-bounds read vulnerability. Successful exploitation could lead to information disclosure.

7.5 2019-05-23 CVE-2019-7108

Adobe Flash Player versions 32.0.0.156 and earlier, 32.0.0.156 and earlier, and 32.0.0.156 and earlier have an out-of-bounds read vulnerability. Successful exploitation could lead to information disclosure .

9.8 2019-05-23 CVE-2019-7096

Adobe Flash Player versions 32.0.0.156 and earlier, 32.0.0.156 and earlier, and 32.0.0.156 and earlier have an use after free vulnerability. Successful exploitation could lead to arbitrary code execution.

8.8 2019-05-22 CVE-2019-7837

Adobe Flash Player versions 32.0.0.171 and earlier, 32.0.0.171 and earlier, and 32.0.0.171 and earlier have a use after free vulnerability. Successful exploitation could lead to arbitrary code execution.

7.8 2019-01-18 CVE-2018-15983

Flash Player versions 31.0.0.153 and earlier, and 31.0.0.108 and earlier have an insecure library loading (dll hijacking) vulnerability. Successful exploitation could lead to privilege escalation.

9.8 2019-01-18 CVE-2018-15982

Flash Player versions 31.0.0.153 and earlier, and 31.0.0.108 and earlier have a use after free vulnerability. Successful exploitation could lead to arbitrary code execution.

9.8 2018-11-29 CVE-2018-15981

Flash Player versions 31.0.0.148 and earlier have a type confusion vulnerability. Successful exploitation could lead to arbitrary code execution.

7.5 2018-11-29 CVE-2018-15978

Flash Player versions 31.0.0.122 and earlier have an out-of-bounds read vulnerability. Successful exploitation could lead to information disclosure.

7.5 2018-09-25 CVE-2018-15967

Adobe Flash Player versions 30.0.0.154 and earlier have a privilege escalation vulnerability. Successful exploitation could lead to information disclosure.

9.8 2018-08-29 CVE-2018-12828

Adobe Flash Player 30.0.0.134 and earlier have a "use of a component with a known vulnerability" vulnerability. Successful exploitation could lead to privilege escalation.

7.5 2018-08-29 CVE-2018-12827

Adobe Flash Player 30.0.0.134 and earlier have an out-of-bounds read vulnerability. Successful exploitation could lead to information disclosure.

7.5 2018-08-29 CVE-2018-12826

Adobe Flash Player 30.0.0.134 and earlier have an out-of-bounds read vulnerability. Successful exploitation could lead to information disclosure.

9.8 2018-08-29 CVE-2018-12825

Adobe Flash Player 30.0.0.134 and earlier have a security bypass vulnerability. Successful exploitation could lead to security mitigation bypass.

5.9 2018-08-29 CVE-2018-12824

Adobe Flash Player 30.0.0.134 and earlier have an out-of-bounds read vulnerability. Successful exploitation could lead to information disclosure.

7.5 2018-07-20 CVE-2018-5008

Adobe Flash Player 30.0.0.113 and earlier versions have an Out-of-bounds read vulnerability. Successful exploitation could lead to information disclosure.

8.8 2018-07-20 CVE-2018-5007

Adobe Flash Player 30.0.0.113 and earlier versions have a Type Confusion vulnerability. Successful exploitation could lead to arbitrary code execution in the context of the current user.

9.8 2018-07-09 CVE-2018-5002

Adobe Flash Player versions 29.0.0.171 and earlier have a Stack-based buffer overflow vulnerability. Successful exploitation could lead to arbitrary code execution in the context of the current user.

6.5 2018-07-09 CVE-2018-5001

Adobe Flash Player versions 29.0.0.171 and earlier have an Out-of-bounds read vulnerability. Successful exploitation could lead to information disclosure.

6.5 2018-07-09 CVE-2018-5000

Adobe Flash Player versions 29.0.0.171 and earlier have an Integer Overflow vulnerability. Successful exploitation could lead to information disclosure.

CWE : Common Weakness Enumeration

%idName
58% (393) CWE-119 Failure to Constrain Operations within the Bounds of a Memory Buffer
8% (60) CWE-416 Use After Free
6% (44) CWE-264 Permissions, Privileges, and Access Controls
5% (34) CWE-200 Information Exposure
4% (29) CWE-189 Numeric Errors
2% (20) CWE-94 Failure to Control Generation of Code ('Code Injection')
2% (17) CWE-399 Resource Management Errors
1% (12) CWE-704 Incorrect Type Conversion or Cast
1% (12) CWE-79 Failure to Preserve Web Page Structure ('Cross-site Scripting')
1% (12) CWE-20 Improper Input Validation
1% (11) CWE-125 Out-of-bounds Read
1% (7) CWE-284 Access Control (Authorization) Issues
0% (6) CWE-352 Cross-Site Request Forgery (CSRF)
0% (4) CWE-190 Integer Overflow or Wraparound
0% (2) CWE-787 Out-of-bounds Write
0% (2) CWE-362 Race Condition
0% (2) CWE-346 Origin Validation Error
0% (2) CWE-254 Security Features
0% (1) CWE-426 Untrusted Search Path
0% (1) CWE-129 Improper Validation of Array Index
0% (1) CWE-59 Improper Link Resolution Before File Access ('Link Following')

Oval Markup Language : Definitions

This CPE Product have more than 25 Relations. If you want to see a complete summary for this CPE, please contact us.
OvalID Name
oval:org.mitre.oval:def:394 SWF Movie Arbitrary Code Execution Vulnerability
oval:org.mitre.oval:def:1050 Flash Arbitrary Code Execution Vulnerability
oval:org.mitre.oval:def:432 Malformed, Compressed .swf File Arbitrary Code Execution Vulnerability
oval:org.mitre.oval:def:709 Adobe Flash Player allowScriptAccess protection bypass vulnerability
oval:org.mitre.oval:def:11405 CRLF injection vulnerability in Adobe Flash Player plugin 9.0.16 and earlier ...
oval:org.mitre.oval:def:9332 Adobe Macromedia Flash Player 7 and 9, when used with Opera before 9.20 or Ko...
oval:org.mitre.oval:def:21835 ELSA-2007:0494: kdebase security update (Important)
oval:org.mitre.oval:def:24920 Adobe Macromedia Flash Player 7 and 9, when used with Opera before 9.20 or Ko...
oval:org.mitre.oval:def:11493 Integer overflow in Adobe Flash Player 9.0.45.0 and earlier might allow remot...
oval:org.mitre.oval:def:22507 ELSA-2007:0696: flash-plugin security update (Critical)
oval:org.mitre.oval:def:29400 Adobe Flash Player 8.0.34.0 and earlier insufficiently validates HTTP Referer...
oval:org.mitre.oval:def:11874 ActionScript 3 (AS3) in Adobe Flash Player 9.0.47.0, and other versions and o...
oval:org.mitre.oval:def:24854 ActionScript 3 (AS3) in Adobe Flash Player 9.0.47.0, and other versions and o...
oval:org.mitre.oval:def:24322 DEPRECATED: Integer overflow in Adobe Flash Player 9.0.45.0 and earlier might...
oval:org.mitre.oval:def:23992 Unspecified vulnerability in Adobe Flash Player 9.0.47.0 and earlier, when ru...
oval:org.mitre.oval:def:9188 Unspecified vulnerability in Adobe Flash Player 9.0.48.0 and earlier might al...
oval:org.mitre.oval:def:24929 Unspecified vulnerability in Adobe Flash Player 9.0.48.0 and earlier might al...
oval:org.mitre.oval:def:11069 Adobe Flash Player 9.x up to 9.0.48.0, 8.x up to 8.0.35.0, and 7.x up to 7.0....
oval:org.mitre.oval:def:24909 Adobe Flash Player 9.x up to 9.0.48.0, 8.x up to 8.0.35.0, and 7.x up to 7.0....
oval:org.mitre.oval:def:10210 Multiple cross-site scripting (XSS) vulnerabilities in Adobe Flash Player 9.x...
oval:org.mitre.oval:def:24545 Multiple cross-site scripting (XSS) vulnerabilities in Adobe Flash Player 9.x...
oval:org.mitre.oval:def:9546 Adobe Flash Player 9.x up to 9.0.48.0, 8.x up to 8.0.35.0, and 7.x up to 7.0....
oval:org.mitre.oval:def:24621 Adobe Flash Player 9.x up to 9.0.48.0, 8.x up to 8.0.35.0, and 7.x up to 7.0....
oval:org.mitre.oval:def:10519 Adobe Flash Player 9.x up to 9.0.48.0, 8.x up to 8.0.35.0, and 7.x up to 7.0....
oval:org.mitre.oval:def:22648 ELSA-2007:1126: flash-plugin security update (Critical)

SAINT Exploits

Description Link
Adobe Flash Player MP4 Copyright Statement Overflow More info here
Adobe Flash Player OpenType Font Integer Overflow More info here
Adobe Flash Player MP4 Sequence Parameter Set Processing More info here
Adobe Reader Flash AVM2 Memory Corruption More info here
Adobe Flash Player Flash Content Parsing Code Execution More info here
Adobe Pixel Shader More info here
Adobe Flash Player SWF Content Regular Expression Heap Overflow More info here
Adobe Flash Player ActionScript Function Arguments Code Execution More info here
Adobe Flash Player callMethod Bytecode Memory Corruption More info here
Adobe Reader authplay.dll newfunction Memory Corruption More info here
Adobe Flash Player authplay.dll vulnerability More info here
Adobe Flash Player Object Confusion Code Execution More info here

Open Source Vulnerability Database (OSVDB)

This CPE Product have more than 25 Relations. If you want to see a complete summary for this CPE, please contact us.
id Description
77619 Adobe Flash Player SWF File Handling Unspecified Remote Code Execution (2011-...
77575 Adobe Flash Player SWF File Handling Unspecified Remote Code Execution (2011-...
77029 Adobe Flash Player Unspecified Remote Memory Corruption (2011-2460)
77028 Adobe Flash Player Unspecified Remote Memory Corruption (2011-2459)
77027 Adobe Flash Player for IE Unspecified Same Origin Policy Bypass
77026 Adobe Flash Player Unspecified Remote Overflow (2011-2457)
77025 Adobe Flash Player Unspecified Remote Overflow (2011-2456)
77024 Adobe Flash Player Unspecified Remote Memory Corruption (2011-2455)
77023 Adobe Flash Player Unspecified Remote Memory Corruption (2011-2454)
77022 Adobe Flash Player Unspecified Remote Memory Corruption (2011-2453)
77021 Adobe Flash Player Unspecified Remote Memory Corruption (2011-2452)
77020 Adobe Flash Player Unspecified Remote Memory Corruption (2011-2451)
77019 Adobe Flash Player Unspecified Remote Overflow (2011-2450)
77018 Adobe Flash Player Unspecified Remote Memory Corruption (2011-2445)
75630 Adobe Flash Player Media Streaming Logic Memory Corruption
75629 Adobe Flash Player Security Control Bypass Information Disclosure
75628 Adobe Flash Player Logic Error Unspecified Memory Corruption
75627 Adobe Flash Player AVM Function Parameter Handling Overflow
75626 Adobe Flash Player AVM2 Function Parameter Handling Overflow
75625 Adobe Flash Player Unspecified XSS
75201 Adobe Flash Player SWF File Handling Arbitrary Code Execution (400 Taviso Bugs)
74444 Adobe Flash Player Unspecified Memory Corruption (2011-2425)
74443 Adobe Flash Player Unspecified Memory Corruption (2011-2417)
74442 Adobe Flash Player Unspecified Overflow (2011-2416)
74441 Adobe Flash Player Unspecified Overflow (2011-2415)

ExploitDB Exploits

id Description
33333 Adobe Flash Player Shader Buffer Overflow
33212 Adobe Flash Player Integer Underflow Remote Code Execution
33095 Adobe Flash Player Type Confusion Remote Code Execution
32959 Adobe Flash Player Regular Expression Heap Overflow
20624 Adobe Flash Player 11.3 Font Parsing Code Execution
19369 Adobe Flash Player Object Type Confusion
19295 Adobe Flash Player AVM Verification Logic Array Indexing Code Execution
18572 Adobe Flash Player .mp4 'cprt' Overflow"
18479 Adobe Flash Player MP4 SequenceParameterSetNALUnit Buffer Overflow
18437 Adobe Flash Player MP4 SequenceParameterSetNALUnit Remote Code Execution Exploit
17473 Adobe Reader X Atom Type Confusion Vulnerability Exploit
17187 Adobe Flash Player < 10.1.53 .64 Action Script Type Confusion Exploit (DEP...
17175 Adobe Flash Player 10.2.153.1 SWF Memory Corruption Vulnerability
17027 Adobe Flash Player AVM Bytecode Verification
16687 Adobe Flash Player "newfunction" Invalid Pointer Use
16667 Adobe Flash Player "Button" Remote Code Execution
16614 Adobe Flash Player "newfunction" Invalid Pointer Use
15426 Adobe Flash ActionIf Integer Denial of Service Vulnerability
14853 MOAUB #1 - Adobe Acrobat Reader and Flash Player
13787 Adobe Flash and Reader - 0day Exploit PoC (from the wild)

OpenVAS Exploits

This CPE Product have more than 25 Relations. If you want to see a complete summary for this CPE, please contact us.
id Description
2013-03-28 Name : Adobe Air Multiple Vulnerabilities - December12 (Mac OS X)
File : nvt/gb_adobe_air_mult_vuln_dec12_macosx.nasl
2013-03-28 Name : Adobe Air Multiple Vulnerabilities - December12 (Windows)
File : nvt/gb_adobe_air_mult_vuln_dec12_win.nasl
2013-03-28 Name : Adobe Air Multiple Vulnerabilities - November12 (Mac OS X)
File : nvt/gb_adobe_air_mult_vuln_nov12_macosx.nasl
2013-03-28 Name : Adobe Air Multiple Vulnerabilities - November12 (Windows)
File : nvt/gb_adobe_air_mult_vuln_nov12_win.nasl
2013-03-28 Name : Adobe Air Multiple Vulnerabilities - October 12 (Mac OS X)
File : nvt/gb_adobe_air_mult_vuln_oct12_macosx.nasl
2013-03-28 Name : Adobe Air Multiple Vulnerabilities - October 12 (Windows)
File : nvt/gb_adobe_air_mult_vuln_oct12_win.nasl
2012-12-14 Name : Adobe Flash Player Multiple Vulnerabilities - December12 (Linux)
File : nvt/gb_adobe_flash_player_mult_vuln_dec12_lin.nasl
2012-12-14 Name : Adobe Flash Player Multiple Vulnerabilities - December12 (Mac OS X)
File : nvt/gb_adobe_prdts_mult_vuln_dec12_macosx.nasl
2012-12-14 Name : Adobe Flash Player Multiple Vulnerabilities - December12 (Windows)
File : nvt/gb_adobe_prdts_mult_vuln_dec12_win.nasl
2012-12-13 Name : SuSE Update for flash-player openSUSE-SU-2012:0427-1 (flash-player)
File : nvt/gb_suse_2012_0427_1.nasl
2012-12-13 Name : SuSE Update for update openSUSE-SU-2012:0594-1 (update)
File : nvt/gb_suse_2012_0594_1.nasl
2012-12-13 Name : SuSE Update for flash-player openSUSE-SU-2012:0723-1 (flash-player)
File : nvt/gb_suse_2012_0723_1.nasl
2012-12-13 Name : SuSE Update for flash-player openSUSE-SU-2012:0996-1 (flash-player)
File : nvt/gb_suse_2012_0996_1.nasl
2012-12-13 Name : SuSE Update for flash-player openSUSE-SU-2012:1324-1 (flash-player)
File : nvt/gb_suse_2012_1324_1.nasl
2012-12-13 Name : SuSE Update for flash-player openSUSE-SU-2012:1480-1 (flash-player)
File : nvt/gb_suse_2012_1480_1.nasl
2012-11-26 Name : FreeBSD Ports: linux-f10-flashplugin
File : nvt/freebsd_linux-f10-flashplugin4.nasl
2012-11-26 Name : FreeBSD Ports: linux-f10-flashplugin
File : nvt/freebsd_linux-f10-flashplugin5.nasl
2012-11-08 Name : Adobe Flash Player Multiple Vulnerabilities - November12 (Linux)
File : nvt/gb_adobe_flash_player_mult_vuln_nov12_lin.nasl
2012-11-08 Name : Adobe Flash Player Multiple Vulnerabilities - November12 (Mac OS X)
File : nvt/gb_adobe_prdts_mult_vuln_nov12_macosx.nasl
2012-11-08 Name : Adobe Flash Player Multiple Vulnerabilities - November12 (Windows)
File : nvt/gb_adobe_prdts_mult_vuln_nov12_win.nasl
2012-10-15 Name : Adobe Flash Player Multiple Vulnerabilities - Oct12 (Linux)
File : nvt/gb_adobe_flash_player_mult_vuln_oct12_lin.nasl
2012-10-15 Name : Adobe Flash Player Multiple Vulnerabilities - October 12 (Mac OS X)
File : nvt/gb_adobe_prdts_mult_vuln_oct12_macosx.nasl
2012-10-15 Name : Adobe Flash Player Multiple Vulnerabilities - October 12 (Windows)
File : nvt/gb_adobe_prdts_mult_vuln_oct12_win.nasl
2012-09-15 Name : Gentoo Security Advisory GLSA 201209-01 (adobe-flash)
File : nvt/glsa_201209_01.nasl
2012-09-03 Name : Adobe Flash Player Multiple Vulnerabilities - Sep12 (Linux)
File : nvt/gb_adobe_flash_player_mult_vuln_sep12_lin.nasl

Information Assurance Vulnerability Management (IAVM)

id Description
2015-A-0221 Multiple Vulnerabilities in Adobe Flash Player and AIR
Severity: Category I - VMSKEY: V0061469
2014-A-0093 Multiple Vulnerabilities in Adobe Flash Player and AIR
Severity: Category I - VMSKEY: V0052949
2014-A-0078 Multiple Vulnerabilities in Adobe Flash Player and AIR
Severity: Category I - VMSKEY: V0052485
2014-A-0069 Multiple Vulnerabilities in Adobe Flash Player and AIR
Severity: Category I - VMSKEY: V0050437
2014-A-0060 Adobe Flash Player Buffer Overflow Vulnerability
Severity: Category I - VMSKEY: V0050013
2014-A-0047 Multiple Vulnerabilities in Adobe Flash Player and AIR
Severity: Category I - VMSKEY: V0048681
2014-A-0034 Multiple Vulnerabilities in Adobe Flash Player
Severity: Category I - VMSKEY: V0046181
2014-A-0029 Multiple Vulnerabilities in Adobe Flash Player and AIR
Severity: Category I - VMSKEY: V0044537
2014-A-0020 Adobe Flash Player Remote Code Execution Vulnerability
Severity: Category I - VMSKEY: V0043920
2014-A-0001 Multiple Vulnerabilities in Adobe Flash Player and AIR
Severity: Category I - VMSKEY: V0043404
2013-A-0229 Multiple Vulnerabilities in Adobe Flash Player
Severity: Category I - VMSKEY: V0042595
2013-A-0209 Multiple Vulnerabilities in Adobe Flash Player
Severity: Category I - VMSKEY: V0042292
2013-A-0168 Multiple Vulnerabilities In Adobe Flash Player
Severity: Category I - VMSKEY: V0040297
2012-B-0048 Multiple Vulnerabilities in HP Systems Insight Manager
Severity: Category I - VMSKEY: V0032178
2008-B-0011 Multiple Adobe Dreamweaver CS3 and Adobe Acrobat Connect SWF Cross-Site Scrip...
Severity: Category II - VMSKEY: V0015694

Snort® IPS/IDS

This CPE Product have more than 25 Relations. If you want to see a complete summary for this CPE, please contact us.
Date Description
2014-01-10 ShockwaveFlash.ShockwaveFlash ActiveX clsid unicode access
RuleID : 7979 - Type : WEB-ACTIVEX - Revision : 10
2014-01-10 ShockwaveFlash.ShockwaveFlash ActiveX clsid access
RuleID : 7978 - Type : BROWSER-PLUGINS - Revision : 15
2019-10-29 Adobe Flash Player ActiveX same origin method execution attempt
RuleID : 51648 - Type : FILE-FLASH - Revision : 1
2019-10-29 Adobe Flash Player use-after-free attempt
RuleID : 51644 - Type : FILE-FLASH - Revision : 1
2019-10-29 Adobe Flash Player use-after-free attempt
RuleID : 51643 - Type : FILE-FLASH - Revision : 1
2019-09-24 Adobe Flash Player malformed ATF heap overflow attempt
RuleID : 51226 - Type : FILE-FLASH - Revision : 1
2019-09-24 Adobe Flash Player malformed ATF heap overflow attempt
RuleID : 51225 - Type : FILE-FLASH - Revision : 1
2019-09-24 Adobe Texture Format file containing invalid texture definition memory corrup...
RuleID : 51224 - Type : FILE-OTHER - Revision : 1
2019-09-24 Adobe Texture Format file containing invalid texture definition memory corrup...
RuleID : 51223 - Type : FILE-OTHER - Revision : 1
2019-09-24 Adobe Flash Player ATF bitmap conversion heap overflow attempt
RuleID : 51222 - Type : FILE-FLASH - Revision : 1
2019-09-24 Adobe Flash Player ATF bitmap conversion heap overflow attempt
RuleID : 51221 - Type : FILE-FLASH - Revision : 1
2019-09-19 Adobe Flash player memory corruption attempt
RuleID : 51082 - Type : FILE-FLASH - Revision : 1
2019-09-19 Adobe Flash player memory corruption attempt
RuleID : 51081 - Type : FILE-FLASH - Revision : 1
2019-08-01 Adobe Flash Player TVSDK metadata use after free attempt
RuleID : 50537 - Type : FILE-FLASH - Revision : 1
2019-08-01 Adobe Flash Player TVSDK metadata use after free attempt
RuleID : 50536 - Type : FILE-FLASH - Revision : 1
2019-08-01 Adobe Flash Player TVSDK metadata use after free attempt
RuleID : 50535 - Type : FILE-FLASH - Revision : 1
2019-08-01 Adobe Flash Player TVSDK metadata use after free attempt
RuleID : 50534 - Type : FILE-FLASH - Revision : 1
2019-07-02 Adobe Flash Player use after free attempt
RuleID : 50268 - Type : FILE-FLASH - Revision : 1
2019-07-02 Adobe Flash Player use after free attempt
RuleID : 50267 - Type : FILE-FLASH - Revision : 1
2019-06-25 Adobe Flash Player writeExternal type confusion attempt
RuleID : 50185 - Type : FILE-FLASH - Revision : 1
2019-06-20 Adobe Flash Player out-of-bounds read attempt
RuleID : 50140 - Type : FILE-FLASH - Revision : 1
2019-06-20 Adobe Flash Player out-of-bounds read attempt
RuleID : 50139 - Type : FILE-FLASH - Revision : 1
2019-05-07 Adobe Flash Player PCRE control character denial of service attempt
RuleID : 49656 - Type : FILE-FLASH - Revision : 1
2019-05-07 Adobe Flash Player PCRE control character denial of service attempt
RuleID : 49655 - Type : FILE-FLASH - Revision : 1
2019-05-07 Adobe Flash Player PCRE control character denial of service attempt
RuleID : 49654 - Type : FILE-FLASH - Revision : 1

Nessus® Vulnerability Scanner

This CPE Product have more than 25 Relations. If you want to see a complete summary for this CPE, please contact us.
id Description
2018-12-07 Name: The remote FreeBSD host is missing a security-related update.
File: freebsd_pkg_49cbe200f92a11e8a89dd43d7ef03aa6.nasl - Type: ACT_GATHER_INFO
2018-12-06 Name: The remote Windows host has a browser plugin installed that is affected by mu...
File: flash_player_apsb18-42.nasl - Type: ACT_GATHER_INFO
2018-12-06 Name: The remote macOS or Mac OSX host has a browser plugin installed that is affec...
File: macosx_flash_player_apsb18-42.nasl - Type: ACT_GATHER_INFO
2018-11-21 Name: The remote Windows host has a browser plugin installed that is affected by an...
File: flash_player_apsb18-44.nasl - Type: ACT_GATHER_INFO
2018-11-21 Name: The remote FreeBSD host is missing a security-related update.
File: freebsd_pkg_8f128c72ecf911e8aa006451062f0f7a.nasl - Type: ACT_GATHER_INFO
2018-11-21 Name: The remote macOS or Mac OSX host has a browser plugin installed that is affec...
File: macosx_flash_player_apsb18-44.nasl - Type: ACT_GATHER_INFO
2018-11-14 Name: The remote FreeBSD host is missing a security-related update.
File: freebsd_pkg_b69292e8e79811e8ae076451062f0f7a.nasl - Type: ACT_GATHER_INFO
2018-11-13 Name: The remote Windows host has a browser plugin installed that is affected by mu...
File: flash_player_apsb18-39.nasl - Type: ACT_GATHER_INFO
2018-11-13 Name: The remote macOS or Mac OSX host has a browser plugin installed that is affec...
File: macosx_flash_player_apsb18-39.nasl - Type: ACT_GATHER_INFO
2018-09-12 Name: The remote FreeBSD host is missing a security-related update.
File: freebsd_pkg_f9d73a20b5f011e8b1da6451062f0f7a.nasl - Type: ACT_GATHER_INFO
2018-09-11 Name: The remote Windows host has a browser plugin installed that is affected by an...
File: flash_player_apsb18-31.nasl - Type: ACT_GATHER_INFO
2018-09-11 Name: The remote macOS or Mac OSX host has a browser plugin installed that is affec...
File: macosx_flash_player_apsb18-31.nasl - Type: ACT_GATHER_INFO
2018-08-15 Name: The remote FreeBSD host is missing a security-related update.
File: freebsd_pkg_98b603c89ff311e8ad636451062f0f7a.nasl - Type: ACT_GATHER_INFO
2018-08-14 Name: The remote Windows host has a browser plugin installed that is affected by mu...
File: flash_player_apsb18-25.nasl - Type: ACT_GATHER_INFO
2018-08-14 Name: The remote macOS or Mac OSX host has a browser plugin installed that is affec...
File: macosx_flash_player_apsb18-25.nasl - Type: ACT_GATHER_INFO
2018-07-12 Name: The remote FreeBSD host is missing a security-related update.
File: freebsd_pkg_e78732b2852811e89c426451062f0f7a.nasl - Type: ACT_GATHER_INFO
2018-07-10 Name: The remote Windows host has a browser plugin installed that is affected by mu...
File: flash_player_apsb18-24.nasl - Type: ACT_GATHER_INFO
2018-07-10 Name: The remote macOS or Mac OSX host has a browser plugin installed that is affec...
File: macosx_flash_player_apsb18-24.nasl - Type: ACT_GATHER_INFO
2018-06-14 Name: The remote Gentoo host is missing one or more security-related patches.
File: gentoo_GLSA-201806-02.nasl - Type: ACT_GATHER_INFO
2018-06-08 Name: The remote FreeBSD host is missing a security-related update.
File: freebsd_pkg_2dde5a566ab111e8b6396451062f0f7a.nasl - Type: ACT_GATHER_INFO
2018-06-07 Name: The remote Windows host has a browser plugin installed that is affected by mu...
File: flash_player_apsb18-19.nasl - Type: ACT_GATHER_INFO
2018-06-07 Name: The remote macOS or Mac OSX host has a browser plugin installed that is affec...
File: macosx_flash_player_apsb18-19.nasl - Type: ACT_GATHER_INFO
2018-05-09 Name: The remote FreeBSD host is missing a security-related update.
File: freebsd_pkg_9558d49c534c11e88177d43d7ef03aa6.nasl - Type: ACT_GATHER_INFO
2018-05-08 Name: The remote Windows host has a browser plugin installed that is affected by mu...
File: flash_player_apsb18-16.nasl - Type: ACT_GATHER_INFO
2018-05-08 Name: The remote macOS or Mac OSX host has a browser plugin installed that is affec...
File: macosx_flash_player_apsb18-16.nasl - Type: ACT_GATHER_INFO