Executive Summary

Summary
Title Libidn vulnerabilities
Informations
Name USN-3068-1 First vendor Publication 2016-08-24
Vendor Ubuntu Last vendor Modification 2016-08-24
Severity (Vendor) N/A Revision N/A

Security-Database Scoring CVSS v3

Cvss vector : N/A
Overall CVSS Score NA
Base Score NA Environmental Score NA
impact SubScore NA Temporal Score NA
Exploitabality Sub Score NA
 
Calculate full CVSS 3.0 Vectors scores

Security-Database Scoring CVSS v2

Cvss vector : (AV:N/AC:L/Au:N/C:P/I:P/A:P)
Cvss Base Score 7.5 Attack Range Network
Cvss Impact Score 6.4 Attack Complexity Low
Cvss Expoit Score 10 Authentication None Required
Calculate full CVSS 2.0 Vectors scores

Detail

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 16.04 LTS - Ubuntu 14.04 LTS - Ubuntu 12.04 LTS

Summary:

Several security issues were fixed in Libidn.

Software Description: - libidn: implementation of IETF IDN specifications

Details:

Thijs Alkemade, Gustavo Grieco, Daniel Stenberg, and Nikos Mavrogiannopoulos discovered that Libidn incorrectly handled invalid UTF-8 characters. A remote attacker could use this issue to cause Libidn to crash, resulting in a denial of service, or possibly disclose sensitive memory. This issue only applied to Ubuntu 12.04 LTS and Ubuntu 14.04 LTS. (CVE-2015-2059)

Hanno Böck discovered that Libidn incorrectly handled certain input. A remote attacker could possibly use this issue to cause Libidn to crash, resulting in a denial of service. (CVE-2015-8948, CVE-2016-6262, CVE-2016-6261, CVE-2016-6263)

Update instructions:

The problem can be corrected by updating your system to the following package versions:

Ubuntu 16.04 LTS:
libidn11 1.32-3ubuntu1.1

Ubuntu 14.04 LTS:
libidn11 1.28-1ubuntu2.1

Ubuntu 12.04 LTS:
libidn11 1.23-2ubuntu0.1

In general, a standard system update will make all the necessary changes.

References:
http://www.ubuntu.com/usn/usn-3068-1
CVE-2015-2059, CVE-2015-8948, CVE-2016-6261, CVE-2016-6262,
CVE-2016-6263

Package Information:
https://launchpad.net/ubuntu/+source/libidn/1.32-3ubuntu1.1
https://launchpad.net/ubuntu/+source/libidn/1.28-1ubuntu2.1
https://launchpad.net/ubuntu/+source/libidn/1.23-2ubuntu0.1

Original Source

Url : http://www.ubuntu.com/usn/USN-3068-1

CWE : Common Weakness Enumeration

% Id Name
80 % CWE-125 Out-of-bounds Read
20 % CWE-119 Failure to Constrain Operations within the Bounds of a Memory Buffer

CPE : Common Platform Enumeration

TypeDescriptionCount
Application 2
Os 3
Os 2
Os 1
Os 2

Nessus® Vulnerability Scanner

Date Description
2016-11-15 Name : The remote Fedora host is missing a security update.
File : fedora_2016-f99c0a8b69.nasl - Type : ACT_GATHER_INFO
2016-09-13 Name : The remote SUSE host is missing one or more security updates.
File : suse_SU-2016-2291-1.nasl - Type : ACT_GATHER_INFO
2016-09-12 Name : The remote openSUSE host is missing a security update.
File : openSUSE-2016-1067.nasl - Type : ACT_GATHER_INFO
2016-09-08 Name : The remote SUSE host is missing one or more security updates.
File : suse_SU-2016-2226-1.nasl - Type : ACT_GATHER_INFO
2016-09-02 Name : The remote SUSE host is missing one or more security updates.
File : suse_SU-2016-2079-1.nasl - Type : ACT_GATHER_INFO
2016-09-02 Name : The remote Debian host is missing a security-related update.
File : debian_DSA-3658.nasl - Type : ACT_GATHER_INFO
2016-08-25 Name : The remote Ubuntu host is missing a security-related patch.
File : ubuntu_USN-3068-1.nasl - Type : ACT_GATHER_INFO
2016-08-24 Name : The remote openSUSE host is missing a security update.
File : openSUSE-2016-1014.nasl - Type : ACT_GATHER_INFO
2016-08-09 Name : The remote Fedora host is missing a security update.
File : fedora_2016-610fe5f5f8.nasl - Type : ACT_GATHER_INFO
2016-08-05 Name : The remote openSUSE host is missing a security update.
File : openSUSE-2016-925.nasl - Type : ACT_GATHER_INFO
2016-08-03 Name : The remote Debian host is missing a security update.
File : debian_DLA-582.nasl - Type : ACT_GATHER_INFO
2016-08-01 Name : The remote FreeBSD host is missing a security-related update.
File : freebsd_pkg_cb5189eb572f11e6b334002590263bf5.nasl - Type : ACT_GATHER_INFO
2016-07-29 Name : The remote Slackware host is missing a security update.
File : Slackware_SSA_2016-210-01.nasl - Type : ACT_GATHER_INFO
2016-07-25 Name : The remote Fedora host is missing a security update.
File : fedora_2016-42514bee97.nasl - Type : ACT_GATHER_INFO
2016-05-18 Name : The remote Debian host is missing a security update.
File : debian_DLA-476.nasl - Type : ACT_GATHER_INFO
2016-05-16 Name : The remote Debian host is missing a security-related update.
File : debian_DSA-3578.nasl - Type : ACT_GATHER_INFO
2015-08-17 Name : The remote Debian host is missing a security update.
File : debian_DLA-291.nasl - Type : ACT_GATHER_INFO
2015-07-29 Name : The remote Fedora host is missing a security update.
File : fedora_2015-11621.nasl - Type : ACT_GATHER_INFO
2015-07-29 Name : The remote Fedora host is missing a security update.
File : fedora_2015-11562.nasl - Type : ACT_GATHER_INFO
2015-07-24 Name : The remote FreeBSD host is missing a security-related update.
File : freebsd_pkg_4caf01e230e611e5a4a5002590263bf5.nasl - Type : ACT_GATHER_INFO
2015-07-20 Name : The remote Debian host is missing a security update.
File : debian_DLA-277.nasl - Type : ACT_GATHER_INFO
2015-07-20 Name : The remote openSUSE host is missing a security update.
File : openSUSE-2015-497.nasl - Type : ACT_GATHER_INFO

Alert History

If you want to see full details history, please login or register.
0
1
2
Date Informations
2016-09-08 05:21:50
  • Multiple Updates
2016-08-26 13:26:07
  • Multiple Updates
2016-08-24 17:21:25
  • First insertion