Executive Summary

Informations
Name CVE-2014-1594 First vendor Publication 2014-12-11
Vendor Cve Last vendor Modification 2016-12-24

Security-Database Scoring CVSS v3

Cvss vector : N/A
Overall CVSS Score NA
Base Score NA Environmental Score NA
impact SubScore NA Temporal Score NA
Exploitabality Sub Score NA
 
Calculate full CVSS 3.0 Vectors scores

Security-Database Scoring CVSS v2

Cvss vector : (AV:N/AC:M/Au:N/C:P/I:P/A:P)
Cvss Base Score 6.8 Attack Range Network
Cvss Impact Score 6.4 Attack Complexity Medium
Cvss Expoit Score 8.6 Authentication None Required
Calculate full CVSS 2.0 Vectors scores

Detail

Mozilla Firefox before 34.0, Firefox ESR 31.x before 31.3, Thunderbird before 31.3, and SeaMonkey before 2.31 might allow remote attackers to execute arbitrary code by leveraging an incorrect cast from the BasicThebesLayer data type to the BasicContainerLayer data type.

Original Source

Url : http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-1594

CWE : Common Weakness Enumeration

% Id Name
100 % CWE-20 Improper Input Validation

OVAL Definitions

Definition Id: oval:org.mitre.oval:def:27983
 
Oval ID: oval:org.mitre.oval:def:27983
Title: RHSA-2014:1919 -- firefox security update (Critical)
Description: Mozilla Firefox is an open source web browser. XULRunner provides the XUL Runtime environment for Mozilla Firefox. Several flaws were found in the processing of malformed web content. A web page containing malicious content could cause Firefox to crash or, potentially, execute arbitrary code with the privileges of the user running Firefox. (CVE-2014-1587, CVE-2014-1590, CVE-2014-1592, CVE-2014-1593) A flaw was found in the Alarm API, which could allow applications to schedule actions to be run in the future. A malicious web application could use this flaw to bypass the same-origin policy. (CVE-2014-1594) This update disables SSL 3.0 support by default in Firefox. Details on how to re-enable SSL 3.0 support are available at: <A HREF="https://access.redhat.com/articles/1283153">https://access.redhat.com/articles/1283153</A> Red Hat would like to thank the Mozilla project for reporting these issues. Upstream acknowledges Gary Kwong, Randell Jesup, Nils Ohlmeier, Jesse Ruderman, Max Jonas Werner, Joe Vennix, Berend-Jan Wever, Abhishek Arya, and Boris Zbarsky as the original reporters of these issues. For technical details regarding these flaws, refer to the Mozilla security advisories for Firefox 31.3.0 ESR. You can find a link to the Mozilla advisories in the References section of this erratum. All Firefox users should upgrade to these updated packages, which contain Firefox version 31.3.0 ESR, which corrects these issues. After installing the update, Firefox must be restarted for the changes to take effect.
Family: unix Class: patch
Reference(s): RHSA-2014:1919
CESA-2014:1919-CentOS 5
CESA-2014:1919-CentOS 6
CESA-2014:1919-CentOS 7
CVE-2014-1587
CVE-2014-1590
CVE-2014-1592
CVE-2014-1593
CVE-2014-1594
Version: 3
Platform(s): Red Hat Enterprise Linux 5
Red Hat Enterprise Linux 6
Red Hat Enterprise Linux 7
CentOS Linux 5
CentOS Linux 6
CentOS Linux 7
Product(s): firefox
Definition Synopsis:
Definition Id: oval:org.mitre.oval:def:28112
 
Oval ID: oval:org.mitre.oval:def:28112
Title: ELSA-2014-1919 -- firefox security update (critical)
Description: [31.3.0-4.0.1] - Add firefox-oracle-default-prefs.js and firefox-oracle-default-bookmarks.html and remove the corresponding Red Hat ones [31.3.0-4] - Update to 31.3.0 ESR Build 2 - Fix for geolocation API (rhbz#1063739) [31.2.0-5] - splice workaround (rhbz#1150082) [31.2.0-4] - ppc build fix (rhbz#1151959)
Family: unix Class: patch
Reference(s): ELSA-2014-1919
CVE-2014-1587
CVE-2014-1590
CVE-2014-1592
CVE-2014-1593
CVE-2014-1594
Version: 3
Platform(s): Oracle Linux 5
Oracle Linux 6
Oracle Linux 7
Product(s): firefox
Definition Synopsis:
Definition Id: oval:org.mitre.oval:def:28254
 
Oval ID: oval:org.mitre.oval:def:28254
Title: ELSA-2014-1924 -- thunderbird security update (important)
Description: [31.3.0-1.0.1.el6_6] - Replaced thunderbird-redhat-default-prefs.js with thunderbird-oracle-default-prefs.js [31.3.0-1] - Update to 31.3.0
Family: unix Class: patch
Reference(s): ELSA-2014-1924
CVE-2014-1587
CVE-2014-1590
CVE-2014-1592
CVE-2014-1593
CVE-2014-1594
Version: 3
Platform(s): Oracle Linux 6
Product(s): thunderbird
Definition Synopsis:
Definition Id: oval:org.mitre.oval:def:28317
 
Oval ID: oval:org.mitre.oval:def:28317
Title: DSA-3092-1 -- icedove security update
Description: Multiple security issues have been found in Icedove, Debian's version of the Mozilla Thunderbird mail and news client: Multiple memory safety errors, buffer overflows, use-after-frees and other implementation errors may lead to the execution of arbitrary code, the bypass of security restrictions or denial of service.
Family: unix Class: patch
Reference(s): DSA-3092-1
CVE-2014-1587
CVE-2014-1590
CVE-2014-1592
CVE-2014-1593
CVE-2014-1594
Version: 3
Platform(s): Debian GNU/Linux 7.0
Debian GNU/kFreeBSD 7.0
Product(s): icedove
Definition Synopsis:
Definition Id: oval:org.mitre.oval:def:28336
 
Oval ID: oval:org.mitre.oval:def:28336
Title: USN-2428-1 -- Thunderbird vulnerabilities
Description: Gary Kwong, Randell Jesup, Nils Ohlmeier, Jesse Ruderman, and Max Jonas Werner discovered multiple memory safety issues in Thunderbird. If a user were tricked in to opening a specially crafted message with scripting enabled, an attacker could potentially exploit these to cause a denial of service via application crash, or execute arbitrary code with the privileges of the user invoking Thunderbird. (<a href="http://people.ubuntu.com/~ubuntu-security/cve/CVE-2014-1587">CVE-2014-1587</a>) Joe Vennix discovered a crash when using XMLHttpRequest in some circumstances. If a user were tricked in to opening a specially crafted message with scripting enabled, an attacker could potentially exploit this to cause a denial of service. (<a href="http://people.ubuntu.com/~ubuntu-security/cve/CVE-2014-1590">CVE-2014-1590</a>) Berend-Jan Wever discovered a use-after-free during HTML parsing. If a user were tricked in to opening a specially crafted message with scripting enabled, an attacker could potentially exploit this to cause a denial of service via application crash or execute arbitrary code with the privileges of the user invoking Thunderbird. (<a href="http://people.ubuntu.com/~ubuntu-security/cve/CVE-2014-1592">CVE-2014-1592</a>) Abhishek Arya discovered a buffer overflow when parsing media content. If a user were tricked in to opening a specially crafted message with scripting enabled, an attacker could potentially exploit this to cause a denial of service via application crash or execute arbitrary code with the privileges of the user invoking Thunderbird. (<a href="http://people.ubuntu.com/~ubuntu-security/cve/CVE-2014-1593">CVE-2014-1593</a>) Byoungyoung Lee, Chengyu Song, and Taesoo Kim discovered a bad cast in the compositor. If a user were tricked in to opening a specially crafted message, an attacker could potentially exploit this to cause undefined behaviour, a denial of service via application crash or execute abitrary code with the privileges of the user invoking Thunderbird. (<a href="http://people.ubuntu.com/~ubuntu-security/cve/CVE-2014-1594">CVE-2014-1594</a>)
Family: unix Class: patch
Reference(s): USN-2428-1
CVE-2014-1587
CVE-2014-1590
CVE-2014-1592
CVE-2014-1593
CVE-2014-1594
Version: 5
Platform(s): Ubuntu 14.10
Ubuntu 14.04
Ubuntu 12.04
Product(s): thunderbird
Definition Synopsis:
Definition Id: oval:org.mitre.oval:def:28351
 
Oval ID: oval:org.mitre.oval:def:28351
Title: USN-2424-1 -- Firefox vulnerabilities
Description: Gary Kwong, Randell Jesup, Nils Ohlmeier, Jesse Ruderman, Max Jonas Werner, Christian Holler, Jon Coppeard, Eric Rahm, Byron Campen, Eric Rescorla, and Xidorn Quan discovered multiple memory safety issues in Firefox. If a user were tricked in to opening a specially crafted website, an attacker could potentially exploit these to cause a denial of service via application crash, or execute arbitrary code with the privileges of the user invoking Firefox. (<a href="http://people.ubuntu.com/~ubuntu-security/cve/CVE-2014-1587">CVE-2014-1587</a>, <a href="http://people.ubuntu.com/~ubuntu-security/cve/CVE-2014-1588">CVE-2014-1588</a>) Cody Crews discovered a way to trigger chrome-level XBL bindings from web content in some circumstances. If a user were tricked in to opening a specially crafted website, an attacker could potentially exploit this to bypass security restrictions. (<a href="http://people.ubuntu.com/~ubuntu-security/cve/CVE-2014-1589">CVE-2014-1589</a>) Joe Vennix discovered a crash when using XMLHttpRequest in some circumstances. If a user were tricked in to opening a specially crafted website, an attacker could potentially exploit this to cause a denial of service. (<a href="http://people.ubuntu.com/~ubuntu-security/cve/CVE-2014-1590">CVE-2014-1590</a>) Muneaki Nishimura discovered that CSP violation reports did not remove path information in some circumstances. If a user were tricked in to opening a specially crafted website, an attacker could potentially exploit this to obtain sensitive information. (<a href="http://people.ubuntu.com/~ubuntu-security/cve/CVE-2014-1591">CVE-2014-1591</a>) Berend-Jan Wever discovered a use-after-free during HTML parsing. If a user were tricked in to opening a specially crafted website, an attacker could potentially exploit this to cause a denial of service via application crash or execute arbitrary code with the privileges of the user invoking Firefox. (<a href="http://people.ubuntu.com/~ubuntu-security/cve/CVE-2014-1592">CVE-2014-1592</a>) Abhishek Arya discovered a buffer overflow when parsing media content. If a user were tricked in to opening a specially crafted website, an attacker could potentially exploit this to cause a denial of service via application crash or execute arbitrary code with the privileges of the user invoking Firefox. (<a href="http://people.ubuntu.com/~ubuntu-security/cve/CVE-2014-1593">CVE-2014-1593</a>) Byoungyoung Lee, Chengyu Song, and Taesoo Kim discovered a bad cast in the compositor. If a user were tricked in to opening a specially crafted website, an attacker could potentially exploit this to cause undefined behaviour, a denial of service via application crash or execute abitrary code with the privileges of the user invoking Firefox. (<a href="http://people.ubuntu.com/~ubuntu-security/cve/CVE-2014-1594">CVE-2014-1594</a>)
Family: unix Class: patch
Reference(s): USN-2424-1
CVE-2014-1587
CVE-2014-1588
CVE-2014-1589
CVE-2014-1590
CVE-2014-1591
CVE-2014-1592
CVE-2014-1593
CVE-2014-1594
Version: 5
Platform(s): Ubuntu 14.10
Ubuntu 14.04
Ubuntu 12.04
Product(s): firefox
Definition Synopsis:
Definition Id: oval:org.mitre.oval:def:28442
 
Oval ID: oval:org.mitre.oval:def:28442
Title: DSA-3090-1 -- iceweasel security update
Description: Multiple security issues have been found in Iceweasel, Debian's version of the Mozilla Firefox web browser: Multiple memory safety errors, buffer overflows, use-after-frees and other implementation errors may lead to the execution of arbitrary code, the bypass of security restrictions or denial of service.
Family: unix Class: patch
Reference(s): DSA-3090-1
CVE-2014-1587
CVE-2014-1590
CVE-2014-1592
CVE-2014-1593
CVE-2014-1594
Version: 3
Platform(s): Debian GNU/Linux 7.0
Debian GNU/kFreeBSD 7.0
Product(s): iceweasel
Definition Synopsis:
Definition Id: oval:org.mitre.oval:def:28459
 
Oval ID: oval:org.mitre.oval:def:28459
Title: RHSA-2014:1924 -- thunderbird security update (Important)
Description: Mozilla Thunderbird is a standalone mail and newsgroup client. Several flaws were found in the processing of malformed web content. A web page containing malicious content could cause Thunderbird to crash or, potentially, execute arbitrary code with the privileges of the user running Thunderbird. (CVE-2014-1587, CVE-2014-1590, CVE-2014-1592, CVE-2014-1593) A flaw was found in the Alarm API, which could allow applications to schedule actions to be run in the future. A malicious web application could use this flaw to bypass the same-origin policy. (CVE-2014-1594) Note: All of the above issues cannot be exploited by a specially crafted HTML mail message as JavaScript is disabled by default for mail messages. They could be exploited another way in Thunderbird, for example, when viewing the full remote content of an RSS feed. This update disables SSL 3.0 support by default in Thunderbird. Details on how to re-enable SSL 3.0 support are available at: <A HREF="https://access.redhat.com/articles/1284233">https://access.redhat.com/articles/1284233</A> Red Hat would like to thank the Mozilla project for reporting these issues. Upstream acknowledges Gary Kwong, Randell Jesup, Nils Ohlmeier, Jesse Ruderman, Max Jonas Werner, Joe Vennix, Berend-Jan Wever, Abhishek Arya, and Boris Zbarsky as the original reporters of these issues. For technical details regarding these flaws, refer to the Mozilla security advisories for Thunderbird 31.3.0. You can find a link to the Mozilla advisories in the References section of this erratum. All Thunderbird users should upgrade to this updated package, which contains Thunderbird version 31.3.0, which corrects these issues. After installing the update, Thunderbird must be restarted for the changes to take effect.
Family: unix Class: patch
Reference(s): RHSA-2014:1924
CESA-2014:1924-CentOS 5
CESA-2014:1924-CentOS 6
CVE-2014-1587
CVE-2014-1590
CVE-2014-1592
CVE-2014-1593
CVE-2014-1594
Version: 3
Platform(s): Red Hat Enterprise Linux 5
Red Hat Enterprise Linux 6
CentOS Linux 5
CentOS Linux 6
Product(s): thunderbird
Definition Synopsis:

CPE : Common Platform Enumeration

TypeDescriptionCount
Application 371
Application 47
Application 217
Application 272

Nessus® Vulnerability Scanner

Date Description
2015-04-08 Name : The remote Gentoo host is missing one or more security-related patches.
File : gentoo_GLSA-201504-01.nasl - Type : ACT_GATHER_INFO
2014-12-18 Name : The remote openSUSE host is missing a security update.
File : openSUSE-2014-786.nasl - Type : ACT_GATHER_INFO
2014-12-18 Name : The remote openSUSE host is missing a security update.
File : openSUSE-2014-785.nasl - Type : ACT_GATHER_INFO
2014-12-18 Name : The remote openSUSE host is missing a security update.
File : openSUSE-2014-784.nasl - Type : ACT_GATHER_INFO
2014-12-15 Name : The remote SuSE 11 host is missing one or more security updates.
File : suse_11_firefox-201412-141208.nasl - Type : ACT_GATHER_INFO
2014-12-09 Name : The remote Debian host is missing a security-related update.
File : debian_DSA-3092.nasl - Type : ACT_GATHER_INFO
2014-12-08 Name : The remote openSUSE host is missing a security update.
File : openSUSE-2014-746.nasl - Type : ACT_GATHER_INFO
2014-12-05 Name : The remote Debian host is missing a security-related update.
File : debian_DSA-3090.nasl - Type : ACT_GATHER_INFO
2014-12-04 Name : The remote FreeBSD host is missing one or more security-related updates.
File : freebsd_pkg_7ae618709dd24884a2f2f19bb5784d09.nasl - Type : ACT_GATHER_INFO
2014-12-04 Name : The remote Ubuntu host is missing a security-related patch.
File : ubuntu_USN-2428-1.nasl - Type : ACT_GATHER_INFO
2014-12-04 Name : The remote Scientific Linux host is missing one or more security updates.
File : sl_20141202_thunderbird_on_SL6_x.nasl - Type : ACT_GATHER_INFO
2014-12-04 Name : The remote Scientific Linux host is missing one or more security updates.
File : sl_20141202_firefox_on_SL5_x.nasl - Type : ACT_GATHER_INFO
2014-12-04 Name : The remote Oracle Linux host is missing a security update.
File : oraclelinux_ELSA-2014-1919.nasl - Type : ACT_GATHER_INFO
2014-12-04 Name : The remote CentOS host is missing a security update.
File : centos_RHSA-2014-1924.nasl - Type : ACT_GATHER_INFO
2014-12-04 Name : The remote CentOS host is missing a security update.
File : centos_RHSA-2014-1919.nasl - Type : ACT_GATHER_INFO
2014-12-03 Name : The remote Ubuntu host is missing a security-related patch.
File : ubuntu_USN-2424-1.nasl - Type : ACT_GATHER_INFO
2014-12-03 Name : The remote Red Hat host is missing one or more security updates.
File : redhat-RHSA-2014-1924.nasl - Type : ACT_GATHER_INFO
2014-12-03 Name : The remote Red Hat host is missing one or more security updates.
File : redhat-RHSA-2014-1919.nasl - Type : ACT_GATHER_INFO
2014-12-03 Name : The remote Oracle Linux host is missing a security update.
File : oraclelinux_ELSA-2014-1924.nasl - Type : ACT_GATHER_INFO
2014-12-02 Name : The remote Mac OS X host contains a web browser that is affected by multiple ...
File : macosx_firefox_31_3_esr.nasl - Type : ACT_GATHER_INFO
2014-12-02 Name : The remote Windows host contains a mail client that is affected by multiple v...
File : mozilla_thunderbird_31_3.nasl - Type : ACT_GATHER_INFO
2014-12-02 Name : The remote Windows host contains a web browser that is affected by multiple v...
File : mozilla_firefox_34.nasl - Type : ACT_GATHER_INFO
2014-12-02 Name : The remote Windows host contains a web browser that is affected by multiple v...
File : mozilla_firefox_31_3_esr.nasl - Type : ACT_GATHER_INFO
2014-12-02 Name : The remote Mac OS X host contains a mail client that is affected by multiple ...
File : macosx_thunderbird_31_3.nasl - Type : ACT_GATHER_INFO
2014-12-02 Name : The remote Mac OS X host contains a web browser that is affected by multiple ...
File : macosx_firefox_34.nasl - Type : ACT_GATHER_INFO

Sources (Detail)

Source Url
BID http://www.securityfocus.com/bid/71396
CONFIRM http://www.mozilla.org/security/announce/2014/mfsa2014-89.html
http://www.oracle.com/technetwork/topics/security/bulletinapr2015-2511959.html
https://bugzilla.mozilla.org/show_bug.cgi?id=1074280
DEBIAN http://www.debian.org/security/2014/dsa-3090
http://www.debian.org/security/2014/dsa-3092
GENTOO https://security.gentoo.org/glsa/201504-01
SUSE http://lists.opensuse.org/opensuse-security-announce/2015-01/msg00024.html
http://lists.opensuse.org/opensuse-security-announce/2015-07/msg00031.html

Alert History

If you want to see full details history, please login or register.
0
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
Date Informations
2020-05-29 01:10:00
  • Multiple Updates
2020-05-23 01:51:16
  • Multiple Updates
2020-05-23 00:40:03
  • Multiple Updates
2019-06-25 12:06:02
  • Multiple Updates
2019-02-09 12:03:11
  • Multiple Updates
2019-01-31 12:02:20
  • Multiple Updates
2019-01-30 12:05:59
  • Multiple Updates
2018-12-04 12:05:43
  • Multiple Updates
2018-08-02 01:03:49
  • Multiple Updates
2018-06-29 12:02:21
  • Multiple Updates
2018-01-18 12:05:59
  • Multiple Updates
2017-11-22 12:05:58
  • Multiple Updates
2017-11-21 12:05:05
  • Multiple Updates
2016-12-24 09:24:02
  • Multiple Updates
2016-12-22 09:23:39
  • Multiple Updates
2016-11-29 00:24:52
  • Multiple Updates
2016-10-25 09:21:51
  • Multiple Updates
2016-06-30 21:37:32
  • Multiple Updates
2016-06-28 22:36:29
  • Multiple Updates
2016-04-27 00:16:17
  • Multiple Updates
2015-04-09 13:29:02
  • Multiple Updates
2015-03-18 09:26:36
  • Multiple Updates
2015-03-17 09:25:51
  • Multiple Updates
2014-12-19 13:24:33
  • Multiple Updates
2014-12-16 13:25:10
  • Multiple Updates
2014-12-12 00:21:41
  • Multiple Updates
2014-12-11 17:22:18
  • First insertion