Executive Summary

Informations
Name CVE-2011-1485 First vendor Publication 2011-05-31
Vendor Cve Last vendor Modification 2012-12-19

Security-Database Scoring CVSS v3

Cvss vector : N/A
Overall CVSS Score NA
Base Score NA Environmental Score NA
impact SubScore NA Temporal Score NA
Exploitabality Sub Score NA
 
Calculate full CVSS 3.0 Vectors scores

Security-Database Scoring CVSS v2

Cvss vector : (AV:L/AC:M/Au:N/C:C/I:C/A:C)
Cvss Base Score 6.9 Attack Range Local
Cvss Impact Score 10 Attack Complexity Medium
Cvss Expoit Score 3.4 Authentication None Required
Calculate full CVSS 2.0 Vectors scores

Detail

Race condition in the pkexec utility and polkitd daemon in PolicyKit (aka polkit) 0.96 allows local users to gain privileges by executing a setuid program from pkexec, related to the use of the effective user ID instead of the real user ID.

Original Source

Url : http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2011-1485

CWE : Common Weakness Enumeration

% Id Name
100 % CWE-362 Race Condition

OVAL Definitions

Definition Id: oval:org.mitre.oval:def:13758
 
Oval ID: oval:org.mitre.oval:def:13758
Title: USN-1117-1 -- policykit-1 vulnerability
Description: policykit-1: framework for managing administrative policies and privileges Local users could gain root access by using the pkexec tool in PolicyKit.
Family: unix Class: patch
Reference(s): USN-1117-1
CVE-2011-1485
Version: 5
Platform(s): Ubuntu 10.10
Ubuntu 9.10
Ubuntu 10.04
Product(s): policykit-1
Definition Synopsis:
Definition Id: oval:org.mitre.oval:def:15134
 
Oval ID: oval:org.mitre.oval:def:15134
Title: DSA-2319-1 policykit-1 -- race condition
Description: Neel Mehta discovered that a race condition in Policykit, a framework for managing administrative policies and privileges, allowed local users to elevate privileges by executing a setuid program from pkexec. The oldstable distribution does not contain the policykit-1 package.
Family: unix Class: patch
Reference(s): DSA-2319-1
CVE-2011-1485
Version: 5
Platform(s): Debian GNU/Linux 6.0
Debian GNU/kFreeBSD 6.0
Product(s): policykit-1
Definition Synopsis:
Definition Id: oval:org.mitre.oval:def:21671
 
Oval ID: oval:org.mitre.oval:def:21671
Title: RHSA-2011:0455: polkit security update (Important)
Description: Race condition in the pkexec utility and polkitd daemon in PolicyKit (aka polkit) 0.96 allows local users to gain privileges by executing a setuid program from pkexec, related to the use of the effective user ID instead of the real user ID.
Family: unix Class: patch
Reference(s): RHSA-2011:0455-01
CVE-2011-1485
Version: 4
Platform(s): Red Hat Enterprise Linux 6
Product(s): polkit
Definition Synopsis:
Definition Id: oval:org.mitre.oval:def:23637
 
Oval ID: oval:org.mitre.oval:def:23637
Title: ELSA-2011:0455: polkit security update (Important)
Description: Race condition in the pkexec utility and polkitd daemon in PolicyKit (aka polkit) 0.96 allows local users to gain privileges by executing a setuid program from pkexec, related to the use of the effective user ID instead of the real user ID.
Family: unix Class: patch
Reference(s): ELSA-2011:0455-01
CVE-2011-1485
Version: 6
Platform(s): Oracle Linux 6
Product(s): polkit
Definition Synopsis:
Definition Id: oval:org.mitre.oval:def:27796
 
Oval ID: oval:org.mitre.oval:def:27796
Title: DEPRECATED: ELSA-2011-0455 -- polkit security update (important)
Description: [0.96-2.el6_0.1] - Include fixes for CVE-2011-1485 - Resolves: #692941
Family: unix Class: patch
Reference(s): ELSA-2011-0455
CVE-2011-1485
Version: 4
Platform(s): Oracle Linux 6
Product(s): polkit
Definition Synopsis:

CPE : Common Platform Enumeration

TypeDescriptionCount
Application 1

ExploitDB Exploits

id Description
2014-10-20 Linux PolicyKit Race Condition Privilege Escalation
2011-10-08 pkexec Race Condition Privilege Escalation Exploit
2011-10-05 PolicyKit Pwnage: linux local privilege escalation on polkit-1 <= 0.101

OpenVAS Exploits

Date Description
2012-06-06 Name : RedHat Update for polkit RHSA-2011:0455-01
File : nvt/gb_RHSA-2011_0455-01_polkit.nasl
2012-04-30 Name : Gentoo Security Advisory GLSA 201204-06 (polkit)
File : nvt/glsa_201204_06.nasl
2011-10-16 Name : Debian Security Advisory DSA 2319-1 (policykit-1)
File : nvt/deb_2319_1.nasl
2011-05-17 Name : Fedora Update for polkit FEDORA-2011-5676
File : nvt/gb_fedora_2011_5676_polkit_fc14.nasl
2011-05-17 Name : Mandriva Update for polkit MDVSA-2011:086 (polkit)
File : nvt/gb_mandriva_MDVSA_2011_086.nasl
2011-05-10 Name : Ubuntu Update for policykit-1 USN-1117-1
File : nvt/gb_ubuntu_USN_1117_1.nasl
0000-00-00 Name : Slackware Advisory SSA:2011-109-01 polkit
File : nvt/esoft_slk_ssa_2011_109_01.nasl

Open Source Vulnerability Database (OSVDB)

Id Description
72261 PolicyKit pkexec Parent Process Race Condition Local Privilege Escalation

PolicyKit contains a flaw related to determining the privileges of the parent process. This may allow a local attacker to gain root privileges.

Metasploit Database

id Description
2011-04-01 Linux PolicyKit Race Condition Privilege Escalation

Nessus® Vulnerability Scanner

Date Description
2014-06-13 Name : The remote openSUSE host is missing a security update.
File : suse_11_3_libpolkit0-110427.nasl - Type : ACT_GATHER_INFO
2014-06-13 Name : The remote openSUSE host is missing a security update.
File : suse_11_4_libpolkit0-110427.nasl - Type : ACT_GATHER_INFO
2013-07-12 Name : The remote Oracle Linux host is missing one or more security updates.
File : oraclelinux_ELSA-2011-0455.nasl - Type : ACT_GATHER_INFO
2012-08-01 Name : The remote Scientific Linux host is missing one or more security updates.
File : sl_20110419_polkit_on_SL6_x.nasl - Type : ACT_GATHER_INFO
2012-06-21 Name : The remote Gentoo host is missing one or more security-related patches.
File : gentoo_GLSA-201204-06.nasl - Type : ACT_GATHER_INFO
2011-10-10 Name : The remote Debian host is missing a security-related update.
File : debian_DSA-2319.nasl - Type : ACT_GATHER_INFO
2011-06-13 Name : The remote Ubuntu host is missing a security-related patch.
File : ubuntu_USN-1117-1.nasl - Type : ACT_GATHER_INFO
2011-05-28 Name : The remote Slackware host is missing a security update.
File : Slackware_SSA_2011-109-01.nasl - Type : ACT_GATHER_INFO
2011-05-16 Name : The remote Mandriva Linux host is missing one or more security updates.
File : mandriva_MDVSA-2011-086.nasl - Type : ACT_GATHER_INFO
2011-05-10 Name : The remote Fedora host is missing a security update.
File : fedora_2011-5676.nasl - Type : ACT_GATHER_INFO
2011-04-23 Name : The remote Fedora host is missing a security update.
File : fedora_2011-5589.nasl - Type : ACT_GATHER_INFO
2011-04-20 Name : The remote Red Hat host is missing one or more security updates.
File : redhat-RHSA-2011-0455.nasl - Type : ACT_GATHER_INFO

Sources (Detail)

Source Url
CONFIRM https://bugzilla.redhat.com/show_bug.cgi?id=692922
DEBIAN http://www.debian.org/security/2011/dsa-2319
FEDORA http://lists.fedoraproject.org/pipermail/package-announce/2011-April/058752.html
http://lists.fedoraproject.org/pipermail/package-announce/2011-May/059859.html
GENTOO http://security.gentoo.org/glsa/glsa-201204-06.xml
MANDRIVA http://www.mandriva.com/security/advisories?name=MDVSA-2011:086
REDHAT http://www.redhat.com/support/errata/RHSA-2011-0455.html
SECUNIA http://secunia.com/advisories/48817
SREASON http://securityreason.com/securityalert/8424
UBUNTU http://www.ubuntu.com/usn/USN-1117-1

Alert History

If you want to see full details history, please login or register.
0
1
2
3
4
5
6
7
8
Date Informations
2020-05-23 13:16:57
  • Multiple Updates
2020-05-23 00:28:18
  • Multiple Updates
2016-04-26 20:41:30
  • Multiple Updates
2014-11-14 13:24:22
  • Multiple Updates
2014-10-21 13:24:12
  • Multiple Updates
2014-06-14 13:30:37
  • Multiple Updates
2014-02-17 11:01:43
  • Multiple Updates
2013-05-10 22:58:22
  • Multiple Updates
2012-12-19 13:23:47
  • Multiple Updates