Executive Summary



This Alert is flagged as TOP 25 Common Weakness Enumeration from CWE/SANS. For more information, you can read this.
Informations
NameCVE-2007-6170First vendor Publication2007-11-29
VendorCveLast vendor Modification2018-10-26

Security-Database Scoring CVSS v2

Cvss vector : (AV:N/AC:L/Au:S/C:P/I:P/A:P)
Cvss Base Score6.5Attack RangeNetwork
Cvss Impact Score6.4Attack ComplexityLow
Cvss Expoit Score8AuthenticationRequires single instance
Calculate full CVSS 2.0 Vectors scores

Security Protection

ImpactsProvides unauthorized access : Allows partial confidentiality, integrity, and availability violation; Allows unauthorized disclosure of information; Allows disruption of service.

Detail

SQL injection vulnerability in the Call Detail Record Postgres logging engine (cdr_pgsql) in Asterisk 1.4.x before 1.4.15, 1.2.x before 1.2.25, B.x before B.2.3.4, and C.x before C.1.0-beta6 allows remote authenticated users to execute arbitrary SQL commands via (1) ANI and (2) DNIS arguments.

Original Source

Url : http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-6170

CWE : Common Weakness Enumeration

%idName
100 %CWE-89Improper Sanitization of Special Elements used in an SQL Command ('SQL Injection') (CWE/SANS Top 25)

OVAL Definitions

Definition Id: oval:org.mitre.oval:def:18041
 
Oval ID: oval:org.mitre.oval:def:18041
Title: DSA-1417-1 asterisk - SQL injection
Description: Tilghman Lesher discovered that the logging engine of Asterisk, a free software PBX and telephony toolkit, performs insufficient sanitising of call-related data, which may lead to SQL injection.
Family: unix Class: patch
Reference(s): DSA-1417-1
CVE-2007-6170
Version: 5
Platform(s): Debian GNU/Linux 4.0
Product(s): asterisk
Definition Synopsis:

CPE : Common Platform Enumeration

TypeDescriptionCount
Application78
Os2

OpenVAS Exploits

DateDescription
2008-09-24Name : Gentoo Security Advisory GLSA 200804-13 (asterisk)
File : nvt/glsa_200804_13.nasl
2008-01-17Name : Debian Security Advisory DSA 1417-1 (asterisk)
File : nvt/deb_1417_1.nasl

Open Source Vulnerability Database (OSVDB)

idDescription
38932Asterisk Call Detail Record Postgres Multiple Strings SQL Injection

Nessus® Vulnerability Scanner

DateDescription
2008-04-17Name : The remote Gentoo host is missing one or more security-related patches.
File : gentoo_GLSA-200804-13.nasl - Type : ACT_GATHER_INFO
2008-03-07Name : The remote openSUSE host is missing a security update.
File : suse_asterisk-5062.nasl - Type : ACT_GATHER_INFO
2007-12-04Name : The remote Debian host is missing a security-related update.
File : debian_DSA-1417.nasl - Type : ACT_GATHER_INFO

Sources (Detail)

SourceUrl
BID http://www.securityfocus.com/bid/26647
BUGTRAQ http://www.securityfocus.com/archive/1/484388/100/0/threaded
CONFIRM http://downloads.digium.com/pub/security/AST-2007-026.html
DEBIAN http://www.debian.org/security/2007/dsa-1417
GENTOO http://security.gentoo.org/glsa/glsa-200804-13.xml
SECTRACK http://securitytracker.com/id?1019020
SUSE http://lists.opensuse.org/opensuse-security-announce/2008-03/msg00001.html
VUPEN http://www.vupen.com/english/advisories/2007/4056
XF https://exchange.xforce.ibmcloud.com/vulnerabilities/38765

Alert History

If you want to see full details history, please login or register.
0
1
2
3
4
5
6
7
DateInformations
2019-07-17 12:02:10
  • Multiple Updates
2018-11-30 12:02:15
  • Multiple Updates
2018-10-26 21:20:59
  • Multiple Updates
2018-10-16 00:19:21
  • Multiple Updates
2017-07-29 12:02:41
  • Multiple Updates
2016-04-26 16:50:52
  • Multiple Updates
2014-02-17 10:42:44
  • Multiple Updates
2013-05-11 10:43:11
  • Multiple Updates