Executive Summary

Summary
Title Adobe Flash, Reader, and Acrobat Vulnerability
Informations
Name TA10-159A First vendor Publication 2010-06-08
Vendor US-CERT Last vendor Modification 2010-06-08
Severity (Vendor) N/A Revision N/A

Security-Database Scoring CVSS v3

Cvss vector : N/A
Overall CVSS Score NA
Base Score NA Environmental Score NA
impact SubScore NA Temporal Score NA
Exploitabality Sub Score NA
 
Calculate full CVSS 3.0 Vectors scores

Security-Database Scoring CVSS v2

Cvss vector : (AV:N/AC:M/Au:N/C:C/I:C/A:C)
Cvss Base Score 9.3 Attack Range Network
Cvss Impact Score 10 Attack Complexity Medium
Cvss Expoit Score 8.6 Authentication None Required
Calculate full CVSS 2.0 Vectors scores

Detail

According to Adobe, there is a vulnerability in Adobe Flash. This vulnerability affects Flash Player, Reader, Acrobat, and possibly other products that support Flash. A remote attacker could exploit this vulnerability to execute arbitrary code.

I. Description

Adobe Security Advisory APSA10-01 describes a vulnerability in Adobe Flash that affects Flash Player, Reader, and Acrobat. It may also affect other products that independently support Flash, such as Photoshop, Photoshop Lightroom, Freehand MX, and Fireworks.

An attacker could exploit this vulnerability by convincing a user to open specially crafted Flash content. Flash content is commonly hosted on a web page, but it can also be embedded in PDF and other documents or provided as a stand-alone file.

As noted in APSA10-01, "There are reports that this vulnerability is being actively exploited in the wild against both Adobe Flash Player, and Adobe Reader and Acrobat."

Additional information is available in US-CERT Vulnerability Note VU#486225.

II. Impact

If a user opens specially crafted Flash content, a remote attacker may be able to execute arbitrary code.

III. Solution

Update

Adobe Security Advisory APSA10-01 suggests updating to the release candidate of Flash Player 10.1.

Disable Flash in your web browser

Uninstall Flash or restrict which sites are allowed to run Flash.
To the extent possible, only run trusted Flash content on trusted domains. For more information, see Securing Your Web Browser.

Disable Flash in Adobe Reader and Acrobat

Disabling Flash in Adobe Reader will mitigate attacks that rely on Flash content embedded in a PDF file. Disabling 3D & Multimedia support does not directly address the vulnerability, but it does provide additional mitigation and results in a more user-friendly error message instead of a crash. To disable Flash and 3D &
Multimedia support in Adobe Reader 9, delete, rename, or remove access to these files:

Microsoft Windows

"%ProgramFiles%\Adobe\Reader 9.0\Reader\authplay.dll"
"%ProgramFiles%\Adobe\Reader 9.0\Reader\rt3d.dll"

Apple Mac OS X

"/Applications/Adobe Reader 9/Adobe Reader.app/Contents/Frameworks/AuthPlayLib.bundle"
"/Applications/Adobe Reader 9/Adobe Reader.app/Contents/Frameworks/Adobe3D.framework"

GNU/Linux (locations may vary among distributions)

"/opt/Adobe/Reader9/Reader/intellinux/lib/libauthplay.so"
"/opt/Adobe/Reader9/Reader/intellinux/lib/librt3d.so"

File locations may be different for Adobe Acrobat or other Adobe products that include Flash and 3D & Multimedia support. Disabling these plugins will reduce functionality and will not protect against Flash content hosted on websites. Depending on the update schedule for products other than Flash Player, consider leaving Flash and 3D & Multimedia support disabled unless they are absolutely required.

Prevent Internet Explorer from automatically opening PDF documents

The installer for Adobe Reader and Acrobat configures Internet Explorer to automatically open PDF files without any user interaction. This behavior can be reverted to a safer option that prompts the user by importing the following as a .REG file:

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\AcroExch.Document.7]
"EditFlags"=hex:00,00,00,00

Disable the display of PDF documents in the web browser

Preventing PDF documents from opening inside a web browser will partially mitigate this vulnerability. If this workaround is applied, it may also mitigate future vulnerabilities.

To prevent PDF documents from automatically being opened in a web browser, do the following:

1. Open Adobe Acrobat Reader.
2. Open the Edit menu.
3. Choose the Preferences option.
4. Choose the Internet section.
5. Uncheck the "Display PDF in browser" checkbox.

Disable JavaScript in Adobe Reader and Acrobat

Disabling JavaScript provides some additional protection against attacks. Acrobat JavaScript can be disabled using the Preferences menu (Edit -> Preferences -> JavaScript; uncheck Enable Acrobat JavaScript).

Enable DEP in Microsoft Windows

Consider enabling Data Execution Prevention (DEP) in supported versions of Windows. DEP should not be treated as a complete workaround, but it can mitigate the execution of attacker-supplied code in some cases. Microsoft has published detailed technical information about DEP in Security Research & Defense blog posts
"Understanding DEP as a mitigation technology" part 1 and part 2.
Use of DEP should be considered in conjunction with the application of patches or other mitigations described in this document.

Do not access PDF documents from untrusted sources

Do not open unfamiliar or unexpected PDF documents, particularly those hosted on websites or delivered as email attachments. Please see Cyber Security Tip ST04-010.

Original Source

Url : http://www.us-cert.gov/cas/techalerts/TA10-159A.html

OVAL Definitions

Definition Id: oval:org.mitre.oval:def:7116
 
Oval ID: oval:org.mitre.oval:def:7116
Title: Adobe Flash Player, Acrobat Reader, and Acrobat 'authplay.dll' Remote Code Execution Vulnerability
Description: Adobe Flash Player before 9.0.277.0 and 10.x before 10.1.53.64; Adobe AIR before 2.0.2.12610; and Adobe Reader and Acrobat 9.x before 9.3.3, and 8.x before 8.2.3 on Windows and Mac OS X, allow remote attackers to execute arbitrary code or cause a denial of service (memory corruption) via crafted SWF content, related to authplay.dll and the ActionScript Virtual Machine 2 (AVM2) newfunction instruction, as exploited in the wild in June 2010.
Family: windows Class: vulnerability
Reference(s): CVE-2010-1297
Version: 30
Platform(s): Microsoft Windows 2000
Microsoft Windows XP
Microsoft Windows Vista
Microsoft Windows Server 2003
Microsoft Windows Server 2008
Microsoft Windows 7
Microsoft Windows Server 2008 R2
Microsoft Windows 8
Microsoft Windows Server 2012
Microsoft Windows 8.1
Microsoft Windows Server 2012 R2
Product(s): Adobe Flash Player
Adobe Reader
Adobe Acrobat
Definition Synopsis:

CPE : Common Platform Enumeration

TypeDescriptionCount
Application 134
Application 85
Application 95

SAINT Exploits

Description Link
Adobe Reader authplay.dll newfunction Memory Corruption More info here

ExploitDB Exploits

id Description
2010-09-25 Adobe Flash Player "newfunction" Invalid Pointer Use
2010-09-20 Adobe Flash Player "newfunction" Invalid Pointer Use
2010-09-01 MOAUB #1 - Adobe Acrobat Reader and Flash Player
2010-06-09 Adobe Flash and Reader - 0day Exploit PoC (from the wild)

OpenVAS Exploits

Date Description
2011-09-07 Name : Mac OS X v10.6.4 Multiple Vulnerabilities (2010-007)
File : nvt/gb_macosx_su10-007.nasl
2011-03-09 Name : Gentoo Security Advisory GLSA 201009-05 (acroread)
File : nvt/glsa_201009_05.nasl
2011-03-09 Name : Gentoo Security Advisory GLSA 201101-09 (adobe-flash)
File : nvt/glsa_201101_09.nasl
2010-07-12 Name : SuSE Update for acroread SUSE-SA:2010:029
File : nvt/gb_suse_2010_029.nasl
2010-07-06 Name : FreeBSD Ports: linux-flashplugin
File : nvt/freebsd_linux-flashplugin8.nasl
2010-06-23 Name : SuSE Update for flash-player SUSE-SA:2010:024
File : nvt/gb_suse_2010_024.nasl
2010-06-22 Name : Adobe Flash Player/Air Multiple Vulnerabilities - June10 (Linux)
File : nvt/secpod_adobe_prdts_mult_vuln_jun10_lin.nasl
2010-06-22 Name : Adobe Flash Player/Air Multiple Vulnerabilities - June10 (Win)
File : nvt/secpod_adobe_prdts_mult_vuln_jun10_win.nasl
2010-06-15 Name : Adobe Products Remote Code Execution Vulnerability - jun10 (Linux)
File : nvt/gb_adobe_prdts_code_exec_vuln_lin_jun10.nasl
2010-06-15 Name : Adobe Products Remote Code Execution Vulnerability - jun10 (Win)
File : nvt/gb_adobe_prdts_code_exec_vuln_win_jun10.nasl

Open Source Vulnerability Database (OSVDB)

Id Description
65141 Adobe Multiple Products SWF Handling Arbitrary Code Execution

Snort® IPS/IDS

Date Description
2014-01-10 Adobe Flash Player newfunction memory corruption attempt
RuleID : 28676 - Revision : 5 - Type : FILE-FLASH
2014-01-10 Adobe Flash Player newfunction memory corruption attempt
RuleID : 28675 - Revision : 5 - Type : FILE-FLASH
2014-01-10 Adobe Flash Player newfunction memory corruption attempt
RuleID : 28674 - Revision : 5 - Type : FILE-FLASH
2014-01-10 Adobe Flash Player newfunction memory corruption attempt
RuleID : 28673 - Revision : 5 - Type : FILE-FLASH
2014-01-10 Teletubbies exploit kit payload download
RuleID : 27886 - Revision : 2 - Type : EXPLOIT-KIT
2014-01-10 Teletubbies exploit kit exploit attempt for Adobe Flash Player
RuleID : 27881 - Revision : 2 - Type : EXPLOIT-KIT
2014-01-10 Adobe Flash Player newfunction memory corruption exploit attempt
RuleID : 23592 - Revision : 7 - Type : FILE-FLASH
2014-01-10 Adobe Flash Player newfunction memory corruption attempt
RuleID : 23591 - Revision : 7 - Type : FILE-FLASH
2014-01-10 Adobe Flash use-after-free attack attempt
RuleID : 23579 - Revision : 6 - Type : FILE-FLASH
2014-01-10 Adobe flash player newfunction memory corruption attempt
RuleID : 23512 - Revision : 5 - Type : FILE-PDF
2014-01-10 Adobe Acrobat Reader authplay.dll vulnerability exploit attempt
RuleID : 23511 - Revision : 7 - Type : FILE-PDF
2014-01-10 Adobe Acrobat Reader File containing Flash use-after-free attack attempt
RuleID : 23510 - Revision : 7 - Type : FILE-PDF
2014-01-10 Adobe Acrobat Reader malformed Richmedia annotation exploit attempt
RuleID : 23509 - Revision : 5 - Type : FILE-PDF
2014-01-10 Adobe Flash Player newfunction memory corruption attempt
RuleID : 23265 - Revision : 11 - Type : FILE-FLASH
2014-01-10 Adobe Flash Player newfunction memory corruption attempt
RuleID : 23264 - Revision : 10 - Type : FILE-FLASH
2014-01-10 Adobe flash player newfunction memory corruption attempt
RuleID : 23263 - Revision : 9 - Type : FILE-PDF
2014-01-10 Phoenix exploit kit post-compromise behavior
RuleID : 21860 - Revision : 5 - Type : MALWARE-CNC
2014-01-10 Phoenix exploit kit landing page
RuleID : 21640 - Revision : 6 - Type : EXPLOIT-KIT
2014-01-10 Adobe Flash Player newfunction memory corruption exploit attempt
RuleID : 19408 - Revision : 12 - Type : FILE-FLASH
2014-01-10 Adobe Flash Player newfunction memory corruption attempt
RuleID : 19145 - Revision : 13 - Type : FILE-FLASH
2014-01-10 Adobe Acrobat Reader authplay.dll vulnerability exploit attempt
RuleID : 16664 - Revision : 12 - Type : FILE-PDF
2014-01-10 Adobe Flash use-after-free attack attempt
RuleID : 16634 - Revision : 16 - Type : FILE-FLASH
2014-01-10 Adobe Acrobat Reader File containing Flash use-after-free attack attempt
RuleID : 16633 - Revision : 19 - Type : FILE-PDF
2014-01-10 Adobe Acrobat Reader malformed Richmedia annotation exploit attempt
RuleID : 16545 - Revision : 21 - Type : FILE-PDF

Nessus® Vulnerability Scanner

Date Description
2013-01-24 Name : The remote Red Hat host is missing a security update.
File : redhat-RHSA-2010-0464.nasl - Type : ACT_GATHER_INFO
2013-01-24 Name : The remote Red Hat host is missing a security update.
File : redhat-RHSA-2010-0470.nasl - Type : ACT_GATHER_INFO
2011-01-27 Name : The remote SuSE 10 host is missing a security-related patch.
File : suse_flash-player-7071.nasl - Type : ACT_GATHER_INFO
2011-01-27 Name : The remote SuSE 10 host is missing a security-related patch.
File : suse_acroread_ja-7086.nasl - Type : ACT_GATHER_INFO
2011-01-27 Name : The remote SuSE 10 host is missing a security-related patch.
File : suse_acroread-7087.nasl - Type : ACT_GATHER_INFO
2011-01-24 Name : The remote Gentoo host is missing one or more security-related patches.
File : gentoo_GLSA-201101-09.nasl - Type : ACT_GATHER_INFO
2010-12-02 Name : The remote SuSE 11 host is missing a security update.
File : suse_11_flash-player-100611.nasl - Type : ACT_GATHER_INFO
2010-12-02 Name : The remote SuSE 11 host is missing a security update.
File : suse_11_acroread_ja-100702.nasl - Type : ACT_GATHER_INFO
2010-12-02 Name : The remote SuSE 11 host is missing one or more security updates.
File : suse_11_acroread-100702.nasl - Type : ACT_GATHER_INFO
2010-11-10 Name : The remote host is missing a Mac OS X update that fixes various security issues.
File : macosx_10_6_5.nasl - Type : ACT_GATHER_INFO
2010-11-10 Name : The remote host is missing a Mac OS X update that fixes security issues.
File : macosx_SecUpd2010-007.nasl - Type : ACT_GATHER_INFO
2010-09-08 Name : The remote Gentoo host is missing one or more security-related patches.
File : gentoo_GLSA-201009-05.nasl - Type : ACT_GATHER_INFO
2010-07-28 Name : The remote Red Hat host is missing one or more security updates.
File : redhat-RHSA-2010-0503.nasl - Type : ACT_GATHER_INFO
2010-07-09 Name : The remote openSUSE host is missing a security update.
File : suse_11_0_acroread-100708.nasl - Type : ACT_GATHER_INFO
2010-07-09 Name : The remote openSUSE host is missing a security update.
File : suse_11_2_acroread-100706.nasl - Type : ACT_GATHER_INFO
2010-07-09 Name : The remote openSUSE host is missing a security update.
File : suse_11_1_acroread-100708.nasl - Type : ACT_GATHER_INFO
2010-06-30 Name : The version of Adobe Acrobat on the remote Windows host is affected by multip...
File : adobe_acrobat_apsb10-15.nasl - Type : ACT_GATHER_INFO
2010-06-30 Name : The version of Adobe Reader on the remote Windows host is affected by multipl...
File : adobe_reader_apsb10-15.nasl - Type : ACT_GATHER_INFO
2010-06-16 Name : The remote FreeBSD host is missing one or more security-related updates.
File : freebsd_pkg_144e524a77eb11dfae06001b2134ef46.nasl - Type : ACT_GATHER_INFO
2010-06-14 Name : The remote openSUSE host is missing a security update.
File : suse_11_1_flash-player-100611.nasl - Type : ACT_GATHER_INFO
2010-06-14 Name : The remote openSUSE host is missing a security update.
File : suse_11_2_flash-player-100611.nasl - Type : ACT_GATHER_INFO
2010-06-14 Name : The remote openSUSE host is missing a security update.
File : suse_11_0_flash-player-100611.nasl - Type : ACT_GATHER_INFO
2010-06-10 Name : The remote Windows host contains a browser plug-in that is affected by a code...
File : flash_player_apsb10-14.nasl - Type : ACT_GATHER_INFO
2010-06-10 Name : The remote Windows host contains a version of Adobe AIR that is affected by m...
File : adobe_air_apsb10-14.nasl - Type : ACT_GATHER_INFO