Executive Summary

Summary
Title OpenShift Container Platform 4.2.21 security update
Informations
Name RHSA-2020:0617 First vendor Publication 2020-03-04
Vendor RedHat Last vendor Modification 2020-03-04
Severity (Vendor) N/A Revision 01

Security-Database Scoring CVSS v3

Cvss vector : CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
Overall CVSS Score 7
Base Score 7 Environmental Score 7
impact SubScore 5.9 Temporal Score 7
Exploitabality Sub Score 1
 
Attack Vector Local Attack Complexity High
Privileges Required Low User Interaction None
Scope Unchanged Confidentiality Impact High
Integrity Impact High Availability Impact High
Calculate full CVSS 3.0 Vectors scores

Security-Database Scoring CVSS v2

Cvss vector : (AV:L/AC:M/Au:N/C:P/I:P/A:P)
Cvss Base Score 4.4 Attack Range Local
Cvss Impact Score 6.4 Attack Complexity Medium
Cvss Expoit Score 3.4 Authentication None Required
Calculate full CVSS 2.0 Vectors scores

Detail

Problem Description:

An update is now available for Red Hat OpenShift Container Platform 4.2.

Red Hat Product Security has rated this update as having a security impact of Moderate. A Common Vulnerability Scoring System (CVSS) base score, which gives a detailed severity rating, is available for each vulnerability from the CVE link(s) in the References section.

2. Description:

Red Hat OpenShift Container Platform is Red Hat's cloud computing Kubernetes application platform solution designed for on-premise or private cloud deployments.

Security Fix(es):

* openshift/mediawiki-apb: /etc/passwd is given incorrect privileges (CVE-2019-19345)

* openshift/mariadb-apb: /etc/passwd is given incorrect privileges (CVE-2019-19346)

* openshift/apb-base: /etc/passwd is given incorrect privileges (CVE-2019-19348)

* openshift/postgresql-apb: /etc/passwd is given incorrect privileges (CVE-2020-1707)

* openshift/mysql-apb: /etc/passwd is given incorrect privileges (CVE-2020-1708)

For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.

3. Solution:

For OpenShift Container Platform 4.2 see the following documentation, which will be updated shortly for release 4.2, for important instructions on how to upgrade your cluster and fully apply this asynchronous errata update:

https://docs.openshift.com/container-platform/4.2/release_notes/ocp-4-2-rel ease-notes.html

Details on how to access this content are available at https://docs.openshift.com/container-platform/4.2/updating/updating-cluster - -cli.html.

4. Bugs fixed (https://bugzilla.redhat.com/):

1793286 - CVE-2019-19348 openshift/apb-base: /etc/passwd is given incorrect privileges 1793289 - CVE-2019-19346 openshift/mariadb-apb: /etc/passwd is given incorrect privileges 1793296 - CVE-2019-19345 openshift/mediawiki-apb: /etc/passwd is given incorrect privileges 1793299 - CVE-2020-1708 openshift/mysql-apb: /etc/passwd is given incorrect privileges 1793301 - CVE-2020-1707 openshift/postgresql-apb: /etc/passwd is given incorrect privileges

5. References:

https://access.redhat.com/security/cve/CVE-2019-19345 https://access.redhat.com/security/cve/CVE-2019-19346 https://access.redhat.com/security/cve/CVE-2019-19348 https://access.redhat.com/security/cve/CVE-2020-1707 https://access.redhat.com/security/cve/CVE-2020-1708 https://access.redhat.com/security/updates/classification/#moderate

Original Source

Url : https://rhn.redhat.com/errata/RHSA-2020-0617.html

CWE : Common Weakness Enumeration

% Id Name
100 % CWE-269 Improper Privilege Management

CPE : Common Platform Enumeration

TypeDescriptionCount
Application 74
Application 4
Os 1

Alert History

If you want to see full details history, please login or register.
0
1
Date Informations
2020-05-23 13:03:45
  • Multiple Updates
2020-03-19 13:20:04
  • First insertion