Executive Summary

Summary
Title libvpx: User-assisted execution of arbitrary code
Informations
Name GLSA-202003-59 First vendor Publication 2020-03-26
Vendor Gentoo Last vendor Modification 2020-03-26
Severity (Vendor) N/A Revision N/A

Security-Database Scoring CVSS v3

Cvss vector : N/A
Overall CVSS Score NA
Base Score NA Environmental Score NA
impact SubScore NA Temporal Score NA
Exploitabality Sub Score NA
 
Calculate full CVSS 3.0 Vectors scores

Security-Database Scoring CVSS v2

Cvss vector : (AV:N/AC:M/Au:N/C:N/I:N/A:C)
Cvss Base Score 7.1 Attack Range Network
Cvss Impact Score 6.9 Attack Complexity Medium
Cvss Expoit Score 8.6 Authentication None Required
Calculate full CVSS 2.0 Vectors scores

Detail

Synopsis

Multiple vulnerabilities have been found in libvpx, the worst of which could result in the execution of arbitrary code.

Background

libvpx is the VP8 codec SDK used to encode and decode video streams, typically within a WebM format media file.

Description

Multiple vulnerabilities have been discovered in libvpx. Please review the CVE identifiers referenced below for details.

Impact

A remote attacker could entice a user to open a specially crafted media file, possibly resulting in the execution of arbitrary code with the privileges of the user running the application, or a Denial of Service.

Workaround

There is no known workaround at this time.

Resolution

All libvpx 1.7.x users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose ">=media-libs/libvpx-1.7.0-r1"

All libvpx 1.8.x users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose ">=media-libs/libvpx-1.8.1"

References

[ 1 ] CVE-2019-9232 : https://nvd.nist.gov/vuln/detail/CVE-2019-9232
[ 2 ] CVE-2019-9325 : https://nvd.nist.gov/vuln/detail/CVE-2019-9325
[ 3 ] CVE-2019-9371 : https://nvd.nist.gov/vuln/detail/CVE-2019-9371
[ 4 ] CVE-2019-9433 : https://nvd.nist.gov/vuln/detail/CVE-2019-9433

Availability

This GLSA and any updates to it are available for viewing at the Gentoo Security Website:

https://security.gentoo.org/glsa/202003-59

Original Source

Url : http://security.gentoo.org/glsa/glsa-202003-59.xml

CWE : Common Weakness Enumeration

% Id Name
50 % CWE-125 Out-of-bounds Read
50 % CWE-20 Improper Input Validation

CPE : Common Platform Enumeration

TypeDescriptionCount
Os 1

Alert History

If you want to see full details history, please login or register.
0
Date Informations
2020-03-26 21:17:54
  • First insertion