Executive Summary

Summary
Title CouchDB: Multiple vulnerabilities
Informations
Name GLSA-201812-06 First vendor Publication 2018-12-15
Vendor Gentoo Last vendor Modification 2018-12-15
Severity (Vendor) N/A Revision N/A

Security-Database Scoring CVSS v3

Cvss vector : N/A
Overall CVSS Score NA
Base Score NA Environmental Score NA
impact SubScore NA Temporal Score NA
Exploitabality Sub Score NA
 
Calculate full CVSS 3.0 Vectors scores

Security-Database Scoring CVSS v2

Cvss vector : (AV:N/AC:L/Au:S/C:C/I:C/A:C)
Cvss Base Score 9 Attack Range Network
Cvss Impact Score 10 Attack Complexity Low
Cvss Expoit Score 8 Authentication Requires single instance
Calculate full CVSS 2.0 Vectors scores

Detail

Synopsis

Multiple vulnerabilities have been found in CouchDB, the worst of which could lead to the remote execution of code.

Background

Apache CouchDB is a distributed, fault-tolerant and schema-free document-oriented database.

Description

Multiple vulnerabilities have been discovered in CouchDB. Please review the CVE identifiers referenced below for details.

Impact

A remote attacker could execute arbitrary code or escalate privileges.

Workaround

There is no known workaround at this time.

Resolution

Gentoo has discontinued support for CouchDB and recommends that users unmerge the package:
# emerge --unmerge "dev-db/couchdb"

References

[ 1 ] CVE-2018-11769 : https://nvd.nist.gov/vuln/detail/CVE-2018-11769
[ 2 ] CVE-2018-8007 : https://nvd.nist.gov/vuln/detail/CVE-2018-8007

Availability

This GLSA and any updates to it are available for viewing at the Gentoo Security Website:

https://security.gentoo.org/glsa/201812-06

Original Source

Url : http://security.gentoo.org/glsa/glsa-201812-06.xml

CWE : Common Weakness Enumeration

% Id Name
100 % CWE-20 Improper Input Validation

CPE : Common Platform Enumeration

TypeDescriptionCount
Application 56

Snort® IPS/IDS

Date Description
2019-09-26 Apache CouchDB _config command injection attempt
RuleID : 51287 - Revision : 1 - Type : SERVER-WEBAPP

Nessus® Vulnerability Scanner

Date Description
2018-12-17 Name : The remote Gentoo host is missing one or more security-related patches.
File : gentoo_GLSA-201812-06.nasl - Type : ACT_GATHER_INFO
2018-08-22 Name : The remote FreeBSD host is missing a security-related update.
File : freebsd_pkg_9b19b6dfa4be11e893660028f8d09152.nasl - Type : ACT_GATHER_INFO
2018-08-17 Name : The remote database server is potentially affected by a privilege escalation ...
File : couchdb_2_2_0.nasl - Type : ACT_GATHER_INFO
2018-07-12 Name : The remote FreeBSD host is missing a security-related update.
File : freebsd_pkg_1e54d140849311e8a7950028f8d09152.nasl - Type : ACT_GATHER_INFO

Alert History

If you want to see full details history, please login or register.
0
Date Informations
2018-12-15 21:19:03
  • First insertion