This CPE summary could be partial or incomplete. Please contact us for a detailed listing.

Summary

Detail
Vendor Psnode Project First view 2021-04-18
Product Psnode Last view 2021-04-18
Version * Type Application
Update *  
Edition *  
Language *  
Sofware Edition *  
Target Software node.js  
Target Hardware *  
Other *  
 
CPE Product cpe:2.3:a:psnode_project:psnode

Activity : Overall

Related : CVE

  Date Alert Description
9.8 2021-04-18 CVE-2021-23375

This affects all versions of package psnode. If attacker-controlled user input is given to the kill function, it is possible for an attacker to execute arbitrary commands. This is due to use of the child_process exec function without input sanitization.

CWE : Common Weakness Enumeration

%idName
100% (1) CWE-77 Improper Sanitization of Special Elements used in a Command ('Comma...