This CPE summary could be partial or incomplete. Please contact us for a detailed listing.

Summary

Detail
Vendor Redhat First view 2014-12-01
Product Undertow Last view 2020-06-10
Version Type
Update  
Edition  
Language  
Sofware Edition  
Target Software  
Target Hardware  
Other  

Activity : Overall

COMMON PLATFORM ENUMERATION: Repartition per Version

CPE Name Affected CVE
cpe:2.3:a:redhat:undertow:-:*:*:*:*:*:*:* 16
cpe:2.3:a:redhat:undertow:1.1.0:cr4:*:*:*:*:*:* 13
cpe:2.3:a:redhat:undertow:1.2.0:beta2:*:*:*:*:*:* 13
cpe:2.3:a:redhat:undertow:1.0.16:*:*:*:*:*:*:* 13
cpe:2.3:a:redhat:undertow:1.0.0:*:*:*:*:*:*:* 13
cpe:2.3:a:redhat:undertow:1.0.1:*:*:*:*:*:*:* 13
cpe:2.3:a:redhat:undertow:1.0.2:*:*:*:*:*:*:* 13
cpe:2.3:a:redhat:undertow:1.0.3:*:*:*:*:*:*:* 13
cpe:2.3:a:redhat:undertow:1.0.4:*:*:*:*:*:*:* 13
cpe:2.3:a:redhat:undertow:1.0.5:*:*:*:*:*:*:* 13
cpe:2.3:a:redhat:undertow:1.0.6:*:*:*:*:*:*:* 13
cpe:2.3:a:redhat:undertow:1.0.7:*:*:*:*:*:*:* 13
cpe:2.3:a:redhat:undertow:1.0.8:*:*:*:*:*:*:* 13
cpe:2.3:a:redhat:undertow:1.0.9:*:*:*:*:*:*:* 13
cpe:2.3:a:redhat:undertow:1.0.10:*:*:*:*:*:*:* 13
cpe:2.3:a:redhat:undertow:1.0.11:*:*:*:*:*:*:* 13
cpe:2.3:a:redhat:undertow:1.0.12:*:*:*:*:*:*:* 13
cpe:2.3:a:redhat:undertow:1.0.13:*:*:*:*:*:*:* 13
cpe:2.3:a:redhat:undertow:1.0.14:*:*:*:*:*:*:* 13
cpe:2.3:a:redhat:undertow:1.0.15:*:*:*:*:*:*:* 13
cpe:2.3:a:redhat:undertow:1.0.17:*:*:*:*:*:*:* 13
cpe:2.3:a:redhat:undertow:1.0.18:*:*:*:*:*:*:* 13
cpe:2.3:a:redhat:undertow:1.0.19:*:*:*:*:*:*:* 13
cpe:2.3:a:redhat:undertow:1.1.0:*:*:*:*:*:*:* 13
cpe:2.3:a:redhat:undertow:1.1.1:*:*:*:*:*:*:* 13
cpe:2.3:a:redhat:undertow:1.1.2:*:*:*:*:*:*:* 13
cpe:2.3:a:redhat:undertow:1.1.3:*:*:*:*:*:*:* 13
cpe:2.3:a:redhat:undertow:1.1.4:*:*:*:*:*:*:* 13
cpe:2.3:a:redhat:undertow:1.1.5:*:*:*:*:*:*:* 13
cpe:2.3:a:redhat:undertow:1.1.6:*:*:*:*:*:*:* 13
cpe:2.3:a:redhat:undertow:1.1.7:*:*:*:*:*:*:* 13
cpe:2.3:a:redhat:undertow:1.1.8:*:*:*:*:*:*:* 13
cpe:2.3:a:redhat:undertow:1.1.9:*:*:*:*:*:*:* 13
cpe:2.3:a:redhat:undertow:1.2.0:*:*:*:*:*:*:* 13
cpe:2.3:a:redhat:undertow:1.0.0:-:*:*:*:*:*:* 13
cpe:2.3:a:redhat:undertow:1.0.0:alpha1:*:*:*:*:*:* 13
cpe:2.3:a:redhat:undertow:1.0.0:alpha10:*:*:*:*:*:* 13
cpe:2.3:a:redhat:undertow:1.0.0:alpha11:*:*:*:*:*:* 13
cpe:2.3:a:redhat:undertow:1.0.0:alpha12:*:*:*:*:*:* 13
cpe:2.3:a:redhat:undertow:1.0.0:alpha13:*:*:*:*:*:* 13
cpe:2.3:a:redhat:undertow:1.0.0:alpha14:*:*:*:*:*:* 13
cpe:2.3:a:redhat:undertow:1.0.0:alpha15:*:*:*:*:*:* 13
cpe:2.3:a:redhat:undertow:1.0.0:alpha16:*:*:*:*:*:* 13
cpe:2.3:a:redhat:undertow:1.0.0:alpha17:*:*:*:*:*:* 13
cpe:2.3:a:redhat:undertow:1.0.0:alpha18:*:*:*:*:*:* 13
cpe:2.3:a:redhat:undertow:1.0.0:alpha19:*:*:*:*:*:* 13
cpe:2.3:a:redhat:undertow:1.0.0:alpha2:*:*:*:*:*:* 13
cpe:2.3:a:redhat:undertow:1.0.0:alpha20:*:*:*:*:*:* 13
cpe:2.3:a:redhat:undertow:1.0.0:alpha21:*:*:*:*:*:* 13
cpe:2.3:a:redhat:undertow:1.0.0:alpha22:*:*:*:*:*:* 13

Related : CVE

  Date Alert Description
7.5 2020-06-10 CVE-2020-10705

A flaw was discovered in Undertow in versions before Undertow 2.1.1.Final where certain requests to the "Expect: 100-continue" header may cause an out of memory error. This flaw may potentially lead to a denial of service.

6.5 2020-05-26 CVE-2020-10719

A flaw was found in Undertow in versions before 2.1.1.Final, regarding the processing of invalid HTTP requests with large chunk sizes. This flaw allows an attacker to take advantage of HTTP request smuggling.

8.1 2020-04-21 CVE-2020-1757

A flaw was found in all undertow-2.x.x SP1 versions prior to undertow-2.0.30.SP1, all undertow-1.x.x and undertow-2.x.x versions prior to undertow-2.1.0.Final, where the Servlet container causes servletPath to normalize incorrectly by truncating the path after semicolon which may lead to an application mapping resulting in the security bypass.

7.5 2020-01-23 CVE-2019-14888

A vulnerability was found in the Undertow HTTP server in versions before 2.0.28.SP1 when listening on HTTPS. An attacker can target the HTTPS port to carry out a Denial Of Service (DOS) to make the service unavailable on SSL.

9.8 2019-10-02 CVE-2019-10212

A flaw was found in, all under 2.0.20, in the Undertow DEBUG log for io.undertow.request.security. If enabled, an attacker could abuse this flaw to obtain the user's credentials from the log files.

7.5 2019-07-25 CVE-2019-10184

undertow before version 2.0.23.Final is vulnerable to an information leak issue. Web apps may have their directory structures predicted through requests without trailing slashes via the api.

9.8 2019-06-12 CVE-2019-3888

A vulnerability was found in Undertow web server before 2.0.21. An information exposure of plain text credentials through log files because Connectors.executeRootHandler:402 logs the HttpServerExchange object at ERROR level using UndertowLogger.REQUEST_LOGGER.undertowRequestFailed(t, exchange)

5.3 2018-09-18 CVE-2018-14642

An information leak vulnerability was found in Undertow. If all headers are not written out in the first write() call then the code that handles flushing the buffer will always write out the full contents of the writevBuffer buffer, which may contain data from previous requests.

6.5 2018-09-11 CVE-2018-1114

It was found that URLResource.getLastModified() in Undertow closes the file descriptors only when they are finalized which can cause file descriptors to exhaust. This leads to a file handler leak.

7.5 2018-07-27 CVE-2017-2670

It was found in Undertow before 1.3.28 that with non-clean TCP close, the Websocket server gets into infinite loop on every IO thread, effectively causing DoS.

6.5 2018-07-27 CVE-2017-2666

It was discovered in Undertow that the code that parsed the HTTP request line permitted invalid characters. This could be exploited, in conjunction with a proxy that also permitted the invalid characters but with a different interpretation, to inject data into the HTTP response. By manipulating the HTTP response the attacker could poison a web-cache, perform an XSS attack, or obtain sensitive information from requests other than their own.

7.5 2018-07-27 CVE-2017-12165

It was discovered that Undertow before 1.4.17, 1.3.31 and 2.0.0 processes http request headers with unusual whitespaces which can cause possible http request smuggling.

6.1 2018-05-21 CVE-2018-1067

In Undertow before versions 7.1.2.CR1, 7.1.2.GA it was found that the fix for CVE-2016-4993 was incomplete and Undertow web server is vulnerable to the injection of arbitrary HTTP headers, and also response splitting, due to insufficient sanitization and validation of user input before the input is used as part of an HTTP header value.

5.9 2018-04-17 CVE-2017-12196

undertow before versions 1.4.18.SP1, 2.0.2.Final, 1.4.24.Final was found vulnerable when using Digest authentication, the server does not ensure that the value of URI in the Authorization header matches the URI in HTTP request line. This allows the attacker to cause a MITM attack and access the desired content on the server.

6.1 2018-01-10 CVE-2017-7559

In Undertow 2.x before 2.0.0.Alpha2, 1.4.x before 1.4.17.Final, and 1.3.x before 1.3.31.Final, it was found that the fix for CVE-2017-2666 was incomplete and invalid characters are still allowed in the query string and path parameters. This could be exploited, in conjunction with a proxy that also permitted the invalid characters but with a different interpretation, to inject data into the HTTP response. By manipulating the HTTP response the attacker could poison a web-cache, perform an XSS attack, or obtain sensitive information from requests other than their own.

5 2014-12-01 CVE-2014-7816

Directory traversal vulnerability in JBoss Undertow 1.0.x before 1.0.17, 1.1.x before 1.1.0.CR5, and 1.2.x before 1.2.0.Beta3, when running on Windows, allows remote attackers to read arbitrary files via a .. (dot dot) in a resource URI.

CWE : Common Weakness Enumeration

%idName
28% (4) CWE-444 Inconsistent Interpretation of HTTP Requests ('HTTP Request Smuggli...
14% (2) CWE-400 Uncontrolled Resource Consumption ('Resource Exhaustion')
14% (2) CWE-200 Information Exposure
7% (1) CWE-532 Information Leak Through Log Files
7% (1) CWE-255 Credentials Management
7% (1) CWE-119 Failure to Constrain Operations within the Bounds of a Memory Buffer
7% (1) CWE-113 Failure to Sanitize CRLF Sequences in HTTP Headers ('HTTP Response ...
7% (1) CWE-22 Improper Limitation of a Pathname to a Restricted Directory ('Path ...
7% (1) CWE-20 Improper Input Validation

Nessus® Vulnerability Scanner

id Description
2017-12-15 Name: The remote Red Hat host is missing one or more security updates.
File: redhat-RHSA-2017-3454.nasl - Type: ACT_GATHER_INFO
2017-12-15 Name: The remote Red Hat host is missing one or more security updates.
File: redhat-RHSA-2017-3455.nasl - Type: ACT_GATHER_INFO
2017-12-14 Name: The remote Red Hat host is missing one or more security updates.
File: redhat-RHSA-2017-3458.nasl - Type: ACT_GATHER_INFO
2017-07-12 Name: The remote Debian host is missing a security-related update.
File: debian_DSA-3906.nasl - Type: ACT_GATHER_INFO