Executive Summary

Informations
NameCVE-2005-0005First vendor Publication2005-05-02
VendorCveLast vendor Modification2010-08-21

Security-Database Scoring CVSS v2

Cvss vector : (AV:N/AC:L/Au:N/C:P/I:P/A:P)
Cvss Base Score7.5Attack RangeNetwork
Cvss Impact Score6.4Attack ComplexityLow
Cvss Expoit Score10AuthenticationNone Required
Calculate full CVSS 2.0 Vectors scores

Security Protection

ImpactsProvides user account access : Allows partial confidentiality, integrity, and availability violation; Allows unauthorized disclosure of information; Allows disruption of service.

Detail

Heap-based buffer overflow in psd.c for ImageMagick 6.1.0, 6.1.7, and possibly earlier versions allows remote attackers to execute arbitrary code via a .PSD image file with a large number of layers.

Original Source

Url : http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-0005

OVAL Definitions

Definition Id: oval:org.mitre.oval:def:9925
 
Oval ID: oval:org.mitre.oval:def:9925
Title: Double free vulnerability in the Adobe Acrobat Reader Plugin before 8.0.0, as used in Mozilla Firefox 1.5.0.7, allows remote attackers to execute arbitrary code by causing an error via a javascript: URI call to document.write in the (1) FDF, (2) XML, or (3) XFDF AJAX request parameters.
Description: Heap-based buffer overflow in psd.c for ImageMagick 6.1.0, 6.1.7, and possibly earlier versions allows remote attackers to execute arbitrary code via a .PSD image file with a large number of layers.
Family: unix Class: vulnerability
Reference(s): CVE-2005-0005
Version: 5
Platform(s): Red Hat Enterprise Linux 3
CentOS Linux 3
Red Hat Enterprise Linux 4
CentOS Linux 4
Oracle Linux 4
Product(s):
Definition Synopsis:

CPE : Common Platform Enumeration

TypeDescriptionCount
Application5
Application24
Application1
Os11
Os8
Os8

OpenVAS Exploits

DateDescription
2008-09-24Name : Gentoo Security Advisory GLSA 200501-26 (imagemagick)
File : nvt/glsa_200501_26.nasl
2008-09-24Name : Gentoo Security Advisory GLSA 200501-37 (GraphicsMagick)
File : nvt/glsa_200501_37.nasl
2008-09-04Name : FreeBSD Ports: ImageMagick
File : nvt/freebsd_ImageMagick0.nasl
2008-01-17Name : Debian Security Advisory DSA 646-1 (imagemagick)
File : nvt/deb_646_1.nasl

Open Source Vulnerability Database (OSVDB)

idDescription
13028ImageMagick PSD Image Decoding Module Overflow

Nessus® Vulnerability Scanner

DateDescription
2006-01-15Name : The remote Ubuntu host is missing one or more security-related patches.
File : ubuntu_USN-62-1.nasl - Type : ACT_GATHER_INFO
2005-09-12Name : The remote Fedora Core host is missing a security update.
File : fedora_2005-235.nasl - Type : ACT_GATHER_INFO
2005-07-13Name : The remote FreeBSD host is missing one or more security-related updates.
File : freebsd_pkg_597e2bee68ea11d9a9e70001020eed82.nasl - Type : ACT_GATHER_INFO
2005-05-19Name : The remote Fedora Core host is missing a security update.
File : fedora_2005-234.nasl - Type : ACT_GATHER_INFO
2005-04-02Name : The remote Mandrake Linux host is missing one or more security updates.
File : mandrake_MDKSA-2005-065.nasl - Type : ACT_GATHER_INFO
2005-03-25Name : The remote Red Hat host is missing one or more security updates.
File : redhat-RHSA-2005-070.nasl - Type : ACT_GATHER_INFO
2005-02-22Name : The remote Red Hat host is missing one or more security updates.
File : redhat-RHSA-2005-071.nasl - Type : ACT_GATHER_INFO
2005-02-14Name : The remote Gentoo host is missing one or more security-related patches.
File : gentoo_GLSA-200501-26.nasl - Type : ACT_GATHER_INFO
2005-02-14Name : The remote Gentoo host is missing one or more security-related patches.
File : gentoo_GLSA-200501-37.nasl - Type : ACT_GATHER_INFO
2005-01-19Name : The remote Debian host is missing a security-related update.
File : debian_DSA-646.nasl - Type : ACT_GATHER_INFO

Internal Sources (Detail)

SourceUrl
BUGTRAQhttp://marc.theaimsgroup.com/?l=bugtraq&m=110608222117215&w=2
DEBIANhttp://www.debian.org/security/2005/dsa-646
GENTOOhttp://www.gentoo.org/security/en/glsa/glsa-200501-37.xml
IDEFENSEhttp://www.idefense.com/application/poi/display?id=184&type=vulnerabilities
REDHAThttp://www.redhat.com/support/errata/RHSA-2005-070.html
http://www.redhat.com/support/errata/RHSA-2005-071.html

Alert History

If you want to see full details history, please login or register.
0
1
DateInformations
2014-02-17 10:29:36
  • Multiple Updates
2013-05-11 11:19:26
  • Multiple Updates