Executive Summary

Summary
Title WALinuxAgent vulnerability
Informations
NameUSN-3907-1First vendor Publication2019-03-12
VendorUbuntuLast vendor Modification2019-03-12
Severity (Vendor) N/ARevisionN/A

Security-Database Scoring CVSS v2

Cvss vector :
Cvss Base ScoreN/AAttack RangeN/A
Cvss Impact ScoreN/AAttack ComplexityN/A
Cvss Expoit ScoreN/AAuthenticationN/A
Calculate full CVSS 2.0 Vectors scores

Detail

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 18.10 - Ubuntu 18.04 LTS - Ubuntu 16.04 LTS - Ubuntu 14.04 LTS

Summary:

WALinuxAgent could be made to expose sensitive information.

Software Description: - walinuxagent: Windows Azure Linux Agent

Details:

It was discovered that WALinuxAgent created swap files with incorrect permissions. A local attacker could possibly use this issue to obtain sensitive information from the swap file.

Update instructions:

The problem can be corrected by updating your system to the following package versions:

Ubuntu 18.10:
walinuxagent 2.2.32-0ubuntu1~18.10.2

Ubuntu 18.04 LTS:
walinuxagent 2.2.32-0ubuntu1~18.04.2

Ubuntu 16.04 LTS:
walinuxagent 2.2.32-0ubuntu1~16.04.2

Ubuntu 14.04 LTS:
walinuxagent 2.2.32-0ubuntu1~14.04.2

In general, a standard system update will make all the necessary changes.

References:
https://usn.ubuntu.com/usn/usn-3907-1
CVE-2019-0804

Package Information:
https://launchpad.net/ubuntu/+source/walinuxagent/2.2.32-0ubuntu1~18.10.2
https://launchpad.net/ubuntu/+source/walinuxagent/2.2.32-0ubuntu1~18.04.2
https://launchpad.net/ubuntu/+source/walinuxagent/2.2.32-0ubuntu1~16.04.2
https://launchpad.net/ubuntu/+source/walinuxagent/2.2.32-0ubuntu1~14.04.2

Original Source

Url : http://www.ubuntu.com/usn/USN-3907-1

Alert History

If you want to see full details history, please login or register.
0
DateInformations
2019-03-12 21:18:20
  • First insertion