Executive Summary

Summary
Titlesystemtap security update
Informations
NameRHSA-2009:0373First vendor Publication2009-03-26
VendorRedHatLast vendor Modification2009-03-26
Severity (Vendor) ModerateRevision01

Security-Database Scoring CVSS v2

Cvss vector : (AV:L/AC:M/Au:N/C:C/I:C/A:C)
Cvss Base Score6.9Attack RangeLocal
Cvss Impact Score10Attack ComplexityMedium
Cvss Expoit Score3.4AuthenticationNone Required
Calculate full CVSS 2.0 Vectors scores

Detail

Problem Description:

Updated systemtap packages that fix a security issue are now available for
Red Hat Enterprise Linux 4 and 5.

This update has been rated as having moderate security impact by the Red
Hat Security Response Team.

2. Relevant releases/architectures:

Red Hat Enterprise Linux (v. 5 server) - i386, ia64, ppc, s390x, x86_64
Red Hat Enterprise Linux AS version 4 - i386, ia64, ppc, x86_64
Red Hat Enterprise Linux Desktop (v. 5 client) - i386, x86_64
Red Hat Enterprise Linux Desktop version 4 - i386, x86_64
Red Hat Enterprise Linux ES version 4 - i386, ia64, x86_64
Red Hat Enterprise Linux WS version 4 - i386, ia64, x86_64

3. Description:

SystemTap is an instrumentation infrastructure for systems running version
2.6 of the Linux kernel. SystemTap scripts can collect system operations
data, greatly simplifying information gathering. Collected data can then
assist in performance measuring, functional testing, and performance and
function problem diagnosis.

A race condition was discovered in SystemTap that could allow users in the
stapusr group to elevate privileges to that of members of the stapdev group
(and hence root), bypassing directory confinement restrictions and allowing
them to insert arbitrary SystemTap kernel modules. (CVE-2009-0784)

Note: This issue was only exploitable if another SystemTap kernel module
was placed in the "systemtap/" module directory for the currently running
kernel.

Red Hat would like to thank Erik Sjölund for reporting this issue.

SystemTap users should upgrade to these updated packages, which contain a
backported patch to correct this issue.

4. Solution:

Before applying this update, make sure that all previously-released
errata relevant to your system have been applied.

This update is available via Red Hat Network. Details on how to use
the Red Hat Network to apply this update are available at
http://kbase.redhat.com/faq/docs/DOC-11259

5. Bugs fixed (http://bugzilla.redhat.com/):

489808 - CVE-2009-0784 systemtap: race condition leads to privilege escalation

Original Source

Url : https://rhn.redhat.com/errata/RHSA-2009-0373.html

CWE : Common Weakness Enumeration

idName
CWE-362Race Condition

OVAL Definitions

Definition Id: oval:org.mitre.oval:def:11613
 
Oval ID: oval:org.mitre.oval:def:11613
Title: Race condition in the SystemTap stap tool 0.0.20080705 and 0.0.20090314 allows local users in the stapusr group to insert arbitrary SystemTap kernel modules and gain privileges via unknown vectors.
Description: Race condition in the SystemTap stap tool 0.0.20080705 and 0.0.20090314 allows local users in the stapusr group to insert arbitrary SystemTap kernel modules and gain privileges via unknown vectors.
Family: unix Class: vulnerability
Reference(s): CVE-2009-0784
Version: 5
Platform(s): Red Hat Enterprise Linux 4
CentOS Linux 4
Oracle Linux 4
Red Hat Enterprise Linux 5
CentOS Linux 5
Oracle Linux 5
Product(s):
Definition Synopsis:
Definition Id: oval:org.mitre.oval:def:22797
 
Oval ID: oval:org.mitre.oval:def:22797
Title: ELSA-2009:0373: systemtap security update (Moderate)
Description: Race condition in the SystemTap stap tool 0.0.20080705 and 0.0.20090314 allows local users in the stapusr group to insert arbitrary SystemTap kernel modules and gain privileges via unknown vectors.
Family: unix Class: patch
Reference(s): ELSA-2009:0373-01
CVE-2009-0784
Version: 3
Platform(s): Oracle Linux 4
Oracle Linux 5
Product(s):
Definition Synopsis:

CPE : Common Platform Enumeration

TypeDescriptionCount
Application1

OpenVAS Exploits

DateDescription
2011-08-09Name : CentOS Update for systemtap CESA-2009:0373 centos4 i386
File : nvt/gb_CESA-2009_0373_systemtap_centos4_i386.nasl
2011-08-09Name : CentOS Update for systemtap CESA-2009:0373 centos5 i386
File : nvt/gb_CESA-2009_0373_systemtap_centos5_i386.nasl
2009-06-05Name : Ubuntu USN-743-1 (gs-gpl)
File : nvt/ubuntu_743_1.nasl
2009-06-05Name : Ubuntu USN-744-1 (lcms)
File : nvt/ubuntu_744_1.nasl
2009-04-15Name : CentOS Security Advisory CESA-2009:0373 (systemtap)
File : nvt/ovcesa2009_0373.nasl
2009-03-31Name : RedHat Security Advisory RHSA-2009:0373
File : nvt/RHSA_2009_0373.nasl
2009-03-31Name : Debian Security Advisory DSA 1755-1 (systemtap)
File : nvt/deb_1755_1.nasl

Open Source Vulnerability Database (OSVDB)

idDescription
53111SystemTap stap Module Loading Race Condition Local Privilege Escalation

Nessus® Vulnerability Scanner

DateDescription
2013-07-12Name : The remote Oracle Linux host is missing one or more security updates.
File : oraclelinux_ELSA-2009-0373.nasl - Type : ACT_GATHER_INFO
2012-08-01Name : The remote Scientific Linux host is missing one or more security updates.
File : sl_20090326_systemtap_on_SL4_x.nasl - Type : ACT_GATHER_INFO
2010-01-06Name : The remote CentOS host is missing one or more security updates.
File : centos_RHSA-2009-0373.nasl - Type : ACT_GATHER_INFO
2009-03-30Name : The remote Debian host is missing a security-related update.
File : debian_DSA-1755.nasl - Type : ACT_GATHER_INFO
2009-03-27Name : The remote Red Hat host is missing one or more security updates.
File : redhat-RHSA-2009-0373.nasl - Type : ACT_GATHER_INFO

Alert History

If you want to see full details history, please login or register.
0
DateInformations
2014-02-17 11:52:23
  • Multiple Updates