Executive Summary



This Alert is flagged as TOP 25 Common Weakness Enumeration from CWE/SANS. For more information, you can read this.
Informations
NameMDVSA-2015:200First vendor Publication2015-04-10
VendorMandrivaLast vendor Modification2015-04-10
Severity (Vendor) N/ARevisionN/A

Security-Database Scoring CVSS v2

Cvss vector : (AV:N/AC:M/Au:N/C:N/I:N/A:C)
Cvss Base Score7.1Attack RangeNetwork
Cvss Impact Score6.9Attack ComplexityMedium
Cvss Expoit Score8.6AuthenticationNone Required
Calculate full CVSS 2.0 Vectors scores

Detail

Updated mediawiki packages fix security vulnerabilities:

In MediaWiki before 1.23.9, one could circumvent the SVG MIME blacklist for embedded resources. This allowed an attacker to embed JavaScript in the SVG (CVE-2015-2931).

In MediaWiki before 1.23.9, the SVG filter to prevent injecting JavaScript using animate elements was incorrect (CVE-2015-2932).

In MediaWiki before 1.23.9, a stored XSS vulnerability exists due to the way attributes were expanded in MediaWiki's Html class, in combination with LanguageConverter substitutions (CVE-2015-2933).

In MediaWiki before 1.23.9, MediaWiki's SVG filtering could be bypassed with entity encoding under the Zend interpreter. This could be used to inject JavaScript (CVE-2015-2934).

In MediaWiki before 1.23.9, one could bypass the style filtering for SVG files to load external resources. This could violate the anonymity of users viewing the SVG (CVE-2015-2935).

In MediaWiki before 1.23.9, MediaWiki versions using PBKDF2 for password hashing (not the default for 1.23) are vulnerable to DoS attacks using extremely long passwords (CVE-2015-2936).

In MediaWiki before 1.23.9, MediaWiki is vulnerable to Quadratic Blowup DoS attacks, under both HHVM and Zend PHP (CVE-2015-2937).

In MediaWiki before 1.23.9, the MediaWiki feature allowing a user to preview another user's custom JavaScript could be abused for privilege escalation (CVE-2015-2938).

In MediaWiki before 1.23.9, function names were not sanitized in Lua error backtraces, which could lead to XSS (CVE-2015-2939).

In MediaWiki before 1.23.9, the CheckUser extension did not prevent CSRF attacks on the form allowing checkusers to look up sensitive information about other users. Since the use of CheckUser is logged, the CSRF could be abused to defame a trusted user or flood the logs with noise (CVE-2015-2940).

The mediawiki package has been updated to version 1.23.9, fixing these issues and other bugs.

Original Source

Url : http://www.mandriva.com/security/advisories?name=MDVSA-2015:200

CWE : Common Weakness Enumeration

%idName
60 %CWE-79Failure to Preserve Web Page Structure ('Cross-site Scripting') (CWE/SANS Top 25)
20 %CWE-399Resource Management Errors
10 %CWE-352Cross-Site Request Forgery (CSRF) (CWE/SANS Top 25)
10 %CWE-200Information Exposure

CPE : Common Platform Enumeration

TypeDescriptionCount
Application1
Application289
Application1

Nessus® Vulnerability Scanner

DateDescription
2015-11-02Name : The remote Gentoo host is missing one or more security-related patches.
File : gentoo_GLSA-201510-05.nasl - Type : ACT_GATHER_INFO
2015-06-12Name : The remote web server contains an application that is affected by multiple vu...
File : mediawiki_1_24_2.nasl - Type : ACT_GATHER_INFO
2015-04-10Name : The remote Mandriva Linux host is missing one or more security updates.
File : mandriva_MDVSA-2015-200.nasl - Type : ACT_GATHER_INFO

Alert History

If you want to see full details history, please login or register.
0
1
2
3
4
DateInformations
2015-04-14 21:30:20
  • Multiple Updates
2015-04-14 17:29:08
  • Multiple Updates
2015-04-13 21:30:23
  • Multiple Updates
2015-04-11 13:29:17
  • Multiple Updates
2015-04-10 09:25:12
  • First insertion