Executive Summary

Summary
Titlepump: User-assisted execution of arbitrary code
Informations
NameGLSA-201911-02First vendor Publication2019-11-07
VendorGentooLast vendor Modification2019-11-07
Severity (Vendor) N/ARevisionN/A

Security-Database Scoring CVSS v2

Cvss vector :
Cvss Base ScoreN/AAttack RangeN/A
Cvss Impact ScoreN/AAttack ComplexityN/A
Cvss Expoit ScoreN/AAuthenticationN/A
Calculate full CVSS 2.0 Vectors scores

Detail

Synopsis

A buffer overflow in pump might allow remote attacker to execute arbitrary code.

Background

BOOTP and DHCP client for automatic IP configuration.

Description

It was discovered that there was an arbitrary code execution vulnerability in the pump DHCP/BOOTP client.

Impact

A remote attacker, by enticing a user to connect to a malicious server, could cause the execution of arbitrary code with the privileges of the user running pump DHCP/BOOTP client.

Workaround

There is no known workaround at this time.

Resolution

Gentoo has discontinued support for pump. We recommend that users unmerge pump:
# emerge --unmerge "net-misc/pump"

References

[ 1 ] Debian Bug Report 933674
https://bugs.debian.org/933674

Availability

This GLSA and any updates to it are available for viewing at the Gentoo Security Website:

https://security.gentoo.org/glsa/201911-02

Original Source

Url : http://security.gentoo.org/glsa/glsa-201911-02.xml

Alert History

If you want to see full details history, please login or register.
0
DateInformations
2019-11-07 21:18:33
  • First insertion