Executive Summary



This Alert is flagged as TOP 25 Common Weakness Enumeration from CWE/SANS. For more information, you can read this.
Summary
TitleRust: Multiple vulnerabilities
Informations
NameGLSA-201812-11First vendor Publication2018-12-30
VendorGentooLast vendor Modification2018-12-30
Severity (Vendor) N/ARevisionN/A

Security-Database Scoring CVSS v2

Cvss vector : (AV:N/AC:L/Au:N/C:P/I:P/A:P)
Cvss Base Score7.5Attack RangeNetwork
Cvss Impact Score6.4Attack ComplexityLow
Cvss Expoit Score10AuthenticationNone Required
Calculate full CVSS 2.0 Vectors scores

Detail

Synopsis

Multiple vulnerabilities have been found in Rust, the worst which may allow local attackers to execute arbitrary code.

Background

A systems programming language that runs blazingly fast, prevents segfaults, and guarantees thread safety.

Description

Multiple vulnerabilities have been discovered in Rust. Please review the CVE identifiers referenced below for details.

Impact

A remote attacker able to control the value passed to Rust's str::repeat function could possibly cause a Denial of Service condition.

In addition, a local attacker could trick another user into executing arbitrary code when using rustdoc.

Workaround

There is no known workaround at this time.

Resolution

All Rust users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-lang/rust-1.29.1"

All Rust binary users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-lang/rust-bin-1.29.1"

References

[ 1 ] CVE-2018-1000622 : https://nvd.nist.gov/vuln/detail/CVE-2018-1000622
[ 2 ] CVE-2018-1000810 : https://nvd.nist.gov/vuln/detail/CVE-2018-1000810

Availability

This GLSA and any updates to it are available for viewing at the Gentoo Security Website:

https://security.gentoo.org/glsa/201812-11

Original Source

Url : http://security.gentoo.org/glsa/glsa-201812-11.xml

CWE : Common Weakness Enumeration

%idName
50 %CWE-427Uncontrolled Search Path Element
50 %CWE-190Integer Overflow or Wraparound (CWE/SANS Top 25)

CPE : Common Platform Enumeration

TypeDescriptionCount
Application47

Nessus® Vulnerability Scanner

DateDescription
2019-01-03Name : The remote Fedora host is missing a security update.
File : fedora_2018-499d74c768.nasl - Type : ACT_GATHER_INFO
2019-01-03Name : The remote Fedora host is missing a security update.
File : fedora_2018-0071ad34f4.nasl - Type : ACT_GATHER_INFO
2019-01-03Name : The remote Fedora host is missing a security update.
File : fedora_2018-63fd68397e.nasl - Type : ACT_GATHER_INFO
2018-12-31Name : The remote Gentoo host is missing one or more security-related patches.
File : gentoo_GLSA-201812-11.nasl - Type : ACT_GATHER_INFO
2018-07-24Name : The remote Fedora host is missing a security update.
File : fedora_2018-f38d1cb219.nasl - Type : ACT_GATHER_INFO

Alert History

If you want to see full details history, please login or register.
0
1
DateInformations
2019-01-04 21:22:22
  • Multiple Updates
2018-12-31 00:18:51
  • First insertion