Executive Summary



This Alert is flagged as TOP 25 Common Weakness Enumeration from CWE/SANS. For more information, you can read this.
Summary
TitleRPM: Multiple vulnerabilities
Informations
NameGLSA-201811-22First vendor Publication2018-11-28
VendorGentooLast vendor Modification2018-11-28
Severity (Vendor) N/ARevisionN/A

Security-Database Scoring CVSS v2

Cvss vector : (AV:N/AC:L/Au:N/C:C/I:C/A:C)
Cvss Base Score10Attack RangeNetwork
Cvss Impact Score10Attack ComplexityLow
Cvss Expoit Score10AuthenticationNone Required
Calculate full CVSS 2.0 Vectors scores

Detail

Synopsis

Multiple vulnerabilities have been found in RPM, the worst of which could allow a remote attacker to escalate privileges.

Background

The Red Hat Package Manager (RPM) is a command line driven package management system capable of installing, uninstalling, verifying, querying, and updating computer software packages.

Description

Multiple vulnerabilities have been discovered in RPM. Please review the CVE identifiers referenced below for details.

Impact

A remote attacker, by enticing the user to process a specially crafted RPM file, could escalate privileges, execute arbitrary code, or cause a Denial of Service condition.

Workaround

There is no known workaround at this time.

Resolution

All RPM users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose ">=app-arch/rpm-4.14.1"

References

[ 1 ] CVE-2013-6435 : https://nvd.nist.gov/vuln/detail/CVE-2013-6435
[ 2 ] CVE-2014-8118 : https://nvd.nist.gov/vuln/detail/CVE-2014-8118
[ 3 ] CVE-2017-7501 : https://nvd.nist.gov/vuln/detail/CVE-2017-7501

Availability

This GLSA and any updates to it are available for viewing at the Gentoo Security Website:

https://security.gentoo.org/glsa/201811-22

Original Source

Url : http://security.gentoo.org/glsa/glsa-201811-22.xml

CWE : Common Weakness Enumeration

%idName
33 %CWE-189Numeric Errors (CWE/SANS Top 25)
33 %CWE-74Failure to Sanitize Data into a Different Plane ('Injection')
33 %CWE-59Improper Link Resolution Before File Access ('Link Following')

OVAL Definitions

Definition Id: oval:org.mitre.oval:def:28661
 
Oval ID: oval:org.mitre.oval:def:28661
Title: RHSA-2014:1974 -- rpm security update (Important)
Description: The RPM Package Manager (RPM) is a powerful command line driven package management system capable of installing, uninstalling, verifying, querying, and updating software packages. Each software package consists of an archive of files along with information about the package such as its version, description, and other information. It was found that RPM wrote file contents to the target installation directory under a temporary name, and verified its cryptographic signature only after the temporary file has been written completely. Under certain conditions, the system interprets the unverified temporary file contents and extracts commands from it. This could allow an attacker to modify signed RPM files in such a way that they would execute code chosen by the attacker during package installation. (CVE-2013-6435) This issue was discovered by Florian Weimer of Red Hat Product Security. All rpm users are advised to upgrade to these updated packages, which contain a backported patch to correct this issue. All running applications linked against the RPM library must be restarted for this update to take effect.
Family: unix Class: patch
Reference(s): RHSA-2014:1974
CESA-2014:1974-CentOS 6
CESA-2014:1974-CentOS 5
CVE-2013-6435
Version: 3
Platform(s): Red Hat Enterprise Linux 5
Red Hat Enterprise Linux 6
CentOS Linux 6
CentOS Linux 5
Product(s): rpm
Definition Synopsis:
Definition Id: oval:org.mitre.oval:def:28261
 
Oval ID: oval:org.mitre.oval:def:28261
Title: ELSA-2014-1974 -- rpm security update (important)
Description: [4.4.2.3-36.0.1] - Add missing files in /usr/share/doc/ [4.8.0-36] - Fix warning when applying the patch for #1163057 [4.8.0-35] - Fix race condidition where unchecked data is exposed in the file system (CVE-2013-6435)(#1163057)
Family: unix Class: patch
Reference(s): ELSA-2014-1974
CVE-2013-6435
Version: 3
Platform(s): Oracle Linux 5
Oracle Linux 6
Product(s): rpm
Definition Synopsis:
Definition Id: oval:org.mitre.oval:def:28615
 
Oval ID: oval:org.mitre.oval:def:28615
Title: ELSA-2014-1976 -- rpm security update (important)
Description: [4.11.1-18] - Add check against malicious CPIO file name size (#1163060) - Fixes CVE-2014-8118 [4.11.1-17] - Fix race condidition where unchecked data is exposed in the file system (#1163060) - Fixes CVE-2013-6435
Family: unix Class: patch
Reference(s): ELSA-2014-1976
CVE-2013-6435
CVE-2014-8118
Version: 3
Platform(s): Oracle Linux 7
Product(s): rpm
Definition Synopsis:
Definition Id: oval:org.mitre.oval:def:28437
 
Oval ID: oval:org.mitre.oval:def:28437
Title: RHSA-2014:1976 -- rpm security update (Important)
Description: The RPM Package Manager (RPM) is a powerful command line driven package management system capable of installing, uninstalling, verifying, querying, and updating software packages. Each software package consists of an archive of files along with information about the package such as its version, description, and other information. It was found that RPM wrote file contents to the target installation directory under a temporary name, and verified its cryptographic signature only after the temporary file has been written completely. Under certain conditions, the system interprets the unverified temporary file contents and extracts commands from it. This could allow an attacker to modify signed RPM files in such a way that they would execute code chosen by the attacker during package installation. (CVE-2013-6435) It was found that RPM could encounter an integer overflow, leading to a stack-based buffer overflow, while parsing a crafted CPIO header in the payload section of an RPM file. This could allow an attacker to modify signed RPM files in such a way that they would execute code chosen by the attacker during package installation. (CVE-2014-8118) These issues were discovered by Florian Weimer of Red Hat Product Security. All rpm users are advised to upgrade to these updated packages, which contain backported patches to correct these issues. All running applications linked against the RPM library must be restarted for this update to take effect.
Family: unix Class: patch
Reference(s): RHSA-2014:1976
CESA-2014:1976
CVE-2013-6435
CVE-2014-8118
Version: 3
Platform(s): Red Hat Enterprise Linux 7
CentOS Linux 7
Product(s): rpm
Definition Synopsis:

CPE : Common Platform Enumeration

TypeDescriptionCount
Application114
Os1

Nessus® Vulnerability Scanner

DateDescription
2018-11-29Name : The remote Gentoo host is missing one or more security-related patches.
File : gentoo_GLSA-201811-22.nasl - Type : ACT_GATHER_INFO
2018-11-06Name : The remote EulerOS host is missing a security update.
File : EulerOS_SA-2018-1353.nasl - Type : ACT_GATHER_INFO
2018-08-17Name : The remote PhotonOS host is missing multiple security updates.
File : PhotonOS_PHSA-2017-1_0-0095.nasl - Type : ACT_GATHER_INFO
2017-11-29Name : The remote Fedora host is missing a security update.
File : fedora_2017-ab57a100f3.nasl - Type : ACT_GATHER_INFO
2017-11-08Name : The remote Fedora host is missing a security update.
File : fedora_2017-9232eac8e8.nasl - Type : ACT_GATHER_INFO
2016-06-22Name : The remote OracleVM host is missing one or more security updates.
File : oraclevm_OVMSA-2016-0077.nasl - Type : ACT_GATHER_INFO
2016-01-28Name : The remote device is missing a vendor-supplied security patch.
File : f5_bigip_SOL16383.nasl - Type : ACT_GATHER_INFO
2015-03-26Name : The remote Debian host is missing a security update.
File : debian_DLA-140.nasl - Type : ACT_GATHER_INFO
2015-03-19Name : The remote Mandriva Linux host is missing one or more security updates.
File : mandriva_MDVSA-2015-056.nasl - Type : ACT_GATHER_INFO
2015-01-20Name : The remote Ubuntu host is missing a security-related patch.
File : ubuntu_USN-2479-1.nasl - Type : ACT_GATHER_INFO
2015-01-19Name : The remote Debian host is missing a security-related update.
File : debian_DSA-3129.nasl - Type : ACT_GATHER_INFO
2014-12-30Name : The remote Fedora host is missing a security update.
File : fedora_2014-16838.nasl - Type : ACT_GATHER_INFO
2014-12-29Name : The remote openSUSE host is missing a security update.
File : openSUSE-2014-816.nasl - Type : ACT_GATHER_INFO
2014-12-26Name : The remote SuSE 11 host is missing one or more security updates.
File : suse_11_popt-141215.nasl - Type : ACT_GATHER_INFO
2014-12-17Name : The remote Fedora host is missing a security update.
File : fedora_2014-16890.nasl - Type : ACT_GATHER_INFO
2014-12-15Name : The remote Mandriva Linux host is missing one or more security updates.
File : mandriva_MDVSA-2014-251.nasl - Type : ACT_GATHER_INFO
2014-12-15Name : The remote OracleVM host is missing one or more security updates.
File : oraclevm_OVMSA-2014-0083.nasl - Type : ACT_GATHER_INFO
2014-12-15Name : The remote Scientific Linux host is missing one or more security updates.
File : sl_20141209_rpm_on_SL5_x.nasl - Type : ACT_GATHER_INFO
2014-12-15Name : The remote Scientific Linux host is missing one or more security updates.
File : sl_20141209_rpm_on_SL7_x.nasl - Type : ACT_GATHER_INFO
2014-12-15Name : The remote CentOS host is missing one or more security updates.
File : centos_RHSA-2014-1976.nasl - Type : ACT_GATHER_INFO
2014-12-10Name : The remote Amazon Linux AMI host is missing a security update.
File : ala_ALAS-2014-458.nasl - Type : ACT_GATHER_INFO
2014-12-10Name : The remote CentOS host is missing one or more security updates.
File : centos_RHSA-2014-1974.nasl - Type : ACT_GATHER_INFO
2014-12-10Name : The remote Oracle Linux host is missing one or more security updates.
File : oraclelinux_ELSA-2014-1974.nasl - Type : ACT_GATHER_INFO
2014-12-10Name : The remote Oracle Linux host is missing one or more security updates.
File : oraclelinux_ELSA-2014-1976.nasl - Type : ACT_GATHER_INFO
2014-12-10Name : The remote Red Hat host is missing one or more security updates.
File : redhat-RHSA-2014-1974.nasl - Type : ACT_GATHER_INFO
2014-12-10Name : The remote Red Hat host is missing one or more security updates.
File : redhat-RHSA-2014-1975.nasl - Type : ACT_GATHER_INFO
2014-12-10Name : The remote Red Hat host is missing one or more security updates.
File : redhat-RHSA-2014-1976.nasl - Type : ACT_GATHER_INFO

Alert History

If you want to see full details history, please login or register.
0
DateInformations
2018-11-29 05:17:14
  • First insertion