This CPE summary could be partial or incomplete. Please contact us for a detailed listing.

Summary

Summuary
CPE Namecpe:/o:microsoft:windows:-
Detail
VendorMicrosoftFirst view 2005-11-03
ProductWindowsLast view2019-07-18
Version-TypeOs
Edition 
Language 
Update 
 
CPE Productcpe:/o:microsoft:windows

Activity : Overall

Related : CVE

This CPE have more than 25 Relations. If you want to see a complete summary for this CPE, please contact us.
 DateAlertAccess VectorAccess ComplexityAuthentication
4.32019-07-18CVE-2019-7963NetworkMediumNone Requ...
6.82019-07-18CVE-2019-7956NetworkMediumNone Requ...
52019-07-18CVE-2019-7941NetworkLowNone Requ...
7.52019-07-18CVE-2019-7850NetworkLowNone Requ...
52019-07-18CVE-2019-7848NetworkLowNone Requ...
Hide | Show 20 More...
 DateAlertAccess VectorAccess ComplexityAuthentication
52019-07-18CVE-2019-7847NetworkLowNone Requ...
52019-07-18CVE-2019-7846NetworkLowNone Requ...
52019-07-18CVE-2019-7843NetworkLowNone Requ...
9.32019-07-11CVE-2019-12574NetworkMediumNone Requ...
9.32019-07-07CVE-2019-13404NetworkMediumNone Requ...
7.52019-07-06CVE-2019-13375NetworkLowNone Requ...
4.32019-07-06CVE-2019-13374NetworkMediumNone Requ...
7.52019-07-06CVE-2019-13373NetworkLowNone Requ...
7.22019-07-05CVE-2019-1932LocalLowNone Requ...
4.62019-07-02CVE-2019-5443LocalLowNone Requ...
7.22019-07-01CVE-2019-4154LocalLowNone Requ...
4.32019-07-01CVE-2019-4102NetworkMediumNone Requ...
2.12019-07-01CVE-2019-4101LocalLowNone Requ...
7.22019-07-01CVE-2019-4057LocalLowNone Requ...
6.82019-06-27CVE-2019-5806NetworkMediumNone Requ...
7.22019-06-21CVE-2019-12572LocalLowNone Requ...
6.92019-06-18CVE-2019-7588LocalMediumNone Requ...
7.22019-06-17CVE-2019-12476LocalLowNone Requ...
6.82019-06-17CVE-2018-19450NetworkMediumNone Requ...

CWE : Common Weakness Enumeration

This CPE have more than 25 Relations. If you want to see a complete summary for this CPE, please contact us.
%idName
23% (399)CWE-119Failure to Constrain Operations within the Bounds of a Memory Buffer
19% (336)CWE-416Use After Free
16% (286)CWE-125Out-of-bounds Read
6% (107)CWE-264Permissions, Privileges, and Access Controls
4% (82)CWE-787Out-of-bounds Write
Hide | Show 20 More...
%idName
4% (81)CWE-20Improper Input Validation
4% (79)CWE-704Incorrect Type Conversion or Cast
4% (79)CWE-200Information Exposure
2% (51)CWE-284Access Control (Authorization) Issues
2% (35)CWE-476NULL Pointer Dereference
1% (28)CWE-426Untrusted Search Path
1% (20)CWE-190Integer Overflow or Wraparound
0% (15)CWE-22Improper Limitation of a Pathname to a Restricted Directory ('Path ...
0% (13)CWE-399Resource Management Errors
0% (11)CWE-254Security Features
0% (9)CWE-362Race Condition
0% (8)CWE-189Numeric Errors
0% (8)CWE-79Failure to Preserve Web Page Structure ('Cross-site Scripting')
0% (7)CWE-77Improper Sanitization of Special Elements used in a Command ('Comma...
0% (6)CWE-275Permission Issues
0% (6)CWE-129Improper Validation of Array Index
0% (5)CWE-415Double Free
0% (4)CWE-287Improper Authentication
0% (4)CWE-94Failure to Control Generation of Code ('Code Injection')
0% (3)CWE-601URL Redirection to Untrusted Site ('Open Redirect')

Oval Markup Language : Definitions

This CPE have more than 25 Relations. If you want to see a complete summary for this CPE, please contact us.
OvalIDName
oval:org.mitre.oval:def:24605Adobe Flash Player before 13.0.0.214 on Windows, Adobe AIR SDK before 13.0.0....
oval:org.mitre.oval:def:15980Unspecified vulnerability which allows attackers to cause a denial of service...
oval:org.mitre.oval:def:11842Unspecified vulnerability which allows attackers to cause a denial of service...
oval:org.mitre.oval:def:15862Adobe Flash Player before 10.3.183.11 and 11.x before 11.1.102.55 on Windows,...
oval:org.mitre.oval:def:14231Adobe Flash Player before 10.3.183.11 and 11.x before 11.1.102.55 on Windows,...
Hide | Show 20 More...
idName
oval:org.mitre.oval:def:19802Adobe Flash Player before 11.7.700.252 and 11.8.x and 11.9.x before 11.9.900....
oval:org.mitre.oval:def:16281Unspecified vulnerability which cause a denial of service (memory corruption)...
oval:org.mitre.oval:def:12179Unspecified vulnerability which cause a denial of service (memory corruption)...
oval:org.mitre.oval:def:22499RHSA-2014:0028: flash-plugin security update (Critical)
oval:org.mitre.oval:def:22228Adobe Flash Player before 11.7.700.260 and 11.8.x and 11.9.x before 12.0.0.38...
oval:org.mitre.oval:def:24087ELSA-2014:0028: flash-plugin security update (Critical)
oval:org.mitre.oval:def:25528SUSE-SU-2014:0116-1 -- Security update for flash-player
oval:org.mitre.oval:def:20004Adobe Flash Player before in Adobe Flash Player before 10.3.183.63 and 11.x b...
oval:org.mitre.oval:def:25763SUSE-SU-2013:0296-1 -- Security update for flash-player
oval:org.mitre.oval:def:15761Adobe Flash Player before 10.3.183.11 and 11.x before 11.1.102.55 on Windows,...
oval:org.mitre.oval:def:14312Adobe Flash Player before 10.3.183.11 and 11.x before 11.1.102.55 on Windows,...
oval:org.mitre.oval:def:28602Adobe Flash Player 14.x though 16.0.0.296 and 13.x through 13.0.0.264 could ...
oval:org.mitre.oval:def:24595Adobe Flash Player before 13.0.0.214 on Windows, Adobe AIR SDK before 13.0.0....
oval:org.mitre.oval:def:20073Integer overflow in Adobe Flash Player before in Adobe Flash Player before 10...
oval:org.mitre.oval:def:20395Buffer overflow in Adobe Flash Player before 10.3.183.48 and 11.x before 11.5...
oval:org.mitre.oval:def:16220Unspecified vulnerability which allows attackers to cause a denial of service...
oval:org.mitre.oval:def:11660Unspecified vulnerability which allows attackers to cause a denial of service...
oval:org.mitre.oval:def:12625Unspecified vulnerability which allows attackers to cause a denial of service...
oval:org.mitre.oval:def:11310Unspecified vulnerability which allows attackers to cause a denial of service...
oval:org.mitre.oval:def:20438RHSA-2013:0574: flash-plugin security update (Critical)

SAINT Exploits

DescriptionLink
Adobe Pixel ShaderMore info here
Adobe Flash Player SWF Content Regular Expression Heap OverflowMore info here
Adobe Flash Player Object Confusion Code ExecutionMore info here

Open Source Vulnerability Database (OSVDB)

This CPE have more than 25 Relations. If you want to see a complete summary for this CPE, please contact us.
idDescription
77029Adobe Flash Player Unspecified Remote Memory Corruption (2011-2460)
77028Adobe Flash Player Unspecified Remote Memory Corruption (2011-2459)
77027Adobe Flash Player for IE Unspecified Same Origin Policy Bypass
77026Adobe Flash Player Unspecified Remote Overflow (2011-2457)
77025Adobe Flash Player Unspecified Remote Overflow (2011-2456)
Hide | Show 20 More...
idDescription
77024Adobe Flash Player Unspecified Remote Memory Corruption (2011-2455)
77023Adobe Flash Player Unspecified Remote Memory Corruption (2011-2454)
77022Adobe Flash Player Unspecified Remote Memory Corruption (2011-2453)
77021Adobe Flash Player Unspecified Remote Memory Corruption (2011-2452)
77020Adobe Flash Player Unspecified Remote Memory Corruption (2011-2451)
77019Adobe Flash Player Unspecified Remote Overflow (2011-2450)
77018Adobe Flash Player Unspecified Remote Memory Corruption (2011-2445)
74691Google Chrome Command Line Unspecified URL Parsing Confusion Issue
72093Mozilla Firefox WebGLES Library Off-by-three Memory Corruption
69146Adobe Flash Unspecified Cross-Domain Policy Bypass (2010-3636)
69135Adobe Flash ActiveX Unspecified Memory Corruption (2010-3637)
69133Adobe Flash Unspecified DoS (2010-3639)
69132Adobe Flash Unspecified Memory Corruption (2010-3640)
69131Adobe Flash Unspecified Memory Corruption (2010-3641)
69130Adobe Flash Unspecified Memory Corruption (2010-3642)
69129Adobe Flash Unspecified Memory Corruption (2010-3643)
69128Adobe Flash Unspecified Memory Corruption (2010-3644)
69127Adobe Flash Unspecified Memory Corruption (2010-3645)
69126Adobe Flash Unspecified Memory Corruption (2010-3646)
69125Adobe Flash Unspecified Memory Corruption (2010-3647)

ExploitDB Exploits

idDescription
33333Adobe Flash Player Shader Buffer Overflow
33212Adobe Flash Player Integer Underflow Remote Code Execution
33095Adobe Flash Player Type Confusion Remote Code Execution
32959Adobe Flash Player Regular Expression Heap Overflow
19369Adobe Flash Player Object Type Confusion
Hide | Show 1 More...
idDescription
15426Adobe Flash ActionIf Integer Denial of Service Vulnerability

OpenVAS Exploits

This CPE have more than 25 Relations. If you want to see a complete summary for this CPE, please contact us.
idDescription
2013-03-28Name : Adobe Air Multiple Vulnerabilities - December12 (Mac OS X)
File : nvt/gb_adobe_air_mult_vuln_dec12_macosx.nasl
2013-03-28Name : Adobe Air Multiple Vulnerabilities - December12 (Windows)
File : nvt/gb_adobe_air_mult_vuln_dec12_win.nasl
2013-03-28Name : Adobe Air Multiple Vulnerabilities - November12 (Mac OS X)
File : nvt/gb_adobe_air_mult_vuln_nov12_macosx.nasl
2013-03-28Name : Adobe Air Multiple Vulnerabilities - November12 (Windows)
File : nvt/gb_adobe_air_mult_vuln_nov12_win.nasl
2013-03-28Name : Adobe Air Multiple Vulnerabilities - October 12 (Mac OS X)
File : nvt/gb_adobe_air_mult_vuln_oct12_macosx.nasl
Hide | Show 20 More...
idDescription
2013-03-28Name : Adobe Air Multiple Vulnerabilities - October 12 (Windows)
File : nvt/gb_adobe_air_mult_vuln_oct12_win.nasl
2012-12-14Name : Adobe Flash Player Multiple Vulnerabilities - December12 (Linux)
File : nvt/gb_adobe_flash_player_mult_vuln_dec12_lin.nasl
2012-12-14Name : Adobe Flash Player Multiple Vulnerabilities - December12 (Mac OS X)
File : nvt/gb_adobe_prdts_mult_vuln_dec12_macosx.nasl
2012-12-14Name : Adobe Flash Player Multiple Vulnerabilities - December12 (Windows)
File : nvt/gb_adobe_prdts_mult_vuln_dec12_win.nasl
2012-12-13Name : SuSE Update for update openSUSE-SU-2012:0594-1 (update)
File : nvt/gb_suse_2012_0594_1.nasl
2012-12-13Name : SuSE Update for flash-player openSUSE-SU-2012:1480-1 (flash-player)
File : nvt/gb_suse_2012_1480_1.nasl
2012-11-26Name : FreeBSD Ports: linux-f10-flashplugin
File : nvt/freebsd_linux-f10-flashplugin4.nasl
2012-11-26Name : FreeBSD Ports: linux-f10-flashplugin
File : nvt/freebsd_linux-f10-flashplugin5.nasl
2012-11-08Name : Adobe Flash Player Multiple Vulnerabilities - November12 (Mac OS X)
File : nvt/gb_adobe_prdts_mult_vuln_nov12_macosx.nasl
2012-11-08Name : Adobe Flash Player Multiple Vulnerabilities - November12 (Windows)
File : nvt/gb_adobe_prdts_mult_vuln_nov12_win.nasl
2012-11-08Name : Adobe Flash Player Multiple Vulnerabilities - November12 (Linux)
File : nvt/gb_adobe_flash_player_mult_vuln_nov12_lin.nasl
2012-10-15Name : Adobe Flash Player Multiple Vulnerabilities - October 12 (Mac OS X)
File : nvt/gb_adobe_prdts_mult_vuln_oct12_macosx.nasl
2012-10-15Name : Adobe Flash Player Multiple Vulnerabilities - October 12 (Windows)
File : nvt/gb_adobe_prdts_mult_vuln_oct12_win.nasl
2012-10-15Name : Adobe Flash Player Multiple Vulnerabilities - Oct12 (Linux)
File : nvt/gb_adobe_flash_player_mult_vuln_oct12_lin.nasl
2012-09-15Name : Gentoo Security Advisory GLSA 201209-01 (adobe-flash)
File : nvt/glsa_201209_01.nasl
2012-09-03Name : Adobe Flash Player Multiple Vulnerabilities - Sep12 (Linux)
File : nvt/gb_adobe_flash_player_mult_vuln_sep12_lin.nasl
2012-08-24Name : Adobe Flash Player Multiple Vulnerabilities -01 August 12 (Mac OS X)
File : nvt/gb_adobe_prdts_mult_vuln01_aug12_macosx.nasl
2012-08-24Name : Adobe Flash Player Multiple Vulnerabilities -01 August 12 (Windows)
File : nvt/gb_adobe_prdts_mult_vuln01_aug12_win.nasl
2012-08-10Name : Gentoo Security Advisory GLSA 201206-21 (Adobe Flash Player)
File : nvt/glsa_201206_21.nasl
2012-05-08Name : Adobe Flash Player Object Confusion Remote Code Execution Vulnerability (Linux)
File : nvt/gb_adobe_flash_player_obj_code_exec_vuln_lin.nasl

Information Assurance Vulnerability Management (IAVM)

idDescription
2015-A-0221Multiple Vulnerabilities in Adobe Flash Player and AIR
Severity : Category I - VMSKEY : V0061469
2014-A-0069Multiple Vulnerabilities in Adobe Flash Player and AIR
Severity : Category I - VMSKEY : V0050437
2014-A-0060Adobe Flash Player Buffer Overflow Vulnerability
Severity : Category I - VMSKEY : V0050013
2014-A-0034Multiple Vulnerabilities in Adobe Flash Player
Severity : Category I - VMSKEY : V0046181
2014-A-0029Multiple Vulnerabilities in Adobe Flash Player and AIR
Severity : Category I - VMSKEY : V0044537
Hide | Show 6 More...
idDescription
2014-A-0020Adobe Flash Player Remote Code Execution Vulnerability
Severity : Category I - VMSKEY : V0043920
2014-A-0001Multiple Vulnerabilities in Adobe Flash Player and AIR
Severity : Category I - VMSKEY : V0043404
2013-A-0229Multiple Vulnerabilities in Adobe Flash Player
Severity : Category I - VMSKEY : V0042595
2013-A-0209Multiple Vulnerabilities in Adobe Flash Player
Severity : Category I - VMSKEY : V0042292
2013-A-0168Multiple Vulnerabilities In Adobe Flash Player
Severity : Category I - VMSKEY : V0040297
2012-B-0048Multiple Vulnerabilities in HP Systems Insight Manager
Severity : Category I - VMSKEY : V0032178

Snort® IPS/IDS

This CPE have more than 25 Relations. If you want to see a complete summary for this CPE, please contact us.
DateDescription
2014-01-10.cmd? access
RuleID : 9791 - Type : SERVER-WEBAPP - Revision : 8
2014-01-10.bat? access
RuleID : 976-community - Type : SERVER-WEBAPP - Revision : 21
2014-01-10.bat? access
RuleID : 976 - Type : SERVER-WEBAPP - Revision : 21
2019-07-16Adobe Acrobat double free attempt
RuleID : 50449 - Type : FILE-PDF - Revision : 1
2019-07-16Adobe Acrobat double free attempt
RuleID : 50448 - Type : FILE-PDF - Revision : 1
Hide | Show 20 More...
DateDescription
2019-07-04Adobe Acrobat execCalculate use after free attempt
RuleID : 50298 - Type : FILE-PDF - Revision : 2
2019-07-04Adobe Acrobat execCalculate use after free attempt
RuleID : 50297 - Type : FILE-PDF - Revision : 2
2019-07-04Apple Webkit updateDescendantDependentFlags use-after-free attempt
RuleID : 50294 - Type : BROWSER-WEBKIT - Revision : 1
2019-07-04Apple Webkit updateDescendantDependentFlags use-after-free attempt
RuleID : 50293 - Type : BROWSER-WEBKIT - Revision : 1
2019-07-02Adobe Acrobat out-of-bounds read attempt
RuleID : 50272 - Type : FILE-PDF - Revision : 1
2019-07-02Adobe Acrobat out-of-bounds read attempt
RuleID : 50271 - Type : FILE-PDF - Revision : 1
2019-07-02Adobe Flash Player use after free attempt
RuleID : 50268 - Type : FILE-FLASH - Revision : 1
2019-07-02Adobe Flash Player use after free attempt
RuleID : 50267 - Type : FILE-FLASH - Revision : 1
2019-07-02Adobe Acrobat out-of-bounds read attempt
RuleID : 50257 - Type : FILE-OTHER - Revision : 1
2019-07-02Adobe Acrobat out-of-bounds read attempt
RuleID : 50256 - Type : FILE-OTHER - Revision : 1
2019-07-02Adobe Acrobat out-of-bounds write attempt
RuleID : 50255 - Type : FILE-PDF - Revision : 1
2019-07-02Adobe Acrobat out-of-bounds write attempt
RuleID : 50254 - Type : FILE-PDF - Revision : 1
2019-07-02Adobe Acrobat out-of-bounds write attempt
RuleID : 50253 - Type : FILE-IMAGE - Revision : 1
2019-07-02Adobe Acrobat out-of-bounds write attempt
RuleID : 50252 - Type : FILE-IMAGE - Revision : 1
2019-07-02Adobe Acrobat out-of-bounds write attempt
RuleID : 50251 - Type : FILE-PDF - Revision : 1
2019-07-02Adobe Acrobat out-of-bounds write attempt
RuleID : 50250 - Type : FILE-PDF - Revision : 1
2019-07-02Adobe Acrobat out-of-bounds read attempt
RuleID : 50249 - Type : FILE-OTHER - Revision : 1
2019-07-02Adobe Acrobat out-of-bounds read attempt
RuleID : 50248 - Type : FILE-OTHER - Revision : 1
2019-07-02Adobe Acrobat out-of-bounds write attempt
RuleID : 50247 - Type : FILE-IMAGE - Revision : 1
2019-07-02Adobe Acrobat out-of-bounds write attempt
RuleID : 50246 - Type : FILE-IMAGE - Revision : 1

Nessus® Vulnerability Scanner

This CPE have more than 25 Relations. If you want to see a complete summary for this CPE, please contact us.
idDescription
2019-01-18Name : A PDF toolkit installed on the remote Windows host is affected by multiple vu...
File : foxit_phantom_8_3_9.nasl - Type : ACT_GATHER_INFO
2019-01-16Name : The remote database server is affected by multiple vulnerabilities
File : mariadb_10_0_37.nasl - Type : ACT_GATHER_INFO
2019-01-09Name : A PDF toolkit installed on the remote Windows host is affected by a multiple ...
File : foxit_phantom_9_4.nasl - Type : ACT_GATHER_INFO
2019-01-09Name : A PDF viewer installed on the remote Windows host is affected by multiple vul...
File : foxit_reader_9_4.nasl - Type : ACT_GATHER_INFO
2019-01-04Name : The version of Adobe Acrobat installed on the remote Windows host is affected...
File : adobe_acrobat_apsb19-02.nasl - Type : ACT_GATHER_INFO
Hide | Show 20 More...
idDescription
2019-01-04Name : The version of Adobe Reader installed on the remote Windows host is affected ...
File : adobe_reader_apsb19-02.nasl - Type : ACT_GATHER_INFO
2019-01-04Name : The version of Adobe Acrobat installed on the remote macOS host is affected b...
File : macosx_adobe_acrobat_apsb19-02.nasl - Type : ACT_GATHER_INFO
2019-01-04Name : The version of Adobe Reader installed on the remote macOS host is affected by...
File : macosx_adobe_reader_apsb19-02.nasl - Type : ACT_GATHER_INFO
2019-01-03Name : The remote Fedora host is missing a security update.
File : fedora_2018-e2e8a07a01.nasl - Type : ACT_GATHER_INFO
2019-01-03Name : The remote Fedora host is missing a security update.
File : fedora_2018-97c58e29e4.nasl - Type : ACT_GATHER_INFO
2019-01-03Name : The remote Fedora host is missing a security update.
File : fedora_2018-499f2dbc96.nasl - Type : ACT_GATHER_INFO
2019-01-03Name : The remote Fedora host is missing a security update.
File : fedora_2018-a1f37d2f08.nasl - Type : ACT_GATHER_INFO
2019-01-03Name : The remote Fedora host is missing a security update.
File : fedora_2018-509fc4a5c8.nasl - Type : ACT_GATHER_INFO
2019-01-03Name : The backup service installed on the remote host is affected by a denial of se...
File : ibm_spectrum_protect_8_1_6_1.nasl - Type : ACT_GATHER_INFO
2019-01-03Name : The remote Fedora host is missing a security update.
File : fedora_2018-55b875c1ac.nasl - Type : ACT_GATHER_INFO
2019-01-03Name : The remote Fedora host is missing a security update.
File : fedora_2018-b1832101b8.nasl - Type : ACT_GATHER_INFO
2019-01-03Name : The remote Fedora host is missing a security update.
File : fedora_2018-b4820696e1.nasl - Type : ACT_GATHER_INFO
2019-01-03Name : The remote Fedora host is missing a security update.
File : fedora_2018-118b9abf99.nasl - Type : ACT_GATHER_INFO
2019-01-03Name : The remote Fedora host is missing a security update.
File : fedora_2018-1a8582a7ee.nasl - Type : ACT_GATHER_INFO
2019-01-03Name : The remote Fedora host is missing a security update.
File : fedora_2018-c82fc3e109.nasl - Type : ACT_GATHER_INFO
2019-01-03Name : The remote Fedora host is missing a security update.
File : fedora_2018-242f6c1a41.nasl - Type : ACT_GATHER_INFO
2018-12-21Name : The remote Apple TV device is affected by multiple vulnerabilities.
File : appletv_12_1_1.nasl - Type : ACT_GATHER_INFO
2018-12-19Name : An application installed on remote host is affected by multiple vulnerabilities
File : itunes_12_9_2.nasl - Type : ACT_GATHER_INFO
2018-12-18Name : A web browser installed on the remote macOS host is affected by multiple vuln...
File : macosx_firefox_62_0.nasl - Type : ACT_GATHER_INFO
2018-12-14Name : The version of Adobe Acrobat installed on the remote Windows host is affected...
File : adobe_acrobat_apsb18-41.nasl - Type : ACT_GATHER_INFO