Executive Summary

Summary
Title Wireshark vulnerabilities
Informations
Name USN-4133-1 First vendor Publication 2019-09-16
Vendor Ubuntu Last vendor Modification 2019-09-16
Severity (Vendor) N/A Revision N/A

Security-Database Scoring CVSS v3

Cvss vector : N/A
Overall CVSS Score NA
Base Score NA Environmental Score NA
impact SubScore NA Temporal Score NA
Exploitabality Sub Score NA
 
Calculate full CVSS 3.0 Vectors scores

Security-Database Scoring CVSS v2

Cvss vector : (AV:N/AC:L/Au:N/C:N/I:N/A:P)
Cvss Base Score 5 Attack Range Network
Cvss Impact Score 2.9 Attack Complexity Low
Cvss Expoit Score 10 Authentication None Required
Calculate full CVSS 2.0 Vectors scores

Detail

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 19.04 - Ubuntu 18.04 LTS - Ubuntu 16.04 LTS

Summary:

Wireshark could be made to crash if it received specially crafted network traffic or input files.

Software Description: - wireshark: network traffic analyzer

Details:

It was discovered that Wireshark improperly handled certain input. A remote or local attacker could cause Wireshark to crash by injecting malformed packets onto the wire or convincing someone to read a malformed packet trace file.

Update instructions:

The problem can be corrected by updating your system to the following package versions:

Ubuntu 19.04:
libwireshark-data 2.6.10-1~ubuntu19.04.0
libwireshark11 2.6.10-1~ubuntu19.04.0
libwiretap8 2.6.10-1~ubuntu19.04.0
libwscodecs2 2.6.10-1~ubuntu19.04.0
libwsutil9 2.6.10-1~ubuntu19.04.0
tshark 2.6.10-1~ubuntu19.04.0
wireshark 2.6.10-1~ubuntu19.04.0
wireshark-common 2.6.10-1~ubuntu19.04.0
wireshark-gtk 2.6.10-1~ubuntu19.04.0
wireshark-qt 2.6.10-1~ubuntu19.04.0

Ubuntu 18.04 LTS:
libwireshark-data 2.6.10-1~ubuntu18.04.0
libwireshark11 2.6.10-1~ubuntu18.04.0
libwiretap8 2.6.10-1~ubuntu18.04.0
libwscodecs2 2.6.10-1~ubuntu18.04.0
libwsutil9 2.6.10-1~ubuntu18.04.0
tshark 2.6.10-1~ubuntu18.04.0
wireshark 2.6.10-1~ubuntu18.04.0
wireshark-common 2.6.10-1~ubuntu18.04.0
wireshark-gtk 2.6.10-1~ubuntu18.04.0
wireshark-qt 2.6.10-1~ubuntu18.04.0

Ubuntu 16.04 LTS:
libwireshark-data 2.6.10-1~ubuntu16.04.0
libwireshark11 2.6.10-1~ubuntu16.04.0
libwiretap8 2.6.10-1~ubuntu16.04.0
libwscodecs2 2.6.10-1~ubuntu16.04.0
libwsutil9 2.6.10-1~ubuntu16.04.0
tshark 2.6.10-1~ubuntu16.04.0
wireshark 2.6.10-1~ubuntu16.04.0
wireshark-common 2.6.10-1~ubuntu16.04.0
wireshark-gtk 2.6.10-1~ubuntu16.04.0
wireshark-qt 2.6.10-1~ubuntu16.04.0

This update uses a new upstream release, which includes additional bug fixes. In general, a standard system update will make all the necessary changes.

References:
https://usn.ubuntu.com/4133-1
CVE-2019-12295, CVE-2019-13619

Package Information:
https://launchpad.net/ubuntu/+source/wireshark/2.6.10-1~ubuntu19.04.0
https://launchpad.net/ubuntu/+source/wireshark/2.6.10-1~ubuntu18.04.0
https://launchpad.net/ubuntu/+source/wireshark/2.6.10-1~ubuntu16.04.0

Original Source

Url : http://www.ubuntu.com/usn/USN-4133-1

CWE : Common Weakness Enumeration

% Id Name
50 % CWE-119 Failure to Constrain Operations within the Bounds of a Memory Buffer
50 % CWE-94 Failure to Control Generation of Code ('Code Injection')

CPE : Common Platform Enumeration

TypeDescriptionCount
Application 229
Os 3
Os 1
Os 2
Os 2

Alert History

If you want to see full details history, please login or register.
0
Date Informations
2019-09-16 09:17:37
  • First insertion