Executive Summary



This Alert is flagged as TOP 25 Common Weakness Enumeration from CWE/SANS. For more information, you can read this.
Summary
Title GIFLIB vulnerabilities
Informations
Name USN-4107-1 First vendor Publication 2019-08-20
Vendor Ubuntu Last vendor Modification 2019-08-20
Severity (Vendor) N/A Revision N/A

Security-Database Scoring CVSS v3

Cvss vector : N/A
Overall CVSS Score NA
Base Score NA Environmental Score NA
impact SubScore NA Temporal Score NA
Exploitabality Sub Score NA
 
Calculate full CVSS 3.0 Vectors scores

Security-Database Scoring CVSS v2

Cvss vector : (AV:N/AC:M/Au:N/C:P/I:P/A:P)
Cvss Base Score 6.8 Attack Range Network
Cvss Impact Score 6.4 Attack Complexity Medium
Cvss Expoit Score 8.6 Authentication None Required
Calculate full CVSS 2.0 Vectors scores

Detail

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 19.04 - Ubuntu 18.04 LTS - Ubuntu 16.04 LTS

Summary:

Several security issues were fixed in GIFLIB.

Software Description: - giflib: library for GIF images (utilities)

Details:

It was discovered that GIFLIB incorrectly handled certain GIF files. An attacker could possibly use this issue to cause a denial of service. This issue only affected Ubuntu 18.04 LTS. (CVE-2016-3977)

It was discovered that GIFLIB incorrectly handled certain GIF files. An attacker could possibly use this issue to cause a denial of service. (CVE-2018-11490, CVE-2019-15133)

Update instructions:

The problem can be corrected by updating your system to the following package versions:

Ubuntu 19.04:
giflib-tools 5.1.4-3ubuntu0.1
libgif7 5.1.4-3ubuntu0.1

Ubuntu 18.04 LTS:
giflib-tools 5.1.4-2ubuntu0.1
libgif7 5.1.4-2ubuntu0.1

Ubuntu 16.04 LTS:
giflib-tools 5.1.4-0.3~16.04.1
libgif7 5.1.4-0.3~16.04.1

In general, a standard system update will make all the necessary changes.

References:
https://usn.ubuntu.com/4107-1
CVE-2016-3977, CVE-2018-11490, CVE-2019-15133

Package Information:
https://launchpad.net/ubuntu/+source/giflib/5.1.4-3ubuntu0.1
https://launchpad.net/ubuntu/+source/giflib/5.1.4-2ubuntu0.1
https://launchpad.net/ubuntu/+source/giflib/5.1.4-0.3~16.04.1

Original Source

Url : http://www.ubuntu.com/usn/USN-4107-1

CWE : Common Weakness Enumeration

% Id Name
25 % CWE-787 Out-of-bounds Write (CWE/SANS Top 25)
25 % CWE-369 Divide By Zero
25 % CWE-129 Improper Validation of Array Index
25 % CWE-119 Failure to Constrain Operations within the Bounds of a Memory Buffer

CPE : Common Platform Enumeration

TypeDescriptionCount
Application 2
Application 1
Os 3
Os 1

Nessus® Vulnerability Scanner

Date Description
2016-05-05 Name : The remote openSUSE host is missing a security update.
File : openSUSE-2016-556.nasl - Type : ACT_GATHER_INFO
2016-04-27 Name : The remote SUSE host is missing one or more security updates.
File : suse_SU-2016-1139-1.nasl - Type : ACT_GATHER_INFO
2016-04-27 Name : The remote SUSE host is missing one or more security updates.
File : suse_SU-2016-1140-1.nasl - Type : ACT_GATHER_INFO
2016-04-21 Name : The remote openSUSE host is missing a security update.
File : openSUSE-2016-492.nasl - Type : ACT_GATHER_INFO
2016-04-21 Name : The remote openSUSE host is missing a security update.
File : openSUSE-2016-497.nasl - Type : ACT_GATHER_INFO

Alert History

If you want to see full details history, please login or register.
0
Date Informations
2019-08-20 21:19:14
  • First insertion