Executive Summary

Summary
Titlesendmail security update
Informations
NameRHSA-2006:0515First vendor Publication2006-06-14
VendorRedHatLast vendor Modification2006-06-14
Severity (Vendor) ImportantRevision01

Security-Database Scoring CVSS v2

Cvss vector : (AV:N/AC:L/Au:N/C:N/I:N/A:P)
Cvss Base Score5Attack RangeNetwork
Cvss Impact Score2.9Attack ComplexityLow
Cvss Expoit Score10AuthenticationNone Required
Calculate full CVSS 2.0 Vectors scores

Detail

Problem Description:

Updated sendmail packages are now available to fix a denial of service security issue.

This update has been rated as having important security impact by the Red Hat Security Response Team.

2. Relevant releases/architectures:

Red Hat Enterprise Linux AS (Advanced Server) version 2.1 - i386, ia64 Red Hat Linux Advanced Workstation 2.1 - ia64 Red Hat Enterprise Linux ES version 2.1 - i386 Red Hat Enterprise Linux WS version 2.1 - i386 Red Hat Enterprise Linux AS version 3 - i386, ia64, ppc, s390, s390x, x86_64 Red Hat Desktop version 3 - i386, x86_64 Red Hat Enterprise Linux ES version 3 - i386, ia64, x86_64 Red Hat Enterprise Linux WS version 3 - i386, ia64, x86_64 Red Hat Enterprise Linux AS version 4 - i386, ia64, ppc, s390, s390x, x86_64 Red Hat Enterprise Linux Desktop version 4 - i386, x86_64 Red Hat Enterprise Linux ES version 4 - i386, ia64, x86_64 Red Hat Enterprise Linux WS version 4 - i386, ia64, x86_64

3. Problem description:

Sendmail is a Mail Transport Agent (MTA) used to send mail between machines.

A flaw in the handling of multi-part MIME messages was discovered in Sendmail. A remote attacker could create a carefully crafted message that could crash the sendmail process during delivery (CVE-2006-1173). By default on Red Hat Enterprise Linux, Sendmail is configured to only accept connections from the local host. Therefore, only users who have configured Sendmail to listen to remote hosts would be remotely vulnerable to this issue.

Users of Sendmail are advised to upgrade to these erratum packages, which contain a backported patch from the Sendmail team to correct this issue.

4. Solution:

Before applying this update, make sure all previously released errata relevant to your system have been applied.

This update is available via Red Hat Network. To use Red Hat Network, launch the Red Hat Update Agent with the following command:

up2date

This will start an interactive process that will result in the appropriate RPMs being upgraded on your system.

5. Bug IDs fixed (http://bugzilla.redhat.com/):

Original Source

Url : https://rhn.redhat.com/errata/RHSA-2006-0515.html

CAPEC : Common Attack Pattern Enumeration & Classification

idName
CAPEC-2Inducing Account Lockout
CAPEC-82Violating Implicit Assumptions Regarding XML Content (aka XML Denial of Servi...
CAPEC-147XML Ping of Death
CAPEC-228Resource Depletion through DTD Injection in a SOAP Message

CWE : Common Weakness Enumeration

%idName
100 %CWE-399Resource Management Errors

OVAL Definitions

Definition Id: oval:org.mitre.oval:def:11253
 
Oval ID: oval:org.mitre.oval:def:11253
Title: Sendmail before 8.13.7 allows remote attackers to cause a denial of service via deeply nested, malformed multipart MIME messages that exhaust the stack during the recursive mime8to7 function for performing 8-bit to 7-bit conversion, which prevents Sendmail from delivering queued messages and might lead to disk consumption by core dump files.
Description: Sendmail before 8.13.7 allows remote attackers to cause a denial of service via deeply nested, malformed multipart MIME messages that exhaust the stack during the recursive mime8to7 function for performing 8-bit to 7-bit conversion, which prevents Sendmail from delivering queued messages and might lead to disk consumption by core dump files.
Family: unix Class: vulnerability
Reference(s): CVE-2006-1173
Version: 5
Platform(s): Red Hat Enterprise Linux 3
CentOS Linux 3
Red Hat Enterprise Linux 4
CentOS Linux 4
Oracle Linux 4
Product(s):
Definition Synopsis:

CPE : Common Platform Enumeration

TypeDescriptionCount
Application66

OpenVAS Exploits

DateDescription
2008-09-24Name : Gentoo Security Advisory GLSA 200606-19 (sendmail)
File : nvt/glsa_200606_19.nasl
2008-09-04Name : FreeBSD Security Advisory (FreeBSD-SA-06:17.sendmail.asc)
File : nvt/freebsdsa_sendmail2.nasl
2008-01-17Name : Debian Security Advisory DSA 1155-1 (sendmail)
File : nvt/deb_1155_1.nasl
2008-01-17Name : Debian Security Advisory DSA 1155-2 (sendmail)
File : nvt/deb_1155_2.nasl
0000-00-00Name : Slackware Advisory SSA:2006-166-01 sendmail
File : nvt/esoft_slk_ssa_2006_166_01.nasl

Open Source Vulnerability Database (OSVDB)

idDescription
26197Sendmail Multi-Part MIME Message Handling DoS

Nessus® Vulnerability Scanner

DateDescription
2013-03-13Name : The remote AIX host is missing a vendor-supplied security patch.
File : aix_U477911.nasl - Type : ACT_GATHER_INFO
2013-03-13Name : The remote AIX host is missing a vendor-supplied security patch.
File : aix_U497412.nasl - Type : ACT_GATHER_INFO
2007-12-03Name : The remote AIX host is missing a vendor-supplied security patch.
File : aix_U806039.nasl - Type : ACT_GATHER_INFO
2007-12-03Name : The remote AIX host is missing a vendor-supplied security patch.
File : aix_U807468.nasl - Type : ACT_GATHER_INFO
2007-02-18Name : The remote host is missing a vendor-supplied security patch
File : suse_SA_2006_032.nasl - Type : ACT_GATHER_INFO
2007-01-17Name : The remote Fedora Core host is missing a security update.
File : fedora_2006-836.nasl - Type : ACT_GATHER_INFO
2007-01-17Name : The remote Fedora Core host is missing a security update.
File : fedora_2006-837.nasl - Type : ACT_GATHER_INFO
2006-10-14Name : The remote Debian host is missing a security-related update.
File : debian_DSA-1155.nasl - Type : ACT_GATHER_INFO
2006-08-08Name : The remote HP-UX host is missing a security-related patch.
File : hpux_PHNE_34689.nasl - Type : ACT_GATHER_INFO
2006-08-08Name : The remote HP-UX host is missing a security-related patch.
File : hpux_PHNE_34900.nasl - Type : ACT_GATHER_INFO
2006-08-08Name : The remote HP-UX host is missing a security-related patch.
File : hpux_PHNE_34927.nasl - Type : ACT_GATHER_INFO
2006-08-08Name : The remote HP-UX host is missing a security-related patch.
File : hpux_PHNE_34936.nasl - Type : ACT_GATHER_INFO
2006-07-03Name : The remote CentOS host is missing one or more security updates.
File : centos_RHSA-2006-0515.nasl - Type : ACT_GATHER_INFO
2006-06-16Name : The remote Mandrake Linux host is missing one or more security updates.
File : mandrake_MDKSA-2006-104.nasl - Type : ACT_GATHER_INFO
2006-06-16Name : The remote Red Hat host is missing one or more security updates.
File : redhat-RHSA-2006-0515.nasl - Type : ACT_GATHER_INFO
2006-06-16Name : The remote Gentoo host is missing one or more security-related patches.
File : gentoo_GLSA-200606-19.nasl - Type : ACT_GATHER_INFO
2006-06-16Name : The remote Slackware host is missing a security update.
File : Slackware_SSA_2006-166-01.nasl - Type : ACT_GATHER_INFO
2004-07-12Name : The remote host is missing Sun Security Patch number 114137-10
File : solaris9_x86_114137.nasl - Type : ACT_GATHER_INFO
2004-07-12Name : The remote host is missing Sun Security Patch number 113575-11
File : solaris9_113575.nasl - Type : ACT_GATHER_INFO

Alert History

If you want to see full details history, please login or register.
0
DateInformations
2014-02-17 11:50:03
  • Multiple Updates