Executive Summary



This Alert is flagged as TOP 25 Common Weakness Enumeration from CWE/SANS. For more information, you can read this.
Summary
Title SQLite: Remote code execution
Informations
Name GLSA-201904-21 First vendor Publication 2019-04-22
Vendor Gentoo Last vendor Modification 2019-04-22
Severity (Vendor) N/A Revision N/A

Security-Database Scoring CVSS v3

Cvss vector : N/A
Overall CVSS Score NA
Base Score NA Environmental Score NA
impact SubScore NA Temporal Score NA
Exploitabality Sub Score NA
 
Calculate full CVSS 3.0 Vectors scores

Security-Database Scoring CVSS v2

Cvss vector : (AV:N/AC:M/Au:N/C:P/I:P/A:P)
Cvss Base Score 6.8 Attack Range Network
Cvss Impact Score 6.4 Attack Complexity Medium
Cvss Expoit Score 8.6 Authentication None Required
Calculate full CVSS 2.0 Vectors scores

Detail

Synopsis

A vulnerability in SQLite may allow for the remote execution of code.

Background

SQLite is a C library that implements an SQL database engine.

Description

An integer overflow was discovered in SQLite's FTS3 extension.

Impact

A remote attacker could, by executing arbitrary SQL statements against a vulnerable host, execute arbitrary code.

Workaround

There is no known workaround at this time.

Resolution

All SQLite users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-db/sqlite-3.25.3"

References

[ 1 ] CVE-2018-20346 : https://nvd.nist.gov/vuln/detail/CVE-2018-20346

Availability

This GLSA and any updates to it are available for viewing at the Gentoo Security Website:

https://security.gentoo.org/glsa/201904-21

Original Source

Url : http://security.gentoo.org/glsa/glsa-201904-21.xml

CWE : Common Weakness Enumeration

% Id Name
100 % CWE-190 Integer Overflow or Wraparound (CWE/SANS Top 25)

CPE : Common Platform Enumeration

TypeDescriptionCount
Application