Executive Summary

Summary
TitleGnuTLS: Multiple vulnerabilities
Informations
NameGLSA-201904-14First vendor Publication2019-04-15
VendorGentooLast vendor Modification2019-04-15
Severity (Vendor) N/ARevisionN/A

Security-Database Scoring CVSS v2

Cvss vector : (AV:N/AC:L/Au:N/C:N/I:N/A:P)
Cvss Base Score5Attack RangeNetwork
Cvss Impact Score2.9Attack ComplexityLow
Cvss Expoit Score10AuthenticationNone Required
Calculate full CVSS 2.0 Vectors scores

Detail

Synopsis

Multiple vulnerabilities have been found in GnuTLS, the worst of which could result in a Denial of Service condition.

Background

GnuTLS is a secure communications library implementing the SSL, TLS and DTLS protocols and technologies around them.

Description

Multiple vulnerabilities have been discovered in GnuTLS. Please review the CVE identifiers referenced below for details.

Impact

Please review the CVE identifiers referenced below for details.

Workaround

There is no known workaround at this time.

Resolution

All GnuTLS users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose ">=net-libs/gnutls-3.6.7"

References

[ 1 ] CVE-2019-3829 : https://nvd.nist.gov/vuln/detail/CVE-2019-3829
[ 2 ] CVE-2019-3836 : https://nvd.nist.gov/vuln/detail/CVE-2019-3836

Availability

This GLSA and any updates to it are available for viewing at the Gentoo Security Website:

https://security.gentoo.org/glsa/201904-14

Original Source

Url : http://security.gentoo.org/glsa/glsa-201904-14.xml

CWE : Common Weakness Enumeration

%idName
50 %CWE-416Use After Free
50 %CWE-415Double Free

CPE : Common Platform Enumeration

TypeDescriptionCount
Application19
Os2
Os1

Alert History

If you want to see full details history, please login or register.
0
DateInformations
2019-04-16 00:18:18
  • First insertion