Executive Summary

Informations
Name CVE-2019-14812 First vendor Publication 2019-11-27
Vendor Cve Last vendor Modification 2020-04-01

Security-Database Scoring CVSS v3

Cvss vector : CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Overall CVSS Score 7.8
Base Score 7.8 Environmental Score 7.8
impact SubScore 5.9 Temporal Score 7.8
Exploitabality Sub Score 1.8
 
Attack Vector Local Attack Complexity Low
Privileges Required None User Interaction Required
Scope Unchanged Confidentiality Impact High
Integrity Impact High Availability Impact High
Calculate full CVSS 3.0 Vectors scores

Security-Database Scoring CVSS v2

Cvss vector : (AV:N/AC:M/Au:N/C:P/I:P/A:P)
Cvss Base Score 6.8 Attack Range Network
Cvss Impact Score 6.4 Attack Complexity Medium
Cvss Expoit Score 8.6 Authentication None Required
Calculate full CVSS 2.0 Vectors scores

Detail

A flaw was found in all ghostscript versions 9.x before 9.50, in the .setuserparams2 procedure where it did not properly secure its privileged calls, enabling scripts to bypass `-dSAFER` restrictions. A specially crafted PostScript file could disable security protection and then have access to the file system, or execute arbitrary commands.

Original Source

Url : http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-14812

CWE : Common Weakness Enumeration

% Id Name
100 % CWE-269 Improper Privilege Management

CPE : Common Platform Enumeration

TypeDescriptionCount
Application 26
Os 1

Sources (Detail)

Source Url
CONFIRM http://git.ghostscript.com/?p=ghostpdl.git;a=commitdiff;h=885444fcbe10dc42787...
https://access.redhat.com/security/cve/cve-2019-14812
https://bugs.ghostscript.com/show_bug.cgi?id=701444
https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-14812
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedorapr...
GENTOO https://security.gentoo.org/glsa/202004-03

Alert History

If you want to see full details history, please login or register.
0
Date Informations
2020-05-23 02:24:59
  • First insertion