Executive Summary

Informations
Name CVE-2015-5315 First vendor Publication 2018-02-21
Vendor Cve Last vendor Modification 2018-03-21

Security-Database Scoring CVSS v3

Cvss vector : CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
Overall CVSS Score 5.9
Base Score 5.9 Environmental Score 5.9
impact SubScore 3.6 Temporal Score 5.9
Exploitabality Sub Score 2.2
 
Attack Vector Network Attack Complexity High
Privileges Required None User Interaction None
Scope Unchanged Confidentiality Impact None
Integrity Impact None Availability Impact High
Calculate full CVSS 3.0 Vectors scores

Security-Database Scoring CVSS v2

Cvss vector : (AV:N/AC:M/Au:N/C:N/I:N/A:P)
Cvss Base Score 4.3 Attack Range Network
Cvss Impact Score 2.9 Attack Complexity Medium
Cvss Expoit Score 8.6 Authentication None Required
Calculate full CVSS 2.0 Vectors scores

Detail

The eap_pwd_process function in eap_peer/eap_pwd.c in wpa_supplicant 2.x before 2.6 does not validate that the reassembly buffer is large enough for the final fragment when EAP-pwd is enabled in a network configuration profile, which allows remote attackers to cause a denial of service (process termination) via a large final fragment in an EAP-pwd message.

Original Source

Url : http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-5315

CWE : Common Weakness Enumeration

% Id Name
100 % CWE-119 Failure to Constrain Operations within the Bounds of a Memory Buffer

CPE : Common Platform Enumeration

TypeDescriptionCount
Application 73
Os 1

Nessus® Vulnerability Scanner

Date Description
2017-03-30 Name : The remote FreeBSD host is missing a security-related update.
File : freebsd_pkg_04bc4e239a7042cb9fec3613632d34bc.nasl - Type : ACT_GATHER_INFO
2016-04-19 Name : The remote FreeBSD host is missing one or more security-related updates.
File : freebsd_pkg_976567f605c511e694fa002590263bf5.nasl - Type : ACT_GATHER_INFO
2015-11-11 Name : The remote Debian host is missing a security-related update.
File : debian_DSA-3397.nasl - Type : ACT_GATHER_INFO
2015-11-11 Name : The remote Ubuntu host is missing one or more security-related patches.
File : ubuntu_USN-2808-1.nasl - Type : ACT_GATHER_INFO

Sources (Detail)

Source Url
CONFIRM http://w1.fi/security/2015-7/eap-pwd-missing-last-fragment-length-validation.txt
DEBIAN https://www.debian.org/security/2015/dsa-3397
MLIST http://www.openwall.com/lists/oss-security/2015/11/10/10
UBUNTU http://www.ubuntu.com/usn/USN-2808-1

Alert History

If you want to see full details history, please login or register.
0
1
2
3
4
5
6
Date Informations
2020-05-23 01:56:17
  • Multiple Updates
2020-05-23 00:45:57
  • Multiple Updates
2019-07-23 12:01:12
  • Multiple Updates
2018-04-20 12:02:48
  • Multiple Updates
2018-03-21 17:19:18
  • Multiple Updates
2018-02-23 09:20:08
  • Multiple Updates
2018-02-21 21:20:31
  • First insertion