Executive Summary

Informations
Name CVE-2014-3158 First vendor Publication 2014-11-15
Vendor Cve Last vendor Modification 2020-02-24

Security-Database Scoring CVSS v3

Cvss vector : N/A
Overall CVSS Score NA
Base Score NA Environmental Score NA
impact SubScore NA Temporal Score NA
Exploitabality Sub Score NA
 
Calculate full CVSS 3.0 Vectors scores

Security-Database Scoring CVSS v2

Cvss vector : (AV:N/AC:L/Au:N/C:P/I:P/A:P)
Cvss Base Score 7.5 Attack Range Network
Cvss Impact Score 6.4 Attack Complexity Low
Cvss Expoit Score 10 Authentication None Required
Calculate full CVSS 2.0 Vectors scores

Detail

Integer overflow in the getword function in options.c in pppd in Paul's PPP Package (ppp) before 2.4.7 allows attackers to "access privileged options" via a long word in an options file, which triggers a heap-based buffer overflow that "[corrupts] security-relevant variables."

Original Source

Url : http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-3158

CWE : Common Weakness Enumeration

% Id Name
100 % CWE-119 Failure to Constrain Operations within the Bounds of a Memory Buffer

OVAL Definitions

Definition Id: oval:org.mitre.oval:def:26520
 
Oval ID: oval:org.mitre.oval:def:26520
Title: SUSE-SU-2014:1088-1 -- Security update for ppp
Description: This ppp update fixes a potential security issue that an unprivileged attacker could access privileged options: * integer overflow in option parsing (CVE-2014-3158, bnc#891489) Security Issues: * CVE-2014-3158 <http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-3158>
Family: unix Class: patch
Reference(s): SUSE-SU-2014:1088-1
CVE-2014-3158
Version: 3
Platform(s): SUSE Linux Enterprise Server 11
SUSE Linux Enterprise Desktop 11
Product(s): ppp
Definition Synopsis:
Definition Id: oval:org.mitre.oval:def:28067
 
Oval ID: oval:org.mitre.oval:def:28067
Title: DSA-3079-1 -- ppp security update
Description: A vulnerability was discovered in ppp, an implementation of the Point-to-Point Protocol: an integer overflow in the routine responsible for parsing user-supplied options potentially allows a local attacker to gain root privileges.
Family: unix Class: patch
Reference(s): DSA-3079-1
CVE-2014-3158
Version: 3
Platform(s): Debian GNU/Linux 7.0
Debian GNU/kFreeBSD 7.0
Product(s): ppp
Definition Synopsis:
Definition Id: oval:org.mitre.oval:def:28448
 
Oval ID: oval:org.mitre.oval:def:28448
Title: USN-2429-1 -- ppp vulnerability
Description: It was discovered that ppp incorrectly handled certain options files. A local attacker could possibly use this issue to escalate privileges.
Family: unix Class: patch
Reference(s): USN-2429-1
CVE-2014-3158
Version: 5
Platform(s): Ubuntu 14.10
Ubuntu 14.04
Ubuntu 12.04
Ubuntu 10.04
Product(s): ppp
Definition Synopsis:

CPE : Common Platform Enumeration

TypeDescriptionCount
Application 5

Nessus® Vulnerability Scanner

Date Description
2015-04-22 Name : The remote Slackware host is missing a security update.
File : Slackware_SSA_2015-111-11.nasl - Type : ACT_GATHER_INFO
2015-03-30 Name : The remote Mandriva Linux host is missing one or more security updates.
File : mandriva_MDVSA-2015-135.nasl - Type : ACT_GATHER_INFO
2015-03-26 Name : The remote Debian host is missing a security update.
File : debian_DLA-74.nasl - Type : ACT_GATHER_INFO
2014-12-15 Name : The remote Gentoo host is missing one or more security-related patches.
File : gentoo_GLSA-201412-19.nasl - Type : ACT_GATHER_INFO
2014-12-02 Name : The remote Ubuntu host is missing a security-related patch.
File : ubuntu_USN-2429-1.nasl - Type : ACT_GATHER_INFO
2014-12-01 Name : The remote Debian host is missing a security-related update.
File : debian_DSA-3079.nasl - Type : ACT_GATHER_INFO
2014-09-17 Name : The remote openSUSE host is missing a security update.
File : openSUSE-2014-545.nasl - Type : ACT_GATHER_INFO
2014-09-12 Name : The remote Mandriva Linux host is missing one or more security updates.
File : mandriva_MDVSA-2014-178.nasl - Type : ACT_GATHER_INFO
2014-09-04 Name : The remote SuSE 11 host is missing a security update.
File : suse_11_ppp-140826.nasl - Type : ACT_GATHER_INFO
2014-08-30 Name : The remote Fedora host is missing a security update.
File : fedora_2014-9401.nasl - Type : ACT_GATHER_INFO
2014-08-23 Name : The remote Fedora host is missing a security update.
File : fedora_2014-9412.nasl - Type : ACT_GATHER_INFO

Sources (Detail)

Source Url
CONFIRM http://advisories.mageia.org/MGASA-2014-0368.html
http://www.oracle.com/technetwork/topics/security/bulletinapr2015-2511959.html
https://bugzilla.redhat.com/show_bug.cgi?id=1128748
https://github.com/paulusmack/ppp/commit/7658e8257183f062dc01f87969c140707c7e...
DEBIAN http://www.debian.org/security/2014/dsa-3079
FEDORA http://lists.fedoraproject.org/pipermail/package-announce/2014-August/136932....
MANDRIVA http://www.mandriva.com/security/advisories?name=MDVSA-2015:135
MLIST http://marc.info/?l=linux-ppp&m=140764978420764
UBUNTU http://www.ubuntu.com/usn/USN-2429-1

Alert History

If you want to see full details history, please login or register.
0
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
Date Informations
2020-05-23 01:51:53
  • Multiple Updates
2020-05-23 00:40:47
  • Multiple Updates
2018-08-14 12:05:55
  • Multiple Updates
2016-10-25 09:21:51
  • Multiple Updates
2016-04-27 00:42:15
  • Multiple Updates
2015-09-16 21:23:00
  • Multiple Updates
2015-04-23 13:30:28
  • Multiple Updates
2015-04-15 09:27:52
  • Multiple Updates
2015-03-31 13:28:25
  • Multiple Updates
2015-03-27 13:28:08
  • Multiple Updates
2014-12-16 13:25:13
  • Multiple Updates
2014-12-07 09:25:40
  • Multiple Updates
2014-12-03 13:28:21
  • Multiple Updates
2014-12-01 13:27:05
  • Multiple Updates
2014-11-17 17:23:25
  • Multiple Updates
2014-11-16 05:34:06
  • First insertion