Executive Summary

Informations
Name CVE-2013-6420 First vendor Publication 2013-12-16
Vendor Cve Last vendor Modification 2018-10-30

Security-Database Scoring CVSS v3

Cvss vector : N/A
Overall CVSS Score NA
Base Score NA Environmental Score NA
impact SubScore NA Temporal Score NA
Exploitabality Sub Score NA
 
Calculate full CVSS 3.0 Vectors scores

Security-Database Scoring CVSS v2

Cvss vector : (AV:N/AC:L/Au:N/C:P/I:P/A:P)
Cvss Base Score 7.5 Attack Range Network
Cvss Impact Score 6.4 Attack Complexity Low
Cvss Expoit Score 10 Authentication None Required
Calculate full CVSS 2.0 Vectors scores

Detail

The asn1_time_to_time_t function in ext/openssl/openssl.c in PHP before 5.3.28, 5.4.x before 5.4.23, and 5.5.x before 5.5.7 does not properly parse (1) notBefore and (2) notAfter timestamps in X.509 certificates, which allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption) via a crafted certificate that is not properly handled by the openssl_x509_parse function.

Original Source

Url : http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2013-6420

CWE : Common Weakness Enumeration

% Id Name
100 % CWE-119 Failure to Constrain Operations within the Bounds of a Memory Buffer

OVAL Definitions

Definition Id: oval:org.mitre.oval:def:21094
 
Oval ID: oval:org.mitre.oval:def:21094
Title: RHSA-2013:1814: php security update (Critical)
Description: The asn1_time_to_time_t function in ext/openssl/openssl.c in PHP before 5.3.28, 5.4.x before 5.4.23, and 5.5.x before 5.5.7 does not properly parse (1) notBefore and (2) notAfter timestamps in X.509 certificates, which allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption) via a crafted certificate that is not properly handled by the openssl_x509_parse function.
Family: unix Class: patch
Reference(s): RHSA-2013:1814-00
CESA-2013:1814
CVE-2011-1398
CVE-2012-2688
CVE-2013-1643
CVE-2013-6420
Version: 61
Platform(s): Red Hat Enterprise Linux 5
CentOS Linux 5
Product(s): php
Definition Synopsis:
Definition Id: oval:org.mitre.oval:def:21158
 
Oval ID: oval:org.mitre.oval:def:21158
Title: RHSA-2013:1813: php53 and php security update (Critical)
Description: The asn1_time_to_time_t function in ext/openssl/openssl.c in PHP before 5.3.28, 5.4.x before 5.4.23, and 5.5.x before 5.5.7 does not properly parse (1) notBefore and (2) notAfter timestamps in X.509 certificates, which allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption) via a crafted certificate that is not properly handled by the openssl_x509_parse function.
Family: unix Class: patch
Reference(s): RHSA-2013:1813-00
CESA-2013:1813
CVE-2013-6420
Version: 6
Platform(s): Red Hat Enterprise Linux 5
Red Hat Enterprise Linux 6
CentOS Linux 5
CentOS Linux 6
Product(s): php53
php
Definition Synopsis:
Definition Id: oval:org.mitre.oval:def:22872
 
Oval ID: oval:org.mitre.oval:def:22872
Title: ELSA-2013:1814: php security update (Critical)
Description: The asn1_time_to_time_t function in ext/openssl/openssl.c in PHP before 5.3.28, 5.4.x before 5.4.23, and 5.5.x before 5.5.7 does not properly parse (1) notBefore and (2) notAfter timestamps in X.509 certificates, which allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption) via a crafted certificate that is not properly handled by the openssl_x509_parse function.
Family: unix Class: patch
Reference(s): ELSA-2013:1814-00
CVE-2011-1398
CVE-2012-2688
CVE-2013-1643
CVE-2013-6420
Version: 21
Platform(s): Oracle Linux 5
Product(s): php
Definition Synopsis:
Definition Id: oval:org.mitre.oval:def:23203
 
Oval ID: oval:org.mitre.oval:def:23203
Title: DEPRECATED: ELSA-2013:1813: php53 and php security update (Critical)
Description: The asn1_time_to_time_t function in ext/openssl/openssl.c in PHP before 5.3.28, 5.4.x before 5.4.23, and 5.5.x before 5.5.7 does not properly parse (1) notBefore and (2) notAfter timestamps in X.509 certificates, which allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption) via a crafted certificate that is not properly handled by the openssl_x509_parse function.
Family: unix Class: patch
Reference(s): ELSA-2013:1813-00
CVE-2013-6420
Version: 7
Platform(s): Oracle Linux 5
Oracle Linux 6
Product(s): php53
php
Definition Synopsis:
Definition Id: oval:org.mitre.oval:def:24153
 
Oval ID: oval:org.mitre.oval:def:24153
Title: ELSA-2013:1813: php53 and php security update (Critical)
Description: The asn1_time_to_time_t function in ext/openssl/openssl.c in PHP before 5.3.28, 5.4.x before 5.4.23, and 5.5.x before 5.5.7 does not properly parse (1) notBefore and (2) notAfter timestamps in X.509 certificates, which allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption) via a crafted certificate that is not properly handled by the openssl_x509_parse function.
Family: unix Class: patch
Reference(s): ELSA-2013:1813-00
CVE-2013-6420
Version: 6
Platform(s): Oracle Linux 5
Oracle Linux 6
Product(s): php53
php
Definition Synopsis:
Definition Id: oval:org.mitre.oval:def:26440
 
Oval ID: oval:org.mitre.oval:def:26440
Title: DEPRECATED: ELSA-2013-1813 -- php53 and php security update (critical)
Description: [5.3.3-27] - add security fix for CVE-2013-6420
Family: unix Class: patch
Reference(s): ELSA-2013-1813
CVE-2013-6420
Version: 4
Platform(s): Oracle Linux 5
Oracle Linux 6
Product(s): php53
php
Definition Synopsis:
Definition Id: oval:org.mitre.oval:def:26714
 
Oval ID: oval:org.mitre.oval:def:26714
Title: DEPRECATED: ELSA-2013-1814 -- php security update (critical)
Description: [5.1.6-43] - drop unneeded patch [5.1.6-42] - add security fixes for CVE-2012-2688, CVE-2011-1398, CVE-2013-1643, CVE-2013-6420
Family: unix Class: patch
Reference(s): ELSA-2013-1814
CVE-2011-1398
CVE-2012-2688
CVE-2013-1643
CVE-2013-6420
Version: 4
Platform(s): Oracle Linux 5
Product(s): php
Definition Synopsis:

CPE : Common Platform Enumeration

TypeDescriptionCount
Application 2
Application 466
Os 93
Os 4

ExploitDB Exploits

id Description
2013-12-17 PHP openssl_x509_parse() - Memory Corruption Vulnerability

Information Assurance Vulnerability Management (IAVM)

Date Description
2014-02-27 IAVM : 2014-A-0030 - Apple Mac OS X Security Update 2014-001
Severity : Category I - VMSKEY : V0044547

Nessus® Vulnerability Scanner

Date Description
2017-07-31 Name : The remote device is affected by multiple vulnerabilities.
File : juniper_jsa10804.nasl - Type : ACT_GATHER_INFO
2015-05-20 Name : The remote SUSE host is missing one or more security updates.
File : suse_SU-2014-0064-1.nasl - Type : ACT_GATHER_INFO
2015-01-19 Name : The remote Solaris system is missing a security patch for third-party software.
File : solaris11_php_20140522.nasl - Type : ACT_GATHER_INFO
2014-11-08 Name : The remote Red Hat host is missing one or more security updates.
File : redhat-RHSA-2013-1825.nasl - Type : ACT_GATHER_INFO
2014-11-08 Name : The remote Red Hat host is missing one or more security updates.
File : redhat-RHSA-2013-1824.nasl - Type : ACT_GATHER_INFO
2014-10-08 Name : The remote web server is affected by multiple vulnerabilities.
File : hpsmh_7_4.nasl - Type : ACT_GATHER_INFO
2014-08-30 Name : The remote Gentoo host is missing one or more security-related patches.
File : gentoo_GLSA-201408-11.nasl - Type : ACT_GATHER_INFO
2014-06-13 Name : The remote openSUSE host is missing a security update.
File : openSUSE-2013-1032.nasl - Type : ACT_GATHER_INFO
2014-02-25 Name : The remote host is missing a Mac OS X update that fixes multiple security vul...
File : macosx_SecUpd2014-001.nasl - Type : ACT_GATHER_INFO
2014-02-25 Name : The remote host is missing a Mac OS X update that fixes a certificate validat...
File : macosx_10_9_2.nasl - Type : ACT_GATHER_INFO
2014-01-27 Name : The remote Mandriva Linux host is missing one or more security updates.
File : mandriva_MDVSA-2014-024.nasl - Type : ACT_GATHER_INFO
2014-01-22 Name : The remote Mandriva Linux host is missing one or more security updates.
File : mandriva_MDVSA-2014-014.nasl - Type : ACT_GATHER_INFO
2014-01-15 Name : The remote SuSE 11 host is missing one or more security updates.
File : suse_11_apache2-mod_php53-131218.nasl - Type : ACT_GATHER_INFO
2014-01-15 Name : The remote SuSE 11 host is missing one or more security updates.
File : suse_11_apache2-mod_php5-131220.nasl - Type : ACT_GATHER_INFO
2014-01-14 Name : The remote Slackware host is missing a security update.
File : Slackware_SSA_2014-013-03.nasl - Type : ACT_GATHER_INFO
2013-12-23 Name : The remote Amazon Linux AMI host is missing a security update.
File : ala_ALAS-2013-262.nasl - Type : ACT_GATHER_INFO
2013-12-23 Name : The remote Amazon Linux AMI host is missing a security update.
File : ala_ALAS-2013-263.nasl - Type : ACT_GATHER_INFO
2013-12-23 Name : The remote Amazon Linux AMI host is missing a security update.
File : ala_ALAS-2013-264.nasl - Type : ACT_GATHER_INFO
2013-12-20 Name : The remote Fedora host is missing a security update.
File : fedora_2013-23164.nasl - Type : ACT_GATHER_INFO
2013-12-20 Name : The remote Fedora host is missing a security update.
File : fedora_2013-23215.nasl - Type : ACT_GATHER_INFO
2013-12-16 Name : The remote FreeBSD host is missing one or more security-related updates.
File : freebsd_pkg_47b4e713651311e3868f0025905a4771.nasl - Type : ACT_GATHER_INFO
2013-12-14 Name : The remote web server uses a version of PHP that is potentially affected by a...
File : php_5_5_7.nasl - Type : ACT_GATHER_INFO
2013-12-14 Name : The remote Debian host is missing a security-related update.
File : debian_DSA-2816.nasl - Type : ACT_GATHER_INFO
2013-12-14 Name : The remote web server uses a version of PHP that is potentially affected by m...
File : php_5_3_28.nasl - Type : ACT_GATHER_INFO
2013-12-14 Name : The remote web server uses a version of PHP that is potentially affected by a...
File : php_5_4_23.nasl - Type : ACT_GATHER_INFO
2013-12-13 Name : The remote Ubuntu host is missing one or more security-related patches.
File : ubuntu_USN-2055-1.nasl - Type : ACT_GATHER_INFO
2013-12-13 Name : The remote Fedora host is missing a security update.
File : fedora_2013-23208.nasl - Type : ACT_GATHER_INFO
2013-12-12 Name : The remote Oracle Linux host is missing one or more security updates.
File : oraclelinux_ELSA-2013-1814.nasl - Type : ACT_GATHER_INFO
2013-12-12 Name : The remote Scientific Linux host is missing one or more security updates.
File : sl_20131211_php_on_SL5_x.nasl - Type : ACT_GATHER_INFO
2013-12-12 Name : The remote Scientific Linux host is missing one or more security updates.
File : sl_20131211_php53_and_php_on_SL5_x.nasl - Type : ACT_GATHER_INFO
2013-12-12 Name : The remote CentOS host is missing one or more security updates.
File : centos_RHSA-2013-1814.nasl - Type : ACT_GATHER_INFO
2013-12-12 Name : The remote CentOS host is missing one or more security updates.
File : centos_RHSA-2013-1813.nasl - Type : ACT_GATHER_INFO
2013-12-11 Name : The remote Oracle Linux host is missing one or more security updates.
File : oraclelinux_ELSA-2013-1813.nasl - Type : ACT_GATHER_INFO
2013-12-11 Name : The remote Red Hat host is missing one or more security updates.
File : redhat-RHSA-2013-1814.nasl - Type : ACT_GATHER_INFO
2013-12-11 Name : The remote Red Hat host is missing one or more security updates.
File : redhat-RHSA-2013-1813.nasl - Type : ACT_GATHER_INFO

Sources (Detail)

Source Url
BID http://www.securityfocus.com/bid/64225
CONFIRM http://forums.interworx.com/threads/8000-InterWorx-Version-5-0-14-Released-on...
http://git.php.net/?p=php-src.git;a=commit;h=c1224573c773b6845e83505f717fbf82...
http://support.apple.com/kb/HT6150
http://www.php.net/ChangeLog-5.php
https://bugzilla.redhat.com/show_bug.cgi?id=1036830
DEBIAN http://www.debian.org/security/2013/dsa-2816
HP https://h20564.www2.hp.com/hpsc/doc/public/display?docId=emr_na-c04463322
MISC https://www.sektioneins.de/advisories/advisory-012013-php-openssl_x509_parse-...
REDHAT http://rhn.redhat.com/errata/RHSA-2013-1813.html
http://rhn.redhat.com/errata/RHSA-2013-1815.html
http://rhn.redhat.com/errata/RHSA-2013-1824.html
http://rhn.redhat.com/errata/RHSA-2013-1825.html
http://rhn.redhat.com/errata/RHSA-2013-1826.html
SECTRACK http://www.securitytracker.com/id/1029472
SECUNIA http://secunia.com/advisories/59652
SUSE http://lists.opensuse.org/opensuse-updates/2013-12/msg00125.html
http://lists.opensuse.org/opensuse-updates/2013-12/msg00126.html
UBUNTU http://www.ubuntu.com/usn/USN-2055-1

Alert History

If you want to see full details history, please login or register.
0
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
Date Informations
2020-05-24 01:12:39
  • Multiple Updates
2020-05-23 00:38:40
  • Multiple Updates
2019-06-08 12:05:41
  • Multiple Updates
2018-10-31 00:20:34
  • Multiple Updates
2018-10-03 12:03:48
  • Multiple Updates
2018-08-14 00:19:31
  • Multiple Updates
2018-01-26 12:05:06
  • Multiple Updates
2018-01-09 13:22:59
  • Multiple Updates
2017-08-02 13:24:44
  • Multiple Updates
2016-11-29 00:24:50
  • Multiple Updates
2016-10-05 01:01:16
  • Multiple Updates
2016-09-01 01:01:56
  • Multiple Updates
2016-06-29 00:32:00
  • Multiple Updates
2016-06-28 19:47:56
  • Multiple Updates
2016-04-12 00:24:42
  • Multiple Updates
2015-05-21 13:31:00
  • Multiple Updates
2015-05-21 00:26:11
  • Multiple Updates
2015-05-19 21:26:57
  • Multiple Updates
2015-05-19 09:26:05
  • Multiple Updates
2015-01-21 13:26:31
  • Multiple Updates
2014-11-08 13:31:23
  • Multiple Updates
2014-10-09 13:26:31
  • Multiple Updates
2014-08-31 13:24:57
  • Multiple Updates
2014-07-17 09:21:52
  • Multiple Updates
2014-06-14 13:36:31
  • Multiple Updates
2014-04-01 14:40:18
  • Multiple Updates
2014-03-06 13:23:42
  • Multiple Updates
2014-02-28 17:19:14
  • Multiple Updates
2014-02-26 13:21:16
  • Multiple Updates
2014-02-17 11:24:11
  • Multiple Updates
2014-01-14 13:20:53
  • Multiple Updates
2014-01-05 00:18:30
  • Multiple Updates
2014-01-04 13:19:48
  • Multiple Updates
2013-12-17 21:20:48
  • Multiple Updates
2013-12-17 13:19:05
  • First insertion