Executive Summary

Informations
Name CVE-2004-1051 First vendor Publication 2005-03-01
Vendor Cve Last vendor Modification 2017-07-11

Security-Database Scoring CVSS v3

Cvss vector : N/A
Overall CVSS Score NA
Base Score NA Environmental Score NA
impact SubScore NA Temporal Score NA
Exploitabality Sub Score NA
 
Calculate full CVSS 3.0 Vectors scores

Security-Database Scoring CVSS v2

Cvss vector : (AV:L/AC:L/Au:N/C:C/I:C/A:C)
Cvss Base Score 7.2 Attack Range Local
Cvss Impact Score 10 Attack Complexity Low
Cvss Expoit Score 3.9 Authentication None Required
Calculate full CVSS 2.0 Vectors scores

Detail

sudo before 1.6.8p2 allows local users to execute arbitrary commands by using "()" style environment variables to create functions that have the same name as any program within the bash script that is called without using the program's full pathname.

Original Source

Url : http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-1051

CPE : Common Platform Enumeration

TypeDescriptionCount
Application 1
Application 25
Os 11
Os 6
Os 2
Os 4
Os 2

OpenVAS Exploits

Date Description
2008-09-04 Name : FreeBSD Ports: sudo
File : nvt/freebsd_sudo0.nasl
2008-01-17 Name : Debian Security Advisory DSA 596-1 (sudo)
File : nvt/deb_596_1.nasl
2008-01-17 Name : Debian Security Advisory DSA 596-2 (sudo)
File : nvt/deb_596_2.nasl

Open Source Vulnerability Database (OSVDB)

Id Description
11716 sudo Bash Script Subversion Arbitrary Command Execution

sudo contains a flaw that may allow a malicious user to gain access to unauthorized privileges. The issue is triggered when sudo fails to sanitize environment variables, and a specially crafted Bash environment variable is used to execute arbitrary commands. This flaw may lead to a loss of integrity.

Nessus® Vulnerability Scanner

Date Description
2006-01-15 Name : The remote Ubuntu host is missing a security-related patch.
File : ubuntu_USN-28-1.nasl - Type : ACT_GATHER_INFO
2005-05-03 Name : The remote host is missing a Mac OS X update that fixes a security issue.
File : macosx_SecUpd2005-005.nasl - Type : ACT_GATHER_INFO
2004-11-24 Name : The remote Debian host is missing a security-related update.
File : debian_DSA-596.nasl - Type : ACT_GATHER_INFO
2004-11-17 Name : The remote Mandrake Linux host is missing a security update.
File : mandrake_MDKSA-2004-133.nasl - Type : ACT_GATHER_INFO

Sources (Detail)

Source Url
APPLE http://lists.apple.com/archives/security-announce/2005/May/msg00001.html
BID http://www.securityfocus.com/bid/11668
BUGTRAQ http://marc.info/?l=bugtraq&m=110028877431192&w=2
CONFIRM http://www.sudo.ws/sudo/alerts/bash_functions.html
DEBIAN http://www.debian.org/security/2004/dsa-596
MANDRAKE http://www.mandriva.com/security/advisories?name=MDKSA-2004:133
OPENPKG http://marc.info/?l=bugtraq&m=110598298225675&w=2
TRUSTIX http://www.trustix.org/errata/2004/0061/
UBUNTU https://www.ubuntu.com/usn/usn-28-1/
XF https://exchange.xforce.ibmcloud.com/vulnerabilities/18055

Alert History

If you want to see full details history, please login or register.
0
1
2
3
4
5
6
Date Informations
2020-05-23 00:15:56
  • Multiple Updates
2017-07-11 12:01:33
  • Multiple Updates
2016-12-08 09:23:21
  • Multiple Updates
2016-10-18 12:01:24
  • Multiple Updates
2015-01-14 21:23:29
  • Multiple Updates
2014-02-17 10:28:21
  • Multiple Updates
2013-05-11 11:43:43
  • Multiple Updates