This CPE summary could be partial or incomplete. Please contact us for a detailed listing.

Summary

Detail
Vendor Putty First view 2000-06-01
Product Putty Last view 2020-06-29
Version Type Application
Update  
Edition  
Language  
Sofware Edition  
Target Software  
Target Hardware  
Other  

Activity : Overall

COMMON PLATFORM ENUMERATION: Repartition per Version

CPE Name Affected CVE
cpe:2.3:a:putty:putty:0.53:*:*:*:*:*:*:* 27
cpe:2.3:a:putty:putty:0.48:*:*:*:*:*:*:* 26
cpe:2.3:a:putty:putty:0.49:*:*:*:*:*:*:* 25
cpe:2.3:a:putty:putty:0.53b:*:*:*:*:*:*:* 22
cpe:2.3:a:putty:putty:0.52:*:*:*:*:*:*:* 21
cpe:2.3:a:putty:putty:0.54:*:*:*:*:*:*:* 21
cpe:2.3:a:putty:putty:0.51:*:*:*:*:*:*:* 21
cpe:2.3:a:putty:putty:0.55:*:*:*:*:*:*:* 20
cpe:2.3:a:putty:putty:0.50:*:*:*:*:*:*:* 20
cpe:2.3:a:putty:putty:0.59:*:*:*:*:*:*:* 19
cpe:2.3:a:putty:putty:0.56:*:*:*:*:*:*:* 19
cpe:2.3:a:putty:putty:0.60:*:*:*:*:*:*:* 18
cpe:2.3:a:putty:putty:0.61:*:*:*:*:*:*:* 18
cpe:2.3:a:putty:putty:0.45:*:*:*:*:*:*:* 18
cpe:2.3:a:putty:putty:0.46:*:*:*:*:*:*:* 18
cpe:2.3:a:putty:putty:0.47:*:*:*:*:*:*:* 18
cpe:2.3:a:putty:putty:0.57:*:*:*:*:*:*:* 18
cpe:2.3:a:putty:putty:0.58:*:*:*:*:*:*:* 18
cpe:2.3:a:putty:putty:-:*:*:*:*:*:*:* 18
cpe:2.3:a:putty:putty:*:*:*:*:*:*:*:* 18
cpe:2.3:a:putty:putty:0.62:*:*:*:*:*:*:* 17
cpe:2.3:a:putty:putty:0.63:*:*:*:*:*:*:* 13
cpe:2.3:a:putty:putty:0.65:*:*:*:*:*:*:* 12
cpe:2.3:a:putty:putty:0.66:*:*:*:*:*:*:* 11
cpe:2.3:a:putty:putty:0.67:*:*:*:*:*:*:* 10
cpe:2.3:a:putty:putty:0.68:*:*:*:*:*:*:* 9
cpe:2.3:a:putty:putty:0.69:*:*:*:*:*:*:* 9
cpe:2.3:a:putty:putty:0.70:*:*:*:*:*:*:* 9
cpe:2.3:a:putty:putty:0.71:*:*:*:*:*:*:* 4

Related : CVE

This CPE Product have more than 25 Relations. If you want to see a complete summary for this CPE, please contact us.
  Date Alert Description
5.9 2020-06-29 CVE-2020-14002

PuTTY 0.68 through 0.73 has an Observable Discrepancy leading to an information leak in the algorithm negotiation. This allows man-in-the-middle attackers to target initial connection attempts (where no host key for the server has been cached by the client).

7.5 2019-10-01 CVE-2019-17069

PuTTY before 0.73 might allow remote SSH-1 servers to cause a denial of service by accessing freed memory locations via an SSH1_MSG_DISCONNECT message.

7.5 2019-10-01 CVE-2019-17068

PuTTY before 0.73 mishandles the "bracketed paste mode" protection mechanism, which may allow a session to be affected by malicious clipboard content.

9.8 2019-10-01 CVE-2019-17067

PuTTY before 0.73 on Windows improperly opens port-forwarding listening sockets, which allows attackers to listen on the same port to steal an incoming connection.

9.8 2019-03-21 CVE-2019-9898

Potential recycling of random numbers used in cryptography exists within PuTTY before 0.71.

7.5 2019-03-21 CVE-2019-9897

Multiple denial-of-service attacks that can be triggered by writing to the terminal exist in PuTTY versions before 0.71.

7.8 2019-03-21 CVE-2019-9896

In PuTTY versions before 0.71 on Windows, local attackers could hijack the application by putting a malicious help file in the same directory as the executable.

9.8 2019-03-21 CVE-2019-9895

In PuTTY versions before 0.71 on Unix, a remotely triggerable buffer overflow exists in any kind of server-to-client forwarding.

7.5 2019-03-21 CVE-2019-9894

A remotely triggerable memory overwrite in RSA key exchange in PuTTY before 0.71 can occur before host key verification.

9.8 2017-03-27 CVE-2017-6542

The ssh_agent_channel_data function in PuTTY before 0.68 allows remote attackers to have unspecified impact via a large length value in an agent protocol message and leveraging the ability to connect to the Unix-domain socket representing the forwarded agent connection, which trigger a buffer overflow.

9.8 2016-04-07 CVE-2016-2563

Stack-based buffer overflow in the SCP command-line utility in PuTTY before 0.67 and KiTTY 0.66.6.3 and earlier allows remote servers to cause a denial of service (stack memory corruption) or execute arbitrary code via a crafted SCP-SINK file-size response to an SCP download request.

4.3 2015-12-07 CVE-2015-5309

Integer overflow in the terminal emulator in PuTTY before 0.66 allows remote attackers to cause a denial of service (memory corruption) or possibly execute arbitrary code via an ECH (erase characters) escape sequence with a large parameter value, which triggers a buffer underflow.

2.1 2015-03-27 CVE-2015-2157

The (1) ssh2_load_userkey and (2) ssh2_save_userkey functions in PuTTY 0.51 through 0.63 do not properly wipe SSH-2 private keys from memory, which allows local users to obtain sensitive information by reading the memory.

2.1 2013-08-23 CVE-2011-4607

PuTTY 0.59 through 0.61 does not clear sensitive process memory when managing user replies that occur during keyboard-interactive authentication, which might allow local users to read login passwords by obtaining access to the process' memory.

6.8 2013-08-19 CVE-2013-4852

Integer overflow in PuTTY 0.62 and earlier, WinSCP before 5.1.6, and other products that use PuTTY allows remote SSH servers to cause a denial of service (crash) and possibly execute arbitrary code in certain applications that use PuTTY via a negative size value in an RSA key signature during the SSH handshake, which triggers a heap-based buffer overflow.

2.1 2013-08-19 CVE-2013-4208

The rsa_verify function in PuTTY before 0.63 (1) does not clear sensitive process memory after use and (2) does not free certain structures containing sensitive process memory, which might allow local users to discover private RSA and DSA keys.

4.3 2013-08-19 CVE-2013-4207

Buffer overflow in sshbn.c in PuTTY before 0.63 allows remote SSH servers to cause a denial of service (crash) via an invalid DSA signature that is not properly handled during computation of a modular inverse and triggers the overflow during a division by zero by the bignum functionality, a different vulnerability than CVE-2013-4206.

6.8 2013-08-19 CVE-2013-4206

Heap-based buffer underflow in the modmul function in sshbn.c in PuTTY before 0.63 allows remote SSH servers to cause a denial of service (crash) and possibly trigger memory corruption or code execution via a crafted DSA signature, which is not properly handled when performing certain bit-shifting operations during modular multiplication.

1.9 2007-03-07 CVE-2006-7162

PuTTY 0.59 and earlier uses weak file permissions for (1) ppk files containing private keys generated by puttygen and (2) session logs created by putty, which allows local users to gain sensitive information by reading these files.

7.5 2005-02-21 CVE-2005-0467

Multiple integer overflows in the (1) sftp_pkt_getstring and (2) fxp_readdir_recv functions in the PSFTP and PSCP clients for PuTTY 0.56, and possibly earlier versions, allow remote malicious web sites to execute arbitrary code via SFTP responses that corrupt the heap after insufficient memory has been allocated.

10 2005-01-10 CVE-2004-1008

Integer signedness error in the ssh2_rdpkt function in PuTTY before 0.56 allows remote attackers to execute arbitrary code via a SSH2_MSG_DEBUG packet with a modified stringlen parameter, which leads to a buffer overflow.

7.5 2004-12-31 CVE-2004-1440

Multiple heap-based buffer overflows in the modpow function in PuTTY before 0.55 allow (1) remote attackers to execute arbitrary code via an SSH2 packet with a base argument that is larger than the mod argument, which causes the modpow function to write memory before the beginning of its buffer, and (2) remote malicious servers to cause a denial of service (client crash) and possibly execute arbitrary code via a large bignum during authentication.

7.5 2003-03-18 CVE-2003-0069

The PuTTY terminal emulator 0.53 allows attackers to modify the window title via a certain character escape sequence and then insert it back to the command line in the user's terminal, e.g. when the user views a file containing the malicious sequence, which could allow the attacker to execute arbitrary commands.

4.6 2003-02-19 CVE-2003-0048

PuTTY 0.53b and earlier does not clear logon credentials from memory, including plaintext passwords, which could allow attackers with access to memory to steal the SSH credentials.

10 2002-12-23 CVE-2002-1360

Multiple SSH2 servers and clients do not properly handle strings with null characters in them when the string length is specified by a length field, which could allow remote attackers to cause a denial of service or possibly execute arbitrary code due to interactions with the use of null-terminated strings as implemented using languages such as C, as demonstrated by the SSHredder SSH protocol test suite.

CWE : Common Weakness Enumeration

%idName
31% (7) CWE-119 Failure to Constrain Operations within the Bounds of a Memory Buffer
27% (6) CWE-20 Improper Input Validation
13% (3) CWE-200 Information Exposure
9% (2) CWE-189 Numeric Errors
4% (1) CWE-770 Allocation of Resources Without Limits or Throttling
4% (1) CWE-327 Use of a Broken or Risky Cryptographic Algorithm
4% (1) CWE-320 Key Management Errors
4% (1) CWE-74 Failure to Sanitize Data into a Different Plane ('Injection')

CAPEC : Common Attack Pattern Enumeration & Classification

id Name
CAPEC-41 Using Meta-characters in E-mail Headers to Inject Malicious Payloads
CAPEC-47 Buffer Overflow via Parameter Expansion
CAPEC-81 Web Logs Tampering
CAPEC-93 Log Injection-Tampering-Forging

Oval Markup Language : Definitions

OvalID Name
oval:org.mitre.oval:def:5849 Multiple Vendors SSH2 "incorrect length fields" Vulnerability
oval:org.mitre.oval:def:5721 Multiple Vendors SSH2 "lists with empty elements or multiple separators" Vuln...
oval:org.mitre.oval:def:5848 Multiple Vendors SSH2 "buffer overflow" Vulnerability
oval:org.mitre.oval:def:5797 Multiple Vendors SSH2 "null characters in strings" Vulnerability
oval:org.mitre.oval:def:18299 DSA-2736-1 putty - several

Open Source Vulnerability Database (OSVDB)

id Description
33856 PuTTY on Debian Linux puttygen ppk File Creation Permission Weakness
14003 PuTTY sftp_pkt_getstring() Function Remote Overflow
14002 PuTTY fxp_readdir_recv() Function Remote Overflow
11165 PuTTY SSH2_MSG_DEBUG Packet Handling Overflow
8348 Multiple xterm Client Embedded Escape Character DoS
8347 PuTTY Window Title Escape Character Arbitrary Command Execution
8299 PuTTY modpow() Pre-authentication Arbitrary Code Execution
8045 SSH2 Server/Client Null Character String Arbitrary Command Execution
8044 Multiple Vendor SSH2 Server/Client Large Field Overflows
8043 SSH2 Server/Client Empty Element List Arbitrary Command Execution
8042 SSH2 Server/Client Incorrect Length Specifiers Arbitrary Code Execution
7687 PuTTY SSH2 Client Memory Logon Credential Leak

OpenVAS Exploits

id Description
2008-09-24 Name : Gentoo Security Advisory GLSA 200408-04 (PuTTY)
File : nvt/glsa_200408_04.nasl
2008-09-24 Name : Gentoo Security Advisory GLSA 200410-29 (putty)
File : nvt/glsa_200410_29.nasl
2008-09-24 Name : Gentoo Security Advisory GLSA 200502-28 (Putty)
File : nvt/glsa_200502_28.nasl
2008-09-04 Name : FreeBSD Ports: putty
File : nvt/freebsd_putty.nasl
2008-09-04 Name : FreeBSD Ports: putty
File : nvt/freebsd_putty0.nasl
2005-11-03 Name : PuTTY window title escape character arbitrary command execution
File : nvt/putty_arbitrary_command_execution.nasl
2005-11-03 Name : PuTTY SSH2 authentication password persistence weakness
File : nvt/putty_logon_credential_leak.nasl
2005-11-03 Name : SSH Multiple Vulns
File : nvt/ssh_multivulns_16122002.nasl
0000-00-00 Name : FreeBSD Ports: putty
File : nvt/freebsd_putty1.nasl

Snort® IPS/IDS

Date Description
2014-01-10 Putty Server key exchange buffer overflow attempt
RuleID : 10010 - Type : SERVER-OTHER - Revision : 8

Nessus® Vulnerability Scanner

This CPE Product have more than 25 Relations. If you want to see a complete summary for this CPE, please contact us.
id Description
2017-12-11 Name: The remote Windows host has an SSH client that is affected by a buffer overfl...
File: putty_067.nasl - Type: ACT_GATHER_INFO
2017-07-21 Name: The remote Fedora host is missing a security update.
File: fedora_2017-efdd962fee.nasl - Type: ACT_GATHER_INFO
2017-06-07 Name: The remote Gentoo host is missing one or more security-related patches.
File: gentoo_GLSA-201706-09.nasl - Type: ACT_GATHER_INFO
2017-03-20 Name: The remote openSUSE host is missing a security update.
File: openSUSE-2017-354.nasl - Type: ACT_GATHER_INFO
2017-03-20 Name: The remote Gentoo host is missing one or more security-related patches.
File: gentoo_GLSA-201703-03.nasl - Type: ACT_GATHER_INFO
2017-03-17 Name: The remote FreeBSD host is missing a security-related update.
File: freebsd_pkg_9b973e970a9911e7ace7080027ef73ec.nasl - Type: ACT_GATHER_INFO
2016-06-06 Name: The remote Gentoo host is missing one or more security-related patches.
File: gentoo_GLSA-201606-01.nasl - Type: ACT_GATHER_INFO
2016-06-01 Name: The remote openSUSE host is missing a security update.
File: openSUSE-2016-667.nasl - Type: ACT_GATHER_INFO
2016-03-08 Name: The remote FreeBSD host is missing a security-related update.
File: freebsd_pkg_7f0fbb30e46211e5a3f3080027ef73ec.nasl - Type: ACT_GATHER_INFO
2016-03-04 Name: The remote Fedora host is missing a security update.
File: fedora_2015-5ad4a1f151.nasl - Type: ACT_GATHER_INFO
2016-03-04 Name: The remote Fedora host is missing a security update.
File: fedora_2015-3d17682c15.nasl - Type: ACT_GATHER_INFO
2015-12-02 Name: The remote Debian host is missing a security-related update.
File: debian_DSA-3409.nasl - Type: ACT_GATHER_INFO
2015-11-30 Name: The remote Debian host is missing a security update.
File: debian_DLA-347.nasl - Type: ACT_GATHER_INFO
2015-11-19 Name: The remote openSUSE host is missing a security update.
File: openSUSE-2015-766.nasl - Type: ACT_GATHER_INFO
2015-11-10 Name: The remote FreeBSD host is missing a security-related update.
File: freebsd_pkg_0cb0afd986b811e5bf60080027ef73ec.nasl - Type: ACT_GATHER_INFO
2015-03-26 Name: The remote Debian host is missing a security update.
File: debian_DLA-173.nasl - Type: ACT_GATHER_INFO
2015-03-17 Name: The remote Fedora host is missing a security update.
File: fedora_2015-3204.nasl - Type: ACT_GATHER_INFO
2015-03-17 Name: The remote Fedora host is missing a security update.
File: fedora_2015-3160.nasl - Type: ACT_GATHER_INFO
2015-03-17 Name: The remote Fedora host is missing a security update.
File: fedora_2015-3070.nasl - Type: ACT_GATHER_INFO
2015-03-17 Name: The remote Debian host is missing a security-related update.
File: debian_DSA-3190.nasl - Type: ACT_GATHER_INFO
2015-03-12 Name: The remote openSUSE host is missing a security update.
File: openSUSE-2015-218.nasl - Type: ACT_GATHER_INFO
2015-03-06 Name: The remote Windows host has an SSH client that is affected by multiple inform...
File: putty_064.nasl - Type: ACT_GATHER_INFO
2015-03-06 Name: The remote FreeBSD host is missing a security-related update.
File: freebsd_pkg_92fc2e2bc38311e48ef7080027ef73ec.nasl - Type: ACT_GATHER_INFO
2014-06-13 Name: The remote openSUSE host is missing a security update.
File: openSUSE-2013-655.nasl - Type: ACT_GATHER_INFO
2014-06-13 Name: The remote openSUSE host is missing a security update.
File: openSUSE-2013-650.nasl - Type: ACT_GATHER_INFO