This CPE summary could be partial or incomplete. Please contact us for a detailed listing.

Summary

Detail
Vendor Zope First view 2001-03-12
Product Zope Last view 2023-10-04
Version 2.1.0 Type Application
Update *  
Edition *  
Language *  
Sofware Edition *  
Target Software *  
Target Hardware *  
Other *  
 
CPE Product cpe:2.3:a:zope:zope

Activity : Overall

Related : CVE

  Date Alert Description
4.8 2023-10-04 CVE-2023-44389

Zope is an open-source web application server. The title property, available on most Zope objects, can be used to store script code that is executed while viewing the affected object in the Zope Management Interface (ZMI). All versions of Zope 4 and Zope 5 are affected. Patches will be released with Zope versions 4.8.11 and 5.8.6.

5.4 2023-09-21 CVE-2023-42458

Zope is an open-source web application server. Prior to versions 4.8.10 and 5.8.5, there is a stored cross site scripting vulnerability for SVG images. Note that an image tag with an SVG image as source is never vulnerable, even when the SVG image contains malicious code. To exploit the vulnerability, an attacker would first need to upload an image, and then trick a user into following a specially crafted link. Patches are available in Zope 4.8.10 and 5.8.5. As a workaround, make sure the "Add Documents, Images, and Files" permission is only assigned to trusted roles. By default, only the Manager has this permission.

7.7 2023-09-06 CVE-2023-41050

AccessControl provides a general security framework for use in Zope. Python's "format" functionality allows someone controlling the format string to "read" objects accessible (recursively) via attribute access and subscription from accessible objects. Those attribute accesses and subscriptions use Python's full blown `getattr` and `getitem`, not the policy restricted `AccessControl` variants `_getattr_` and `_getitem_`. This can lead to critical information disclosure. `AccessControl` already provides a safe variant for `str.format` and denies access to `string.Formatter`. However, `str.format_map` is still unsafe. Affected are all users who allow untrusted users to create `AccessControl` controlled Python code and execute it. A fix has been introduced in versions 4.4, 5.8 and 6.2. Users are advised to upgrade. There are no known workarounds for this vulnerability.

7.2 2021-08-02 CVE-2021-32811

Zope is an open-source web application server. Zope versions prior to versions 4.6.3 and 5.3 have a remote code execution security issue. In order to be affected, one must use Python 3 for one's Zope deployment, run Zope 4 below version 4.6.3 or Zope 5 below version 5.3, and have the optional `Products.PythonScripts` add-on package installed. By default, one must have the admin-level Zope "Manager" role to add or edit Script (Python) objects through the web. Only sites that allow untrusted users to add/edit these scripts through the web are at risk. Zope releases 4.6.3 and 5.3 are not vulnerable. As a workaround, a site administrator can restrict adding/editing Script (Python) objects through the web using the standard Zope user/role permission mechanisms. Untrusted users should not be assigned the Zope Manager role and adding/editing these scripts through the web should be restricted to trusted users only. This is the default configuration in Zope.

8.8 2021-06-08 CVE-2021-32674

Zope is an open-source web application server. This advisory extends the previous advisory at https://github.com/zopefoundation/Zope/security/advisories/GHSA-5pr9-v234-jw36 with additional cases of TAL expression traversal vulnerabilities. Most Python modules are not available for using in TAL expressions that you can add through-the-web, for example in Zope Page Templates. This restriction avoids file system access, for example via the 'os' module. But some of the untrusted modules are available indirectly through Python modules that are available for direct use. By default, you need to have the Manager role to add or edit Zope Page Templates through the web. Only sites that allow untrusted users to add/edit Zope Page Templates through the web are at risk. The problem has been fixed in Zope 5.2.1 and 4.6.1. The workaround is the same as for https://github.com/zopefoundation/Zope/security/advisories/GHSA-5pr9-v234-jw36: A site administrator can restrict adding/editing Zope Page Templates through the web using the standard Zope user/role permission mechanisms. Untrusted users should not be assigned the Zope Manager role and adding/editing Zope Page Templates through the web should be restricted to trusted users only.

6.1 2021-05-21 CVE-2021-33507

Zope Products.CMFCore before 2.5.1 and Products.PluggableAuthService before 2.6.2, as used in Plone through 5.2.4 and other products, allow Reflected XSS.

8.8 2021-05-21 CVE-2021-32633

Zope is an open-source web application server. In Zope versions prior to 4.6 and 5.2, users can access untrusted modules indirectly through Python modules that are available for direct use. By default, only users with the Manager role can add or edit Zope Page Templates through the web, but sites that allow untrusted users to add/edit Zope Page Templates through the web are at risk from this vulnerability. The problem has been fixed in Zope 5.2 and 4.6. As a workaround, a site administrator can restrict adding/editing Zope Page Templates through the web using the standard Zope user/role permission mechanisms. Untrusted users should not be assigned the Zope Manager role and adding/editing Zope Page Templates through the web should be restricted to trusted users only.

6.1 2019-11-25 CVE-2011-4924

Cross-site scripting (XSS) vulnerability in Zope 2.8.x before 2.8.12, 2.9.x before 2.9.12, 2.10.x before 2.10.11, 2.11.x before 2.11.6, and 2.12.x before 2.12.3, 3.1.1 through 3.4.1. allows remote attackers to inject arbitrary web script or HTML via vectors related to the way error messages perform sanitization. NOTE: this issue exists because of an incomplete fix for CVE-2010-1104

5 2014-11-03 CVE-2012-6661

Zope before 2.13.19, as used in Plone before 4.2.3 and 4.3 before beta 1, does not reseed the pseudo-random number generator (PRNG), which makes it easier for remote attackers to guess the value via unspecified vectors. NOTE: this issue was SPLIT from CVE-2012-5508 due to different vulnerability types (ADT2).

6.5 2014-09-30 CVE-2012-5489

The App.Undo.UndoSupport.get_request_var_or_attr function in Zope before 2.12.21 and 3.13.x before 2.13.11, as used in Plone before 4.2.3 and 4.3 before beta 1, allows remote authenticated users to gain access to restricted attributes via unspecified vectors.

4 2008-11-17 CVE-2008-5102

PythonScripts in Zope 2 2.11.2 and earlier, as used in Conga and other products, allows remote authenticated users to cause a denial of service (resource consumption or application halt) via certain (1) raise or (2) import statements.

4.3 2007-03-22 CVE-2007-0240

Cross-site scripting (XSS) vulnerability in Zope 2.10.2 and earlier allows remote attackers to inject arbitrary web script or HTML via unspecified vectors in a HTTP GET request.

7.5 2005-10-27 CVE-2005-3323

docutils in Zope 2.6, 2.7 before 2.7.8, and 2.8 before 2.8.2 allows remote attackers to include arbitrary files via include directives in RestructuredText functionality.

5 2002-07-23 CVE-2002-0687

The "through the web code" capability for Zope 2.0 through 2.5.1 b1 allows untrusted users to shut down the Zope server via certain headers.

2.1 2001-08-22 CVE-2001-0569

Digital Creations Zope 2.3.1 b1 and earlier contains a problem in the method return values related to the classes (1) ObjectManager, (2) PropertyManager, and (3) PropertySheet.

2.1 2001-08-22 CVE-2001-0568

Digital Creations Zope 2.3.1 b1 and earlier allows a local attacker (Zope user) with through-the-web scripting capabilities to alter ZClasses class attributes.

7.2 2001-03-12 CVE-2001-0128

Zope before 2.2.4 does not properly compute local roles, which could allow users to bypass specified access restrictions and gain privileges.

CWE : Common Weakness Enumeration

%idName
36% (4) CWE-79 Failure to Preserve Web Page Structure ('Cross-site Scripting')
18% (2) CWE-22 Improper Limitation of a Pathname to a Restricted Directory ('Path ...
9% (1) CWE-399 Resource Management Errors
9% (1) CWE-310 Cryptographic Issues
9% (1) CWE-264 Permissions, Privileges, and Access Controls
9% (1) CWE-200 Information Exposure
9% (1) CWE-80 Improper Sanitization of Script-Related HTML Tags in a Web Page (Basic XSS)

CAPEC : Common Attack Pattern Enumeration & Classification

id Name
CAPEC-58 Restful Privilege Elevation

Open Source Vulnerability Database (OSVDB)

id Description
50487 PythonScripts for Zope Multiple Statements Remote DoS
34366 Zope Unspecified HTTP GET Request CSRF
19951 Zope Unspecified RestructuredText Functionality Disclosure
6286 Zope Class Return Value Modification
6285 Zope ZClass Modification Local DoS
6284 Zope Local Role Computation Error Privilege Escalation
5166 Zope Through The Web Code Header Injection DoS

OpenVAS Exploits

id Description
2008-11-21 Name : Zope Python Scripts Local Denial of Service Vulnerability
File : nvt/gb_zope_python_scripts_dos_vuln_lin.nasl
2008-09-24 Name : Gentoo Security Advisory GLSA 200510-20 (Zope)
File : nvt/glsa_200510_20.nasl
2008-09-04 Name : FreeBSD Ports: zope
File : nvt/freebsd_zope1.nasl
2008-09-04 Name : FreeBSD Ports: zope28
File : nvt/freebsd_zope28.nasl
2008-01-17 Name : Debian Security Advisory DSA 043-1 (zope)
File : nvt/deb_043_1.nasl
2008-01-17 Name : Debian Security Advisory DSA 1275-1 (zope2.7)
File : nvt/deb_1275_1.nasl
2008-01-17 Name : Debian Security Advisory DSA 910-1 (zope2.7)
File : nvt/deb_910_1.nasl

Nessus® Vulnerability Scanner

id Description
2013-07-12 Name: The remote Oracle Linux host is missing one or more security updates.
File: oraclelinux_ELSA-2012-0151.nasl - Type: ACT_GATHER_INFO
2012-09-06 Name: The remote Mandrake Linux host is missing one or more security updates.
File: mandrake_MDKSA-2000-086.nasl - Type: ACT_GATHER_INFO
2012-09-06 Name: The remote Mandrake Linux host is missing one or more security updates.
File: mandrake_MDKSA-2001-025.nasl - Type: ACT_GATHER_INFO
2012-09-06 Name: The remote Mandrake Linux host is missing one or more security updates.
File: mandrake_MDKSA-2001-049.nasl - Type: ACT_GATHER_INFO
2007-10-17 Name: The remote openSUSE host is missing a security update.
File: suse_zope-3346.nasl - Type: ACT_GATHER_INFO
2007-04-10 Name: The remote Debian host is missing a security-related update.
File: debian_DSA-1275.nasl - Type: ACT_GATHER_INFO
2007-04-10 Name: The remote FreeBSD host is missing one or more security-related updates.
File: freebsd_pkg_34414a1ee37711dbb8ab000c76189c4c.nasl - Type: ACT_GATHER_INFO
2006-10-14 Name: The remote Debian host is missing a security-related update.
File: debian_DSA-910.nasl - Type: ACT_GATHER_INFO
2006-05-13 Name: The remote FreeBSD host is missing one or more security-related updates.
File: freebsd_pkg_d2b80c7c3aae11da948400123ffe8333.nasl - Type: ACT_GATHER_INFO
2006-01-21 Name: The remote Ubuntu host is missing one or more security-related patches.
File: ubuntu_USN-229-1.nasl - Type: ACT_GATHER_INFO
2005-10-28 Name: The remote Gentoo host is missing one or more security-related patches.
File: gentoo_GLSA-200510-20.nasl - Type: ACT_GATHER_INFO
2004-09-29 Name: The remote Debian host is missing a security-related update.
File: debian_DSA-043.nasl - Type: ACT_GATHER_INFO
2001-08-04 Name: The remote web server contains an application server that is prone to a denia...
File: zope_dos.nasl - Type: ACT_GATHER_INFO