This CPE summary could be partial or incomplete. Please contact us for a detailed listing.

Summary

Detail
Vendor Drupal First view 2016-04-12
Product Drupal Last view 2022-09-28
Version 8.0 Type Application
Update alpha14  
Edition *  
Language *  
Sofware Edition *  
Target Software *  
Target Hardware *  
Other *  
 
CPE Product cpe:2.3:a:drupal:drupal

Activity : Overall

Related : CVE

This CPE have more than 25 Relations. If you want to see a complete summary for this CPE, please contact us.
  Date Alert Description
7.5 2022-09-28 CVE-2022-39261

Twig is a template language for PHP. Versions 1.x prior to 1.44.7, 2.x prior to 2.15.3, and 3.x prior to 3.4.3 encounter an issue when the filesystem loader loads templates for which the name is a user input. It is possible to use the `source` or `include` statement to read arbitrary files from outside the templates' directory when using a namespace like `@somewhere/../some.file`. In such a case, validation is bypassed. Versions 1.44.7, 2.15.3, and 3.4.3 contain a fix for validation of such template names. There are no known workarounds aside from upgrading.

7.5 2022-06-10 CVE-2022-31043

Guzzle is an open source PHP HTTP client. In affected versions `Authorization` headers on requests are sensitive information. On making a request using the `https` scheme to a server which responds with a redirect to a URI with the `http` scheme, we should not forward the `Authorization` header on. This is much the same as to how we don't forward on the header if the host changes. Prior to this fix, `https` to `http` downgrades did not result in the `Authorization` header being removed, only changes to the host. Affected Guzzle 7 users should upgrade to Guzzle 7.4.4 as soon as possible. Affected users using any earlier series of Guzzle should upgrade to Guzzle 6.5.7 or 7.4.4. Users unable to upgrade may consider an alternative approach which would be to use their own redirect middleware. Alternately users may simply disable redirects all together if redirects are not expected or required.

7.5 2022-06-10 CVE-2022-31042

Guzzle is an open source PHP HTTP client. In affected versions the `Cookie` headers on requests are sensitive information. On making a request using the `https` scheme to a server which responds with a redirect to a URI with the `http` scheme, or on making a request to a server which responds with a redirect to a a URI to a different host, we should not forward the `Cookie` header on. Prior to this fix, only cookies that were managed by our cookie middleware would be safely removed, and any `Cookie` header manually added to the initial request would not be stripped. We now always strip it, and allow the cookie middleware to re-add any cookies that it deems should be there. Affected Guzzle 7 users should upgrade to Guzzle 7.4.4 as soon as possible. Affected users using any earlier series of Guzzle should upgrade to Guzzle 6.5.7 or 7.4.4. Users unable to upgrade may consider an alternative approach to use your own redirect middleware, rather than ours. If you do not require or expect redirects to be followed, one should simply disable redirects all together.

8.1 2022-05-25 CVE-2022-29248

Guzzle is a PHP HTTP client. Guzzle prior to versions 6.5.6 and 7.4.3 contains a vulnerability with the cookie middleware. The vulnerability is that it is not checked if the cookie domain equals the domain of the server which sets the cookie via the Set-Cookie header, allowing a malicious server to set cookies for unrelated domains. The cookie middleware is disabled by default, so most library consumers will not be affected by this issue. Only those who manually add the cookie middleware to the handler stack or construct the client with ['cookies' => true] are affected. Moreover, those who do not use the same Guzzle client to call multiple domains and have disabled redirect forwarding are not affected by this vulnerability. Guzzle versions 6.5.6 and 7.4.3 contain a patch for this issue. As a workaround, turn off the cookie middleware.

7.5 2022-03-21 CVE-2022-24775

guzzlehttp/psr7 is a PSR-7 HTTP message library. Versions prior to 1.8.4 and 2.1.1 are vulnerable to improper header parsing. An attacker could sneak in a new line character and pass untrusted values. The issue is patched in 1.8.4 and 2.1.1. There are currently no known workarounds.

7.5 2022-03-16 CVE-2022-24729

CKEditor4 is an open source what-you-see-is-what-you-get HTML editor. CKEditor4 prior to version 4.18.0 contains a vulnerability in the `dialog` plugin. The vulnerability allows abuse of a dialog input validator regular expression, which can cause a significant performance drop resulting in a browser tab freeze. A patch is available in version 4.18.0. There are currently no known workarounds.

5.4 2022-03-16 CVE-2022-24728

CKEditor4 is an open source what-you-see-is-what-you-get HTML editor. A vulnerability has been discovered in the core HTML processing module and may affect all plugins used by CKEditor 4 prior to version 4.18.0. The vulnerability allows someone to inject malformed HTML bypassing content sanitization, which could result in executing JavaScript code. This problem has been patched in version 4.18.0. There are currently no known workarounds.

6.5 2022-02-17 CVE-2022-25270

The Quick Edit module does not properly check entity access in some circumstances. This could result in users with the "access in-place editing" permission viewing some content they are are not authorized to access. Sites are only affected if the QuickEdit module (which comes with the Standard profile) is installed.

7.5 2022-02-16 CVE-2022-25271

Drupal core's form API has a vulnerability where certain contributed or custom modules' forms may be vulnerable to improper input validation. This could allow an attacker to inject disallowed values or overwrite data. Affected forms are uncommon, but in certain cases an attacker could alter critical or sensitive data.

7.5 2022-02-11 CVE-2020-13677

Under some circumstances, the Drupal core JSON:API module does not properly restrict access to certain content, which may result in unintended access bypass. Sites that do not have the JSON:API module enabled are not affected.

6.5 2022-02-11 CVE-2020-13676

The QuickEdit module does not properly check access to fields in some circumstances, which can lead to unintended disclosure of field data. Sites are only affected if the QuickEdit module (which comes with the Standard profile) is installed.

9.8 2022-02-11 CVE-2020-13675

Drupal's JSON:API and REST/File modules allow file uploads through their HTTP APIs. The modules do not correctly run all file validation, which causes an access bypass vulnerability. An attacker might be able to upload files that bypass the file validation process implemented by modules on the site.

6.5 2022-02-11 CVE-2020-13674

The QuickEdit module does not properly validate access to routes, which could allow cross-site request forgery under some circumstances and lead to possible data integrity issues. Sites are only affected if the QuickEdit module (which comes with the Standard profile) is installed. Removing the "access in-place editing" permission from untrusted users will not fully mitigate the vulnerability.

6.1 2022-02-11 CVE-2020-13672

Cross-site Scripting (XSS) vulnerability in Drupal core's sanitization API fails to properly filter cross-site scripting under certain circumstances. This issue affects: Drupal Core 9.1.x versions prior to 9.1.7; 9.0.x versions prior to 9.0.12; 8.9.x versions prior to 8.9.14; 7.x versions prior to 7.80.

7.5 2022-02-11 CVE-2020-13670

Information Disclosure vulnerability in file module of Drupal Core allows an attacker to gain access to the file metadata of a permanent private file that they do not have access to by guessing the ID of the file. This issue affects: Drupal Core 8.8.x versions prior to 8.8.10; 8.9.x versions prior to 8.9.6; 9.0.x versions prior to 9.0.6.

6.1 2022-02-11 CVE-2020-13669

Cross-site Scripting (XSS) vulnerability in ckeditor of Drupal Core allows attacker to inject XSS. This issue affects: Drupal Core 8.8.x versions prior to 8.8.10.; 8.9.x versions prior to 8.9.6; 9.0.x versions prior to 9.0.6.

6.1 2022-02-11 CVE-2020-13668

Access Bypass vulnerability in Drupal Core allows for an attacker to leverage the way that HTML is rendered for affected forms in order to exploit the vulnerability. This issue affects: Drupal Core 8.8.x versions prior to 8.8.10; 8.9.x versions prior to 8.9.6; 9.0.x versions prior to 9.0.6.

5.4 2021-11-17 CVE-2021-41165

CKEditor4 is an open source WYSIWYG HTML editor. In affected version a vulnerability has been discovered in the core HTML processing module and may affect all plugins used by CKEditor 4. The vulnerability allowed to inject malformed comments HTML bypassing content sanitization, which could result in executing JavaScript code. It affects all users using the CKEditor 4 at version < 4.17.0. The problem has been recognized and patched. The fix will be available in version 4.17.0.

5.4 2021-11-17 CVE-2021-41164

CKEditor4 is an open source WYSIWYG HTML editor. In affected versions a vulnerability has been discovered in the Advanced Content Filter (ACF) module and may affect all plugins used by CKEditor 4. The vulnerability allowed to inject malformed HTML bypassing content sanitization, which could result in executing JavaScript code. It affects all users using the CKEditor 4 at version < 4.17.0. The problem has been recognized and patched. The fix will be available in version 4.17.0.

6.1 2021-10-26 CVE-2021-41184

jQuery-UI is the official jQuery user interface library. Prior to version 1.13.0, accepting the value of the `of` option of the `.position()` util from untrusted sources may execute untrusted code. The issue is fixed in jQuery UI 1.13.0. Any string value passed to the `of` option is now treated as a CSS selector. A workaround is to not accept the value of the `of` option from untrusted sources.

6.1 2021-10-26 CVE-2021-41183

jQuery-UI is the official jQuery user interface library. Prior to version 1.13.0, accepting the value of various `*Text` options of the Datepicker widget from untrusted sources may execute untrusted code. The issue is fixed in jQuery UI 1.13.0. The values passed to various `*Text` options are now always treated as pure text, not HTML. A workaround is to not accept the value of the `*Text` options from untrusted sources.

6.1 2021-06-11 CVE-2020-13688

Cross-site scripting vulnerability in l Drupal Core allows an attacker could leverage the way that HTML is rendered for affected forms in order to exploit the vulnerability. This issue affects: Drupal Core 8.8.X versions prior to 8.8.10; 8.9.X versions prior to 8.9.6; 9.0.X versions prior to 9.0.6.

8.8 2021-06-11 CVE-2020-13663

Cross Site Request Forgery vulnerability in Drupal Core Form API does not properly handle certain form input from cross-site requests, which can lead to other vulnerabilities.

6.1 2021-06-09 CVE-2021-33829

A cross-site scripting (XSS) vulnerability in the HTML Data Processor in CKEditor 4 4.14.0 through 4.16.x before 4.16.1 allows remote attackers to inject executable JavaScript code through a crafted comment because --!> is mishandled.

5.3 2021-05-17 CVE-2020-13667

Access bypass vulnerability in of Drupal Core Workspaces allows an attacker to access data without correct permissions. The Workspaces module doesn't sufficiently check access permissions when switching workspaces, leading to an access bypass vulnerability. An attacker might be able to see content before the site owner intends people to see the content. This vulnerability is mitigated by the fact that sites are only vulnerable if they have installed the experimental Workspaces module. This issue affects Drupal Core8.8.X versions prior to 8.8.10; 8.9.X versions prior to 8.9.6; 9.0.X versions prior to 9.0.6.

CWE : Common Weakness Enumeration

%idName
35% (19) CWE-79 Failure to Preserve Web Page Structure ('Cross-site Scripting')
9% (5) CWE-200 Information Exposure
9% (5) CWE-20 Improper Input Validation
7% (4) CWE-502 Deserialization of Untrusted Data
5% (3) CWE-434 Unrestricted Upload of File with Dangerous Type
5% (3) CWE-22 Improper Limitation of a Pathname to a Restricted Directory ('Path ...
3% (2) CWE-352 Cross-Site Request Forgery (CSRF)
1% (1) CWE-668 Exposure of Resource to Wrong Sphere
1% (1) CWE-601 URL Redirection to Untrusted Site ('Open Redirect')
1% (1) CWE-552 Files or Directories Accessible to External Parties
1% (1) CWE-400 Uncontrolled Resource Consumption ('Resource Exhaustion')
1% (1) CWE-287 Improper Authentication
1% (1) CWE-276 Incorrect Default Permissions
1% (1) CWE-269 Improper Privilege Management
1% (1) CWE-89 Improper Sanitization of Special Elements used in an SQL Command ('...
1% (1) CWE-77 Improper Sanitization of Special Elements used in a Command ('Comma...
1% (1) CWE-74 Failure to Sanitize Data into a Different Plane ('Injection')
1% (1) CWE-59 Improper Link Resolution Before File Access ('Link Following')
1% (1) CWE-19 Data Handling

SAINT Exploits

Description Link
Drupal REST module command execution More info here
Drupal Form API command execution More info here

Snort® IPS/IDS

Date Description
2019-07-23 TYPO3 PharStreamWrapper Package directory traversal attempt
RuleID : 50491 - Type : SERVER-WEBAPP - Revision : 1
2019-07-23 TYPO3 PharStreamWrapper Package directory traversal attempt
RuleID : 50490 - Type : SERVER-WEBAPP - Revision : 1
2019-03-28 Drupal Core 8 PHP object injection RCE attempt
RuleID : 49257 - Type : SERVER-WEBAPP - Revision : 2
2018-09-25 Symfony HttpFoundation component potential security bypass attempt
RuleID : 47620 - Type : SERVER-WEBAPP - Revision : 2
2018-09-25 Symfony HttpFoundation component potential security bypass attempt
RuleID : 47619 - Type : SERVER-WEBAPP - Revision : 3
2018-05-29 Drupal unsafe internal attribute remote code execution attempt
RuleID : 46451 - Type : SERVER-WEBAPP - Revision : 1
2018-05-03 Drupal 8 remote code execution attempt
RuleID : 46316-community - Type : SERVER-WEBAPP - Revision : 5
2018-05-15 Drupal 8 remote code execution attempt
RuleID : 46316 - Type : SERVER-WEBAPP - Revision : 5
2016-07-28 HttpOxy CGI application vulnerability potential man-in-the-middle attempt
RuleID : 39737-community - Type : SERVER-WEBAPP - Revision : 2
2016-08-31 HttpOxy CGI application vulnerability potential man-in-the-middle attempt
RuleID : 39737 - Type : SERVER-WEBAPP - Revision : 2

Nessus® Vulnerability Scanner

This CPE have more than 25 Relations. If you want to see a complete summary for this CPE, please contact us.
id Description
2019-01-03 Name: The remote Fedora host is missing a security update.
File: fedora_2018-9c38d1dc1d.nasl - Type: ACT_GATHER_INFO
2019-01-03 Name: The remote Fedora host is missing a security update.
File: fedora_2018-9b54497b6e.nasl - Type: ACT_GATHER_INFO
2019-01-03 Name: The remote Fedora host is missing a security update.
File: fedora_2018-906ba26b4d.nasl - Type: ACT_GATHER_INFO
2019-01-03 Name: The remote Fedora host is missing a security update.
File: fedora_2018-8fd924a53d.nasl - Type: ACT_GATHER_INFO
2019-01-03 Name: The remote Fedora host is missing a security update.
File: fedora_2018-75bca4c5a0.nasl - Type: ACT_GATHER_INFO
2019-01-03 Name: The remote Fedora host is missing a security update.
File: fedora_2018-732f45d43e.nasl - Type: ACT_GATHER_INFO
2019-01-03 Name: The remote Fedora host is missing a security update.
File: fedora_2018-43c64deada.nasl - Type: ACT_GATHER_INFO
2018-08-15 Name: The remote Fedora host is missing a security update.
File: fedora_2018-6f3ceeb7cb.nasl - Type: ACT_GATHER_INFO
2018-08-15 Name: The remote Fedora host is missing a security update.
File: fedora_2018-4deae442f2.nasl - Type: ACT_GATHER_INFO
2018-08-15 Name: The remote Fedora host is missing a security update.
File: fedora_2018-7f43cbdb69.nasl - Type: ACT_GATHER_INFO
2018-08-09 Name: A PHP application running on the remote web server is affected by a restricti...
File: drupal_8_5_6.nasl - Type: ACT_GATHER_INFO
2018-05-11 Name: The remote Fedora host is missing a security update.
File: fedora_2018-b9ad458866.nasl - Type: ACT_GATHER_INFO
2018-05-11 Name: The remote Fedora host is missing a security update.
File: fedora_2018-2359c2ae0e.nasl - Type: ACT_GATHER_INFO
2018-05-11 Name: The remote Fedora host is missing a security update.
File: fedora_2018-1ba93b3144.nasl - Type: ACT_GATHER_INFO
2018-04-27 Name: The remote Debian host is missing a security update.
File: debian_DLA-1365.nasl - Type: ACT_GATHER_INFO
2018-04-27 Name: The remote web server hosts a script that is affected by a cross-site scripti...
File: ckeditor_image2_xss.nasl - Type: ACT_GATHER_INFO
2018-04-26 Name: The remote Debian host is missing a security-related update.
File: debian_DSA-4180.nasl - Type: ACT_GATHER_INFO
2018-04-25 Name: A PHP application running on the remote web server is affected by a remote co...
File: drupal_8_5_3.nasl - Type: ACT_GATHER_INFO
2018-04-24 Name: The remote Fedora host is missing a security update.
File: fedora_2018-922cc2fbaa.nasl - Type: ACT_GATHER_INFO
2018-04-16 Name: The remote FreeBSD host is missing a security-related update.
File: freebsd_pkg_a9e466e8414411e8a29200e04c1ea73d.nasl - Type: ACT_GATHER_INFO
2018-04-11 Name: The remote Fedora host is missing a security update.
File: fedora_2018-d8269e4262.nasl - Type: ACT_GATHER_INFO
2018-04-11 Name: The remote Fedora host is missing a security update.
File: fedora_2018-143886fdbd.nasl - Type: ACT_GATHER_INFO
2018-03-29 Name: The remote Debian host is missing a security-related update.
File: debian_DSA-4156.nasl - Type: ACT_GATHER_INFO
2018-03-29 Name: The remote Debian host is missing a security update.
File: debian_DLA-1325.nasl - Type: ACT_GATHER_INFO
2018-03-28 Name: A PHP application running on the remote web server is affected by a remote co...
File: drupal_8_5_1.nasl - Type: ACT_GATHER_INFO