This CPE summary could be partial or incomplete. Please contact us for a detailed listing.

Summary

Detail
Vendor Egroupware First view 2004-12-31
Product Egroupware Last view 2017-09-29
Version 1.0.3 Type Application
Update *  
Edition *  
Language *  
Sofware Edition *  
Target Software *  
Target Hardware *  
Other *  
 
CPE Product cpe:2.3:a:egroupware:egroupware

Activity : Overall

Related : CVE

  Date Alert Description
6.1 2017-09-29 CVE-2017-14920

Stored XSS vulnerability in eGroupware Community Edition before 16.1.20170922 allows an unauthenticated remote attacker to inject JavaScript via the User-Agent HTTP header, which is mishandled during rendering by the application administrator.

7.5 2015-03-31 CVE-2014-2027

eGroupware before 1.8.006.20140217 allows remote attackers to conduct PHP object injection attacks, delete arbitrary files, and possibly execute arbitrary code via the (1) addr_fields or (2) trans parameter to addressbook/csv_import.php, (3) cal_fields or (4) trans parameter to calendar/csv_import.php, (5) info_fields or (6) trans parameter to csv_import.php in (a) projectmanager/ or (b) infolog/, or (7) processed parameter to preferences/inc/class.uiaclprefs.inc.php.

8.5 2014-10-26 CVE-2014-2988

EGroupware Enterprise Line (EPL) before 1.1.20140505, EGroupware Community Edition before 1.8.007.20140506, and EGroupware before 14.1 beta allows remote authenticated administrators to execute arbitrary PHP code via crafted callback values to the call_user_func PHP function, as demonstrated using the newsettings[system] parameter. NOTE: this can be exploited by remote attackers by leveraging CVE-2014-2987.

6.8 2014-10-26 CVE-2014-2987

Multiple cross-site request forgery (CSRF) vulnerabilities in EGroupware Enterprise Line (EPL) before 1.1.20140505, EGroupware Community Edition before 1.8.007.20140506, and EGroupware before 14.1 beta allow remote attackers to hijack the authentication of administrators for requests that (1) create an administrator user via an admin.uiaccounts.add_user action to index.php or (2) modify settings via the newsettings parameter in an admin.uiconfig.index action to index.php. NOTE: vector 2 can be used to execute arbitrary PHP code by leveraging CVE-2014-2988.

4.3 2012-11-22 CVE-2012-2211

Cross-site scripting (XSS) vulnerability in phpgwapi/inc/common_functions_inc.php in eGroupware before 1.8.004.20120405 allows remote attackers to inject arbitrary web script or HTML via the menuaction parameter to etemplate/process_exec.php. NOTE: some of these details are obtained from third party information.

5.8 2012-08-31 CVE-2011-4951

Open redirect vulnerability in phpgwapi/ntlm/index.php in EGroupware Enterprise Line (EPL) before 11.1.20110804-1 and EGroupware Community Edition before 1.8.001.20110805 allows remote attackers to redirect users to arbitrary web sites and conduct phishing attacks via a URL in the forward parameter.

4.3 2012-08-31 CVE-2011-4950

Cross-site scripting (XSS) vulnerability in phpgwapi/js/jscalendar/test.php in EGroupware Enterprise Line (EPL) before 11.1.20110804-1 and EGroupware Community Edition before 1.8.001.20110805 allows remote attackers to inject arbitrary web script or HTML via the lang parameter.

7.5 2012-08-31 CVE-2011-4949

SQL injection vulnerability in phpgwapi/js/dhtmlxtree/samples/with_db/loaddetails.php in EGroupware Enterprise Line (EPL) before 11.1.20110804-1 and EGroupware Community Edition before 1.8.001.20110805 allows remote attackers to execute arbitrary SQL commands via the id parameter.

5 2012-08-31 CVE-2011-4948

Directory traversal vulnerability in admin/remote.php in EGroupware Enterprise Line (EPL) before 11.1.20110804-1 and EGroupware Community Edition before 1.8.001.20110805 allows remote attackers to read arbitrary files via a ..%2f (encoded dot dot slash) in the type parameter.

10 2008-04-30 CVE-2008-2041

Multiple unspecified vulnerabilities in eGroupWare before 1.4.004 have unspecified attack vectors and "grave" impact when the web server has write access to a directory under the web document root.

4.3 2008-03-25 CVE-2008-1502

The _bad_protocol_once function in phpgwapi/inc/class.kses.inc.php in KSES, as used in eGroupWare before 1.4.003, Moodle before 1.8.5, and other products, allows remote attackers to bypass HTML filtering and conduct cross-site scripting (XSS) attacks via a string containing crafted URL protocols.

10 2007-06-11 CVE-2007-3155

Unspecified vulnerability in eGroupWare before 1.2.107-2 has unknown impact and attack vectors related to ADOdb. NOTE: due to lack of details from the vendor, it is uncertain whether this issue is already covered by another CVE identifier.

10 2007-06-11 CVE-2007-3154

Unspecified vulnerability in Walter Zorn wz_tooltip.js (aka wz_tooltips) before 4.01, as used by eGroupWare before 1.2.107-2 and other packages, has unknown impact and remote attack vectors.

7.5 2005-05-02 CVE-2005-1203

Multiple SQL injection vulnerabilities in index.php in eGroupware before 1.0.0.007 allow remote attackers to execute arbitrary SQL commands via the (1) filter or (2) cats_app parameter.

6.8 2005-05-02 CVE-2005-1202

Multiple cross-site scripting (XSS) vulnerabilities in eGroupware before 1.0.0.007 allow remote attackers to inject arbitrary web script or HTML via the (1) ab_id, (2) page, (3) type, or (4) lang parameter to index.php or (5) category_id parameter.

4.3 2004-12-31 CVE-2004-1467

Multiple cross-site scripting (XSS) vulnerabilities in eGroupWare 1.0.00.003 and earlier allow remote attackers to inject arbitrary web script or HTML via (1) date or search text field in the calendar module, (2) Field parameter, Filter parameter, QField parameter, Start parameter or Search field in the address module, (3) Subject field in the message module or (4) Subject field in the Ticket module.

CWE : Common Weakness Enumeration

%idName
40% (4) CWE-79 Failure to Preserve Web Page Structure ('Cross-site Scripting')
30% (3) CWE-94 Failure to Control Generation of Code ('Code Injection')
10% (1) CWE-352 Cross-Site Request Forgery (CSRF)
10% (1) CWE-89 Improper Sanitization of Special Elements used in an SQL Command ('...
10% (1) CWE-22 Improper Limitation of a Pathname to a Restricted Directory ('Path ...

Open Source Vulnerability Database (OSVDB)

id Description
44986 eGroupWare Web Server Write Access Unspecified "Grave" Issue
43677 KSES class.kses.inc.php _bad_protocol_once() Function HTML Filter Bypass
37188 eGroupWare ADOdb Unspecified Issue
37187 Walter Zorn wz_tooltip.js (aka wz_tooltips) Unspecified Issue
15753 eGroupWare index.php cats_app Parameter SQL Injection
15752 eGroupWare tts/index.php filter Parameter SQL Injection
15751 eGroupWare sitemgr-site/index.php category_id Parameter XSS
15649 eGroupWare index.php Multiple Parameter XSS
9138 eGroupWare Ticket Module Subject Parameter XSS
9137 eGroupWare Messenger Module Subject Parameter XSS
9136 eGroupWare Address Book Module Multiple Parameter XSS
9134 eGroupWare Calendar Module date Parameter XSS

ExploitDB Exploits

id Description
33389 EGroupware 1.8.006 - Multiple Vulnerabilities

OpenVAS Exploits

id Description
2011-06-07 Name : eGroupware Multiple Vulnerabilities
File : nvt/gb_egroupware_mult_vuln.nasl
2009-10-19 Name : Mandrake Security Advisory MDVSA-2009:265 (egroupware)
File : nvt/mdksa_2009_265.nasl
2009-09-02 Name : Debian Security Advisory DSA 1871-1 (wordpress)
File : nvt/deb_1871_1.nasl
2009-09-02 Name : Debian Security Advisory DSA 1871-2 (wordpress)
File : nvt/deb_1871_2.nasl
2009-06-05 Name : Ubuntu USN-698-1 (nagios)
File : nvt/ubuntu_698_1.nasl
2009-03-23 Name : Ubuntu Update for moodle vulnerability USN-658-1
File : nvt/gb_ubuntu_USN_658_1.nasl
2009-02-17 Name : Fedora Update for moodle FEDORA-2008-6226
File : nvt/gb_fedora_2008_6226_moodle_fc8.nasl
2008-12-29 Name : Debian Security Advisory DSA 1691-1 (moodle)
File : nvt/deb_1691_1.nasl
2008-12-29 Name : Ubuntu USN-698-2 (nagios3)
File : nvt/ubuntu_698_2.nasl
2008-12-29 Name : Ubuntu USN-699-1 (blender)
File : nvt/ubuntu_699_1.nasl
2008-09-24 Name : Gentoo Security Advisory GLSA 200409-06 (eGroupWare)
File : nvt/glsa_200409_06.nasl
2008-09-24 Name : Gentoo Security Advisory GLSA 200504-24 (eGroupWare)
File : nvt/glsa_200504_24.nasl
2008-09-24 Name : Gentoo Security Advisory GLSA 200805-04 (egroupware)
File : nvt/glsa_200805_04.nasl
2008-09-04 Name : FreeBSD Ports: egroupware
File : nvt/freebsd_egroupware.nasl

Nessus® Vulnerability Scanner

id Description
2017-11-13 Name: The remote Gentoo host is missing one or more security-related patches.
File: gentoo_GLSA-201711-12.nasl - Type: ACT_GATHER_INFO
2015-03-30 Name: The remote Mandriva Linux host is missing one or more security updates.
File: mandriva_MDVSA-2015-087.nasl - Type: ACT_GATHER_INFO
2010-02-24 Name: The remote Debian host is missing a security-related update.
File: debian_DSA-1871.nasl - Type: ACT_GATHER_INFO
2009-04-23 Name: The remote Ubuntu host is missing a security-related patch.
File: ubuntu_USN-658-1.nasl - Type: ACT_GATHER_INFO
2008-12-22 Name: The remote Debian host is missing a security-related update.
File: debian_DSA-1691.nasl - Type: ACT_GATHER_INFO
2008-07-16 Name: The remote openSUSE host is missing a security update.
File: suse_moodle-5439.nasl - Type: ACT_GATHER_INFO
2008-07-10 Name: The remote Fedora host is missing a security update.
File: fedora_2008-6226.nasl - Type: ACT_GATHER_INFO
2008-05-09 Name: The remote Gentoo host is missing one or more security-related patches.
File: gentoo_GLSA-200805-04.nasl - Type: ACT_GATHER_INFO
2005-08-01 Name: The remote FreeBSD host is missing a security-related update.
File: freebsd_pkg_b4892b5bfb1c11d996ba00909925db3e.nasl - Type: ACT_GATHER_INFO
2005-04-25 Name: The remote Gentoo host is missing one or more security-related patches.
File: gentoo_GLSA-200504-24.nasl - Type: ACT_GATHER_INFO
2004-11-13 Name: The remote web server contains a PHP application that is vulnerable to multip...
File: egroupware_unknown_vuln.nasl - Type: ACT_GATHER_INFO
2004-09-03 Name: The remote Gentoo host is missing one or more security-related patches.
File: gentoo_GLSA-200409-06.nasl - Type: ACT_GATHER_INFO
2004-08-23 Name: A web application running on the remote host has a cross-site scripting vulne...
File: egroupware_xss.nasl - Type: ACT_ATTACK