Executive Summary

Summary
TitleVMware ESXi and ESX security update for third party library
Informations
NameVMSA-2013-0004First vendor Publication2013-03-28
VendorVMwareLast vendor Modification2013-05-30
Severity (Vendor) N/ARevision3

Security-Database Scoring CVSS v2

Cvss vector : (AV:N/AC:M/Au:N/C:P/I:P/A:P)
Cvss Base Score6.8Attack RangeNetwork
Cvss Impact Score6.4Attack ComplexityMedium
Cvss Expoit Score8.6AuthenticationNone Required
Calculate full CVSS 2.0 Vectors scores

Detail

a. Update to ESX/ESXi libxml2 userworld and service console.

The ESX/ESXi userworld libxml2 library has been updated to resolve a security issue. Also, the ESX service console libxml2 packages are updated to the following versions:

libxml2-2.6.26-2.1.15.el5_8.6 libxml2-python-2.6.26-2.1.15.el5_8.6

The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2012-5134 to this issue.

Original Source

Url : http://www.vmware.com/security/advisories/VMSA-2013-0004.html

CWE : Common Weakness Enumeration

%idName
100 %CWE-119Failure to Constrain Operations within the Bounds of a Memory Buffer

OVAL Definitions

Definition Id: oval:org.mitre.oval:def:21665
 
Oval ID: oval:org.mitre.oval:def:21665
Title: RHSA-2012:1512: libxml2 security update (Important)
Description: Heap-based buffer underflow in the xmlParseAttValueComplex function in parser.c in libxml2 2.9.0 and earlier, as used in Google Chrome before 23.0.1271.91 and other products, allows remote attackers to cause a denial of service or possibly execute arbitrary code via crafted entities in an XML document.
Family: unix Class: patch
Reference(s): RHSA-2012:1512-01
CESA-2012:1512
CVE-2012-5134
Version: 4
Platform(s): Red Hat Enterprise Linux 5
Red Hat Enterprise Linux 6
CentOS Linux 5
CentOS Linux 6
Product(s): libxml2
Definition Synopsis:
Definition Id: oval:org.mitre.oval:def:20771
 
Oval ID: oval:org.mitre.oval:def:20771
Title: RHSA-2013:0217: mingw32-libxml2 security update (Important)
Description: Heap-based buffer underflow in the xmlParseAttValueComplex function in parser.c in libxml2 2.9.0 and earlier, as used in Google Chrome before 23.0.1271.91 and other products, allows remote attackers to cause a denial of service or possibly execute arbitrary code via crafted entities in an XML document.
Family: unix Class: patch
Reference(s): RHSA-2013:0217-01
CESA-2013:0217
CVE-2010-4008
CVE-2010-4494
CVE-2011-0216
CVE-2011-1944
CVE-2011-2821
CVE-2011-2834
CVE-2011-3102
CVE-2011-3905
CVE-2011-3919
CVE-2012-0841
CVE-2012-5134
Version: 157
Platform(s): Red Hat Enterprise Linux 6
CentOS Linux 6
Product(s): mingw32-libxml2
Definition Synopsis:
Definition Id: oval:org.mitre.oval:def:20411
 
Oval ID: oval:org.mitre.oval:def:20411
Title: VMware ESXi and ESX security update for third party library
Description: Heap-based buffer underflow in the xmlParseAttValueComplex function in parser.c in libxml2 2.9.0 and earlier, as used in Google Chrome before 23.0.1271.91 and other products, allows remote attackers to cause a denial of service or possibly execute arbitrary code via crafted entities in an XML document.
Family: unix Class: vulnerability
Reference(s): CVE-2012-5134
Version: 4
Platform(s): VMWare ESX Server 4.1
VMWare ESX Server 4.0
Product(s):
Definition Synopsis:
Definition Id: oval:org.mitre.oval:def:19412
 
Oval ID: oval:org.mitre.oval:def:19412
Title: DSA-2580-1 libxml2 - buffer overflow
Description: Jueri Aedla discovered a buffer overflow in the libxml XML library, which could result in the execution of arbitrary code.
Family: unix Class: patch
Reference(s): DSA-2580-1
CVE-2012-5134
Version: 5
Platform(s): Debian GNU/Linux 6.0
Debian GNU/kFreeBSD 6.0
Product(s): libxml2
Definition Synopsis:
Definition Id: oval:org.mitre.oval:def:17901
 
Oval ID: oval:org.mitre.oval:def:17901
Title: USN-1656-1 -- libxml2 vulnerability
Description: Applications using libxml2 could be made to crash or run programs as your login if they opened a specially crafted file.
Family: unix Class: patch
Reference(s): USN-1656-1
CVE-2012-5134
Version: 7
Platform(s): Ubuntu 12.10
Ubuntu 12.04
Ubuntu 11.10
Ubuntu 10.04
Ubuntu 8.04
Product(s): libxml2
Definition Synopsis:
Definition Id: oval:org.mitre.oval:def:23922
 
Oval ID: oval:org.mitre.oval:def:23922
Title: ELSA-2012:1512: libxml2 security update (Important)
Description: Heap-based buffer underflow in the xmlParseAttValueComplex function in parser.c in libxml2 2.9.0 and earlier, as used in Google Chrome before 23.0.1271.91 and other products, allows remote attackers to cause a denial of service or possibly execute arbitrary code via crafted entities in an XML document.
Family: unix Class: patch
Reference(s): ELSA-2012:1512-01
CVE-2012-5134
Version: 6
Platform(s): Oracle Linux 5
Oracle Linux 6
Product(s): libxml2
Definition Synopsis:
Definition Id: oval:org.mitre.oval:def:23888
 
Oval ID: oval:org.mitre.oval:def:23888
Title: ELSA-2013:0217: mingw32-libxml2 security update (Important)
Description: Heap-based buffer underflow in the xmlParseAttValueComplex function in parser.c in libxml2 2.9.0 and earlier, as used in Google Chrome before 23.0.1271.91 and other products, allows remote attackers to cause a denial of service or possibly execute arbitrary code via crafted entities in an XML document.
Family: unix Class: patch
Reference(s): ELSA-2013:0217-01
CVE-2010-4008
CVE-2010-4494
CVE-2011-0216
CVE-2011-1944
CVE-2011-2821
CVE-2011-2834
CVE-2011-3102
CVE-2011-3905
CVE-2011-3919
CVE-2012-0841
CVE-2012-5134
Version: 49
Platform(s): Oracle Linux 6
Product(s): mingw32-libxml2
Definition Synopsis:
Definition Id: oval:org.mitre.oval:def:23439
 
Oval ID: oval:org.mitre.oval:def:23439
Title: DEPRECATED: ELSA-2012:1512: libxml2 security update (Important)
Description: Heap-based buffer underflow in the xmlParseAttValueComplex function in parser.c in libxml2 2.9.0 and earlier, as used in Google Chrome before 23.0.1271.91 and other products, allows remote attackers to cause a denial of service or possibly execute arbitrary code via crafted entities in an XML document.
Family: unix Class: patch
Reference(s): ELSA-2012:1512-01
CVE-2012-5134
Version: 7
Platform(s): Oracle Linux 5
Oracle Linux 6
Product(s): libxml2
Definition Synopsis:
Definition Id: oval:org.mitre.oval:def:26819
 
Oval ID: oval:org.mitre.oval:def:26819
Title: Allows remote attackers to cause a denial of service or possibly execute arbitrary code
Description: Heap-based buffer underflow in the xmlParseAttValueComplex function in parser.c in libxml2 2.9.0 and earlier, as used in Google Chrome before 23.0.1271.91 and other products, allows remote attackers to cause a denial of service or possibly execute arbitrary code via crafted entities in an XML document.
Family: windows Class: vulnerability
Reference(s): CVE-2012-5134
Version: 3
Platform(s): Microsoft Windows 2000
Microsoft Windows XP
Microsoft Windows Server 2003
Microsoft Windows Server 2008
Microsoft Windows Server 2008 R2
Microsoft Windows Vista
Microsoft Windows 7
Microsoft Windows 8
Microsoft Windows 8.1
Microsoft Windows Server 2012
Microsoft Windows Server 2012 R2
Product(s): Google Chrome
Definition Synopsis:
Definition Id: oval:org.mitre.oval:def:27385
 
Oval ID: oval:org.mitre.oval:def:27385
Title: DEPRECATED: ELSA-2013-0217 -- mingw32-libxml2 security update (important)
Description: [2.7.6-6] - Synchronize patch-set with mainline-version. - Bump version to 5, 6. Related: rhbz#891477 [2.7.6-4] - Change release number to 4. - Added patch libxml2-Fix-an-off-by-one-pointer-access.patch - Added patch libxml2-Fix-a-segfault-on-XSD-validation-on-pattern-error.patch - Added patch libxml2-Fix-entities-local-buffers-size-problems.patch - Added patch libxml2-gnome-bug-561340-fix.patch - Added patch for CVE-2012-0841 - Added patch for CVE-2011-0216 - Added patch for CVE-2011-2834 - Added patch for CVE-2011-3919 - Added patch for CVE-2011-1944 - Added patch for CVE-2011-3905 Related: rhbz#891477
Family: unix Class: patch
Reference(s): ELSA-2013-0217
CVE-2012-0841
CVE-2011-3905
CVE-2011-3919
CVE-2010-4008
CVE-2010-4494
CVE-2011-0216
CVE-2011-1944
CVE-2011-2821
CVE-2011-2834
CVE-2011-3102
CVE-2012-5134
Version: 4
Platform(s): Oracle Linux 6
Product(s): mingw32-libxml2
Definition Synopsis:
Definition Id: oval:org.mitre.oval:def:27133
 
Oval ID: oval:org.mitre.oval:def:27133
Title: DEPRECATED: ELSA-2012-1512 -- libxml2 security update (important)
Description: [2.7.6-8.0.1.el6_3.4 ] - Update doc/redhat.gif in tarball - Add libxml2-oracle-enterprise.patch and update logos in tarball [2.7.6-8.el6_3.4] - fix out of range heap access (CVE-2012-5134)
Family: unix Class: patch
Reference(s): ELSA-2012-1512
CVE-2012-5134
Version: 4
Platform(s): Oracle Linux 5
Oracle Linux 6
Product(s): libxml2
Definition Synopsis:

CPE : Common Platform Enumeration

TypeDescriptionCount
Application2555
Application138
Os123

OpenVAS Exploits

DateDescription
2012-12-14Name : SuSE Update for Chromium openSUSE-SU-2012:1637-1 (Chromium)
File : nvt/gb_suse_2012_1637_1.nasl
2012-12-06Name : Ubuntu Update for libxml2 USN-1656-1
File : nvt/gb_ubuntu_USN_1656_1.nasl
2012-12-04Name : RedHat Update for libxml2 RHSA-2012:1512-01
File : nvt/gb_RHSA-2012_1512-01_libxml2.nasl
2012-12-04Name : Mandriva Update for libxml2 MDVSA-2012:176 (libxml2)
File : nvt/gb_mandriva_MDVSA_2012_176.nasl
2012-12-04Name : Debian Security Advisory DSA 2580-1 (libxml2)
File : nvt/deb_2580_1.nasl
2012-12-04Name : FreeBSD Ports: chromium
File : nvt/freebsd_chromium24.nasl
2012-12-04Name : CentOS Update for libxml2 CESA-2012:1512 centos5
File : nvt/gb_CESA-2012_1512_libxml2_centos5.nasl
2012-12-04Name : CentOS Update for libxml2 CESA-2012:1512 centos6
File : nvt/gb_CESA-2012_1512_libxml2_centos6.nasl
2012-12-04Name : Google Chrome Multiple Vulnerabilities-01 Dec2012 (Linux)
File : nvt/gb_google_chrome_mult_vuln01_dec12_lin.nasl
2012-12-04Name : Google Chrome Multiple Vulnerabilities-01 Dec2012 (Mac OS X)
File : nvt/gb_google_chrome_mult_vuln01_dec12_macosx.nasl
2012-12-04Name : Google Chrome Multiple Vulnerabilities-01 Dec2012 (Windows)
File : nvt/gb_google_chrome_mult_vuln01_dec12_win.nasl

Nessus® Vulnerability Scanner

DateDescription
2016-03-04Name : The remote VMware ESX / ESXi host is missing a security-related patch.
File : vmware_esx_VMSA-2013-0004_remote.nasl - Type : ACT_GATHER_INFO
2015-05-20Name : The remote SUSE host is missing one or more security updates.
File : suse_SU-2013-1627-1.nasl - Type : ACT_GATHER_INFO
2015-01-23Name : The remote device is missing a vendor-supplied security patch.
File : juniper_jsa10669.nasl - Type : ACT_GATHER_INFO
2015-01-19Name : The remote Solaris system is missing a security patch for third-party software.
File : solaris11_libxml2_20130702.nasl - Type : ACT_GATHER_INFO
2014-11-26Name : The remote OracleVM host is missing one or more security updates.
File : oraclevm_OVMSA-2013-0004.nasl - Type : ACT_GATHER_INFO
2014-06-13Name : The remote openSUSE host is missing a security update.
File : openSUSE-2012-845.nasl - Type : ACT_GATHER_INFO
2014-06-13Name : The remote openSUSE host is missing a security update.
File : openSUSE-2012-854.nasl - Type : ACT_GATHER_INFO
2014-01-23Name : The remote host contains an application that has multiple vulnerabilities.
File : itunes_11_1_4.nasl - Type : ACT_GATHER_INFO
2014-01-23Name : The remote host contains a multimedia application that has multiple vulnerabi...
File : itunes_11_1_4_banner.nasl - Type : ACT_GATHER_INFO
2013-11-13Name : The remote VMware ESXi 5.0 host is affected by multiple vulnerabilities.
File : vmware_esxi_5_0_build_1022489_remote.nasl - Type : ACT_GATHER_INFO
2013-11-13Name : The remote VMware ESXi 5.1 host is affected by multiple security vulnerabilit...
File : vmware_esxi_5_1_build_1063671_remote.nasl - Type : ACT_GATHER_INFO
2013-11-11Name : The remote Gentoo host is missing one or more security-related patches.
File : gentoo_GLSA-201311-06.nasl - Type : ACT_GATHER_INFO
2013-10-24Name : The remote host contains an application that has multiple vulnerabilities.
File : itunes_11_1_2.nasl - Type : ACT_GATHER_INFO
2013-10-24Name : The remote host contains a multimedia application that has multiple vulnerabi...
File : itunes_11_1_2_banner.nasl - Type : ACT_GATHER_INFO
2013-10-01Name : The remote device is affected by multiple vulnerabilities.
File : appletv_6_0.nasl - Type : ACT_GATHER_INFO
2013-09-04Name : The remote Amazon Linux AMI host is missing a security update.
File : ala_ALAS-2012-143.nasl - Type : ACT_GATHER_INFO
2013-07-12Name : The remote Oracle Linux host is missing one or more security updates.
File : oraclelinux_ELSA-2012-1512.nasl - Type : ACT_GATHER_INFO
2013-07-12Name : The remote Oracle Linux host is missing one or more security updates.
File : oraclelinux_ELSA-2013-0217.nasl - Type : ACT_GATHER_INFO
2013-04-20Name : The remote Mandriva Linux host is missing one or more security updates.
File : mandriva_MDVSA-2013-056.nasl - Type : ACT_GATHER_INFO
2013-03-29Name : The remote VMware ESXi / ESX host is missing a security-related patch.
File : vmware_VMSA-2013-0004.nasl - Type : ACT_GATHER_INFO
2013-02-04Name : The remote Scientific Linux host is missing one or more security updates.
File : sl_20130131_mingw32_libxml2_on_SL6_x.nasl - Type : ACT_GATHER_INFO
2013-02-01Name : The remote CentOS host is missing one or more security updates.
File : centos_RHSA-2013-0217.nasl - Type : ACT_GATHER_INFO
2013-02-01Name : The remote Red Hat host is missing one or more security updates.
File : redhat-RHSA-2013-0217.nasl - Type : ACT_GATHER_INFO
2013-01-25Name : The remote SuSE 11 host is missing one or more security updates.
File : suse_11_libxml2-121207.nasl - Type : ACT_GATHER_INFO
2012-12-07Name : The remote Slackware host is missing a security update.
File : Slackware_SSA_2012-341-03.nasl - Type : ACT_GATHER_INFO
2012-12-06Name : The remote Ubuntu host is missing a security-related patch.
File : ubuntu_USN-1656-1.nasl - Type : ACT_GATHER_INFO
2012-12-03Name : The remote Mandriva Linux host is missing one or more security updates.
File : mandriva_MDVSA-2012-176.nasl - Type : ACT_GATHER_INFO
2012-12-03Name : The remote Debian host is missing a security-related update.
File : debian_DSA-2580.nasl - Type : ACT_GATHER_INFO
2012-11-30Name : The remote Red Hat host is missing one or more security updates.
File : redhat-RHSA-2012-1512.nasl - Type : ACT_GATHER_INFO
2012-11-30Name : The remote CentOS host is missing one or more security updates.
File : centos_RHSA-2012-1512.nasl - Type : ACT_GATHER_INFO
2012-11-30Name : The remote Scientific Linux host is missing one or more security updates.
File : sl_20121129_libxml2_on_SL5_x.nasl - Type : ACT_GATHER_INFO
2012-11-28Name : The remote FreeBSD host is missing a security-related update.
File : freebsd_pkg_4d64fc61387811e2a4eb00262d5ed8ee.nasl - Type : ACT_GATHER_INFO
2012-11-27Name : The remote host contains a web browser that is affected by multiple vulnerabi...
File : google_chrome_23_0_1271_91.nasl - Type : ACT_GATHER_INFO

Alert History

If you want to see full details history, please login or register.
0
1
2
3
4
5
6
7
8
9
DateInformations
2016-03-05 13:26:43
  • Multiple Updates
2014-11-27 13:28:44
  • Multiple Updates
2014-02-17 12:07:26
  • Multiple Updates
2013-05-31 09:18:52
  • Multiple Updates
2013-05-01 00:20:15
  • Multiple Updates
2013-05-01 00:18:42
  • Multiple Updates
2013-04-27 13:20:16
  • Multiple Updates
2013-04-27 09:40:27
  • Multiple Updates
2013-03-29 09:19:29
  • Multiple Updates
2013-03-29 09:17:28
  • First insertion