Executive Summary

Title LibThai vulnerability
NameUSN-885-1First vendor Publication2010-01-14
VendorUbuntuLast vendor Modification2010-01-18
Severity (Vendor) N/ARevisionN/A

Security-Database Scoring CVSS v2

Cvss vector : (AV:N/AC:L/Au:N/C:C/I:C/A:C)
Cvss Base Score10Attack RangeNetwork
Cvss Impact Score10Attack ComplexityLow
Cvss Expoit Score10AuthenticationNone Required
Calculate full CVSS 2.0 Vectors scores


A security issue affects the following Ubuntu releases:

Ubuntu 8.04 LTS Ubuntu 8.10 Ubuntu 9.04 Ubuntu 9.10

This advisory also applies to the corresponding versions of Kubuntu, Edubuntu, and Xubuntu.

The problem can be corrected by upgrading your system to the following package versions:

Ubuntu 8.04 LTS:
libthai0 0.1.9-1ubuntu0.2

Ubuntu 8.10:
libthai0 0.1.9-4ubuntu0.8.10.2

Ubuntu 9.04:
libthai0 0.1.9-4ubuntu0.9.04.2

Ubuntu 9.10:
libthai0 0.1.12-1ubuntu0.2

In general, a standard system upgrade is sufficient to effect the necessary changes.

Details follow:

Tim Starling discovered that LibThai did not correctly handle long strings. A remote attacker could use specially-formed strings to execute arbitrary code with the user's privileges.

Original Source

Url : http://www.ubuntu.com/usn/USN-885-1

Alert History

If you want to see full details history, please login or register.
2016-04-27 00:33:23
  • Multiple Updates
2014-02-17 12:06:30
  • Multiple Updates
2013-05-11 00:56:16
  • Multiple Updates