Executive Summary

Summary
Title Irssi vulnerability
Informations
NameUSN-4119-1First vendor Publication2019-09-03
VendorUbuntuLast vendor Modification2019-09-03
Severity (Vendor) N/ARevisionN/A

Security-Database Scoring CVSS v2

Cvss vector : (AV:N/AC:L/Au:N/C:P/I:P/A:P)
Cvss Base Score7.5Attack RangeNetwork
Cvss Impact Score6.4Attack ComplexityLow
Cvss Expoit Score10AuthenticationNone Required
Calculate full CVSS 2.0 Vectors scores

Detail

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 19.04

Summary:

Irssi could be made to crash or execute arbitrary code if it received a specially crafted CAP request.

Software Description: - irssi: terminal based IRC client

Details:

It was discovered that Irssi incorrectly handled certain CAP requests. An attacker could possibly use this issue to cause a denial of service or execute arbitrary code.

Update instructions:

The problem can be corrected by updating your system to the following package versions:

Ubuntu 19.04:
irssi 1.2.0-2ubuntu1.2

After a standard system update you need to restart Irssi to make all the necessary changes.

References:
https://usn.ubuntu.com/4119-1
CVE-2019-15717

Package Information:
https://launchpad.net/ubuntu/+source/irssi/1.2.0-2ubuntu1.2

Original Source

Url : http://www.ubuntu.com/usn/USN-4119-1

CWE : Common Weakness Enumeration

%idName
100 %CWE-416Use After Free

CPE : Common Platform Enumeration

TypeDescriptionCount
Application2
Os1

Alert History

If you want to see full details history, please login or register.
0
1
DateInformations
2019-09-04 05:22:29
  • Multiple Updates
2019-09-03 21:18:43
  • First insertion