Executive Summary

Summary
Title BWA vulnerability
Informations
NameUSN-4087-1First vendor Publication2019-08-06
VendorUbuntuLast vendor Modification2019-08-06
Severity (Vendor) N/ARevisionN/A

Security-Database Scoring CVSS v2

Cvss vector : (AV:N/AC:L/Au:N/C:C/I:C/A:C)
Cvss Base Score10Attack RangeNetwork
Cvss Impact Score10Attack ComplexityLow
Cvss Expoit Score10AuthenticationNone Required
Calculate full CVSS 2.0 Vectors scores

Detail

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 19.04 - Ubuntu 18.04 LTS

Summary:

BWA could be made to crash or run programs as your login if it opened a specially crafted file.

Software Description: - bwa: Software package for mapping DNA sequences against a large reference genome

Details:

It was discovered that Burrows-Wheeler Aligner (BWA) mishandled certain crafted .alt files. An attacker could use this vulnerability to cause a denial of service (crash) or possibly execute arbitrary code.

Update instructions:

The problem can be corrected by updating your system to the following package versions:

Ubuntu 19.04:
bwa 0.7.17-3~ubuntu0.19.04.1

Ubuntu 18.04 LTS:
bwa 0.7.17-1ubuntu0.1

In general, a standard system update will make all the necessary changes.

References:
https://usn.ubuntu.com/4087-1
CVE-2019-10269

Package Information:
https://launchpad.net/ubuntu/+source/bwa/0.7.17-3~ubuntu0.19.04.1
https://launchpad.net/ubuntu/+source/bwa/0.7.17-1ubuntu0.1

Original Source

Url : http://www.ubuntu.com/usn/USN-4087-1

CWE : Common Weakness Enumeration

%idName
100 %CWE-119Failure to Constrain Operations within the Bounds of a Memory Buffer

Alert History

If you want to see full details history, please login or register.
0
DateInformations
2019-08-06 21:19:22
  • First insertion