Executive Summary

Summary
Title D-Bus vulnerability
Informations
Name USN-401-1 First vendor Publication 2007-01-04
Vendor Ubuntu Last vendor Modification 2007-01-04
Severity (Vendor) N/A Revision N/A

Security-Database Scoring CVSS v2

Cvss vector : (AV:L/AC:L/Au:S/C:N/I:N/A:P)
Cvss Base Score 1.7 Attack Range Local
Cvss Impact Score 2.9 Attack Complexity Low
Cvss Expoit Score 3.1 Authentication Requires single instance
Calculate full CVSS 2.0 Vectors scores

Detail

A security issue affects the following Ubuntu releases:

Ubuntu 5.10 Ubuntu 6.06 LTS Ubuntu 6.10

This advisory also applies to the corresponding versions of Kubuntu, Edubuntu, and Xubuntu.

The problem can be corrected by upgrading your system to the following package versions:

Ubuntu 5.10:
dbus 0.36.2-0ubuntu7.1

Ubuntu 6.06 LTS:
dbus 0.60-6ubuntu8.1

Ubuntu 6.10:
dbus 0.93-0ubuntu3.1

After a standard system upgrade you need to reboot your computer to effect the necessary changes.

Details follow:

Kimmo Hämäläinen discovered that local users could delete other users' D-Bus match rules. Applications would stop receiving D-Bus messages, resulting in a local denial of service, and potential data loss for applications that depended on D-Bus for storing information.

Original Source

Url : http://www.ubuntu.com/usn/USN-401-1

OVAL Definitions

Definition Id:Ā oval:org.mitre.oval:def:9951
Ā 
Oval ID: oval:org.mitre.oval:def:9951
Title: Unspecified vulnerability in the match_rule_equal function in bus/signals.c in D-Bus before 1.0.2 allows local applications to remove match rules for other applications and cause a denial of service (lost process messages).
Description: Unspecified vulnerability in the match_rule_equal function in bus/signals.c in D-Bus before 1.0.2 allows local applications to remove match rules for other applications and cause a denial of service (lost process messages).
Family: unix Class: vulnerability
Reference(s): CVE-2006-6107
Version: 5
Platform(s): Red Hat Enterprise Linux 4
CentOS Linux 4
Oracle Linux 4
Product(s):
Definition Synopsis:

CPE : Common Platform Enumeration

TypeDescriptionCount
Application7

OpenVAS Exploits

DateDescription
2009-03-23Name : Ubuntu Update for dbus vulnerability USN-401-1
File : nvt/gb_ubuntu_USN_401_1.nasl
2008-09-04Name : FreeBSD Ports: dbus
File : nvt/freebsd_dbus.nasl

Open Source Vulnerability Database (OSVDB)

idDescription
32279D-Bus match_rule_equal() Function Rule Manipulation

NessusĀ® Vulnerability Scanner

DateDescription
2014-06-13Name : The remote openSUSE host is missing a security update.
File : openSUSE-2012-750.nasl - Type : ACT_GATHER_INFO
2013-07-12Name : The remote Oracle Linux host is missing one or more security updates.
File : oraclelinux_ELSA-2007-0008.nasl - Type : ACT_GATHER_INFO
2007-11-10Name : The remote Ubuntu host is missing one or more security-related patches.
File : ubuntu_USN-401-1.nasl - Type : ACT_GATHER_INFO
2007-02-18Name : The remote Mandrake Linux host is missing one or more security updates.
File : mandrake_MDKSA-2006-233.nasl - Type : ACT_GATHER_INFO
2007-02-09Name : The remote Red Hat host is missing one or more security updates.
File : redhat-RHSA-2007-0008.nasl - Type : ACT_GATHER_INFO
2007-02-09Name : The remote CentOS host is missing one or more security updates.
File : centos_RHSA-2007-0008.nasl - Type : ACT_GATHER_INFO
2006-12-16Name : The remote FreeBSD host is missing a security-related update.
File : freebsd_pkg_5b47b70d8ba911db81d500123ffe8333.nasl - Type : ACT_GATHER_INFO

Alert History

If you want to see full details history, please login or register.
0
DateInformations
2014-02-17 12:04:04
  • Multiple Updates