Executive Summary



This Alert is flagged as TOP 25 Common Weakness Enumeration from CWE/SANS. For more information, you can read this.
Summary
Title LibRaw vulnerabilities
Informations
NameUSN-3838-1First vendor Publication2018-12-06
VendorUbuntuLast vendor Modification2018-12-06
Severity (Vendor) N/ARevisionN/A

Security-Database Scoring CVSS v2

Cvss vector : (AV:N/AC:M/Au:N/C:N/I:N/A:C)
Cvss Base Score7.1Attack RangeNetwork
Cvss Impact Score6.9Attack ComplexityMedium
Cvss Expoit Score8.6AuthenticationNone Required
Calculate full CVSS 2.0 Vectors scores

Detail

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 18.04 LTS - Ubuntu 16.04 LTS - Ubuntu 14.04 LTS

Summary:

LibRaw could be made to crash or run programs as your login if it opened a specially crafted file.

Software Description: - libraw: raw image decoder library

Details:

It was discovered that LibRaw incorrectly handled photo files. If a user or automated system were tricked into processing a specially crafted photo file, a remote attacker could cause applications linked against LibRaw to crash, resulting in a denial of service, or possibly execute arbitrary code.

Update instructions:

The problem can be corrected by updating your system to the following package versions:

Ubuntu 18.04 LTS:
libraw16 0.18.8-1ubuntu0.2

Ubuntu 16.04 LTS:
libraw15 0.17.1-1ubuntu0.4

Ubuntu 14.04 LTS:
libraw9 0.15.4-1ubuntu0.3

After a standard system update you need to restart your session to make all the necessary changes.

References:
https://usn.ubuntu.com/usn/usn-3838-1
CVE-2018-5807, CVE-2018-5810, CVE-2018-5811, CVE-2018-5812,
CVE-2018-5813, CVE-2018-5815, CVE-2018-5816

Package Information:
https://launchpad.net/ubuntu/+source/libraw/0.18.8-1ubuntu0.2
https://launchpad.net/ubuntu/+source/libraw/0.17.1-1ubuntu0.4
https://launchpad.net/ubuntu/+source/libraw/0.15.4-1ubuntu0.3

Original Source

Url : http://www.ubuntu.com/usn/USN-3838-1

CWE : Common Weakness Enumeration

%idName
29 %CWE-190Integer Overflow or Wraparound (CWE/SANS Top 25)
29 %CWE-125Out-of-bounds Read
14 %CWE-476NULL Pointer Dereference
14 %CWE-400Uncontrolled Resource Consumption ('Resource Exhaustion')
14 %CWE-119Failure to Constrain Operations within the Bounds of a Memory Buffer

CPE : Common Platform Enumeration

TypeDescriptionCount
Application24
Os3

Nessus® Vulnerability Scanner

DateDescription
2019-01-03Name : The remote Fedora host is missing a security update.
File : fedora_2018-f37cbaafdf.nasl - Type : ACT_GATHER_INFO
2018-08-15Name : The remote Fedora host is missing a security update.
File : fedora_2018-baa8315daa.nasl - Type : ACT_GATHER_INFO

Alert History

If you want to see full details history, please login or register.
0
1
2
3
DateInformations
2019-01-03 21:21:05
  • Multiple Updates
2018-12-29 00:21:08
  • Multiple Updates
2018-12-08 17:21:11
  • Multiple Updates
2018-12-06 05:17:40
  • First insertion