Executive Summary



This Alert is flagged as TOP 25 Common Weakness Enumeration from CWE/SANS. For more information, you can read this.
Summary
Titlegit security update
Informations
NameRHSA-2010:1003First vendor Publication2010-12-21
VendorRedHatLast vendor Modification2010-12-21
Severity (Vendor) ModerateRevision01

Security-Database Scoring CVSS v2

Cvss vector : (AV:N/AC:M/Au:N/C:N/I:P/A:N)
Cvss Base Score4.3Attack RangeNetwork
Cvss Impact Score2.9Attack ComplexityMedium
Cvss Expoit Score8.6AuthenticationNone Required
Calculate full CVSS 2.0 Vectors scores

Detail

Problem Description:

Updated git packages that fix one security issue are now available for Red Hat Enterprise Linux 6.

The Red Hat Security Response Team has rated this update as having moderate security impact. A Common Vulnerability Scoring System (CVSS) base score, which gives a detailed severity rating, is available from the CVE link in the References section.

2. Relevant releases/architectures:

Red Hat Enterprise Linux Desktop Optional (v. 6) - i386, noarch, x86_64 Red Hat Enterprise Linux HPC Node Optional (v. 6) - noarch, x86_64 Red Hat Enterprise Linux Server (v. 6) - i386, noarch, ppc64, s390x, x86_64 Red Hat Enterprise Linux Server Optional (v. 6) - i386, noarch, ppc64, s390x, x86_64 Red Hat Enterprise Linux Workstation (v. 6) - i386, noarch, x86_64 Red Hat Enterprise Linux Workstation Optional (v. 6) - i386, noarch, x86_64

3. Description:

Git is a fast, scalable, distributed revision control system.

A cross-site scripting (XSS) flaw was found in gitweb, a simple web interface for Git repositories. A remote attacker could perform an XSS attack against victims by tricking them into visiting a specially-crafted gitweb URL. (CVE-2010-3906)

All gitweb users should upgrade to these updated packages, which contain a backported patch to correct this issue.

4. Solution:

Before applying this update, make sure all previously-released errata relevant to your system have been applied.

This update is available via the Red Hat Network. Details on how to use the Red Hat Network to apply this update are available at http://kbase.redhat.com/faq/docs/DOC-11259

5. Bugs fixed (http://bugzilla.redhat.com/):

663609 - CVE-2010-3906 Git (gitweb): XSS due to missing escaping of HTML element attributes

Original Source

Url : https://rhn.redhat.com/errata/RHSA-2010-1003.html

CWE : Common Weakness Enumeration

idName
CWE-79Failure to Preserve Web Page Structure ('Cross-site Scripting') (CWE/SANS Top 25)

OVAL Definitions

Definition Id: oval:org.mitre.oval:def:22223
 
Oval ID: oval:org.mitre.oval:def:22223
Title: RHSA-2010:1003: git security update (Moderate)
Description: Cross-site scripting (XSS) vulnerability in Gitweb 1.7.3.3 and earlier allows remote attackers to inject arbitrary web script or HTML via the (1) f and (2) fp parameters.
Family: unix Class: patch
Reference(s): RHSA-2010:1003-01
CVE-2010-3906
Version: 4
Platform(s): Red Hat Enterprise Linux 6
Product(s): git
Definition Synopsis:
Definition Id: oval:org.mitre.oval:def:23492
 
Oval ID: oval:org.mitre.oval:def:23492
Title: ELSA-2010:1003: git security update (Moderate)
Description: Cross-site scripting (XSS) vulnerability in Gitweb 1.7.3.3 and earlier allows remote attackers to inject arbitrary web script or HTML via the (1) f and (2) fp parameters.
Family: unix Class: patch
Reference(s): ELSA-2010:1003-01
CVE-2010-3906
Version: 6
Platform(s): Oracle Linux 6
Product(s): git
Definition Synopsis:

CPE : Common Platform Enumeration

TypeDescriptionCount
Application170

ExploitDB Exploits

idDescription
2010-12-15Gitweb <=1.7.3.3 Cross Site Scripting

OpenVAS Exploits

DateDescription
2011-01-11Name : Fedora Update for git FEDORA-2010-18973
File : nvt/gb_fedora_2010_18973_git_fc13.nasl
2010-12-28Name : Mandriva Update for git MDVSA-2010:256 (git)
File : nvt/gb_mandriva_MDVSA_2010_256.nasl
2010-12-28Name : Fedora Update for git FEDORA-2010-18981
File : nvt/gb_fedora_2010_18981_git_fc14.nasl

Open Source Vulnerability Database (OSVDB)

idDescription
69929Gitweb index.php Multiple Parameter XSS

Nessus® Vulnerability Scanner

DateDescription
2014-06-13Name : The remote openSUSE host is missing a security update.
File : suse_11_3_git-110117.nasl - Type : ACT_GATHER_INFO
2013-07-12Name : The remote Oracle Linux host is missing one or more security updates.
File : oraclelinux_ELSA-2010-1003.nasl - Type : ACT_GATHER_INFO
2012-08-01Name : The remote Scientific Linux host is missing one or more security updates.
File : sl_20101221_git_on_SL6_x.nasl - Type : ACT_GATHER_INFO
2011-05-05Name : The remote openSUSE host is missing a security update.
File : suse_11_2_git-110117.nasl - Type : ACT_GATHER_INFO
2011-01-04Name : The remote Fedora host is missing a security update.
File : fedora_2010-18973.nasl - Type : ACT_GATHER_INFO
2010-12-26Name : The remote Fedora host is missing a security update.
File : fedora_2010-18981.nasl - Type : ACT_GATHER_INFO
2010-12-23Name : The remote web server hosts a CGI script that is prone to a cross- site scrip...
File : gitweb_f_xss.nasl - Type : ACT_ATTACK
2010-12-22Name : The remote Red Hat host is missing one or more security updates.
File : redhat-RHSA-2010-1003.nasl - Type : ACT_GATHER_INFO
2010-12-17Name : The remote Mandriva Linux host is missing one or more security updates.
File : mandriva_MDVSA-2010-256.nasl - Type : ACT_GATHER_INFO

Alert History

If you want to see full details history, please login or register.
0
DateInformations
2014-02-17 11:54:12
  • Multiple Updates