Executive Summary

Summary
Title ethereal security update
Informations
Name RHSA-2006:0420 First vendor Publication 2006-05-03
Vendor RedHat Last vendor Modification 2006-05-03
Severity (Vendor) Moderate Revision 01

Security-Database Scoring CVSS v2

Cvss vector : (AV:N/AC:L/Au:N/C:C/I:C/A:C)
Cvss Base Score 10 Attack Range Network
Cvss Impact Score 10 Attack Complexity Low
Cvss Expoit Score 10 Authentication None Required
Calculate full CVSS 2.0 Vectors scores

Detail

Problem Description:

Updated Ethereal packages that fix various security vulnerabilities are now available.

This update has been rated as having moderate security impact by the Red Hat Security Response Team.

2. Relevant releases/architectures:

Red Hat Enterprise Linux AS (Advanced Server) version 2.1 - i386, ia64 Red Hat Linux Advanced Workstation 2.1 - ia64 Red Hat Enterprise Linux ES version 2.1 - i386 Red Hat Enterprise Linux WS version 2.1 - i386 Red Hat Enterprise Linux AS version 3 - i386, ia64, ppc, s390, s390x, x86_64 Red Hat Desktop version 3 - i386, x86_64 Red Hat Enterprise Linux ES version 3 - i386, ia64, x86_64 Red Hat Enterprise Linux WS version 3 - i386, ia64, x86_64 Red Hat Enterprise Linux AS version 4 - i386, ia64, ppc, s390, s390x, x86_64 Red Hat Enterprise Linux Desktop version 4 - i386, x86_64 Red Hat Enterprise Linux ES version 4 - i386, ia64, x86_64 Red Hat Enterprise Linux WS version 4 - i386, ia64, x86_64

3. Problem description:

Ethereal is a program for monitoring network traffic.

Several denial of service bugs were found in Ethereal's protocol dissectors. Ethereal could crash or stop responding if it reads a malformed packet off the network. (CVE-2006-1932, CVE-2006-1933, CVE-2006-1937, CVE-2006-1938, CVE-2006-1939, CVE-2006-1940)

Several buffer overflow bugs were found in Ethereal's COPS, telnet, and ALCAP dissectors as well as Network Instruments file code and NetXray/Windows Sniffer file code. Ethereal could crash or execute arbitrary code if it reads a malformed packet off the network. (CVE-2006-1934, CVE-2006-1935, CVE-2006-1936)

Users of ethereal should upgrade to these updated packages containing version 0.99.0, which is not vulnerable to these issues.

4. Solution:

Before applying this update, make sure all previously released errata relevant to your system have been applied.

This update is available via Red Hat Network. To use Red Hat Network, launch the Red Hat Update Agent with the following command:

up2date

This will start an interactive process that will result in the appropriate RPMs being upgraded on your system.

5. Bug IDs fixed (http://bugzilla.redhat.com/):

189906 - CVE-2006-1932 Multiple ethereal issues (CVE-2006-1933, CVE-2006-1934, CVE-2006-1935, CVE-2006-1936, CVE-2006-1937, CVE-2006-1938, CVE-2006-1939, CVE-2006-1940)

Original Source

Url : https://rhn.redhat.com/errata/RHSA-2006-0420.html

OVAL Definitions

Definition Id: oval:org.mitre.oval:def:9823
 
Oval ID: oval:org.mitre.oval:def:9823
Title: Off-by-one error in the OID printing routine in Ethereal 0.10.x up to 0.10.14 has unknown impact and remote attack vectors.
Description: Off-by-one error in the OID printing routine in Ethereal 0.10.x up to 0.10.14 has unknown impact and remote attack vectors.
Family: unix Class: vulnerability
Reference(s): CVE-2006-1932
Version: 5
Platform(s): Red Hat Enterprise Linux 3
CentOS Linux 3
Red Hat Enterprise Linux 4
CentOS Linux 4
Oracle Linux 4
Product(s):
Definition Synopsis:
Definition Id: oval:org.mitre.oval:def:10841
 
Oval ID: oval:org.mitre.oval:def:10841
Title: Multiple unspecified vulnerabilities in Ethereal 0.10.x up to 0.10.14 allow remote attackers to cause a denial of service (large or infinite loops) viarafted packets to the (1) UMA and (2) BER dissectors.
Description: Multiple unspecified vulnerabilities in Ethereal 0.10.x up to 0.10.14 allow remote attackers to cause a denial of service (large or infinite loops) viarafted packets to the (1) UMA and (2) BER dissectors.
Family: unix Class: vulnerability
Reference(s): CVE-2006-1933
Version: 5
Platform(s): Red Hat Enterprise Linux 3
CentOS Linux 3
Red Hat Enterprise Linux 4
CentOS Linux 4
Oracle Linux 4
Product(s):
Definition Synopsis:
Definition Id: oval:org.mitre.oval:def:10445
 
Oval ID: oval:org.mitre.oval:def:10445
Title: Multiple buffer overflows in Ethereal 0.10.x up to 0.10.14 allow remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via the (1) ALCAP dissector, (2) Network Instruments file code, or (3) NetXray/Windows Sniffer file code.
Description: Multiple buffer overflows in Ethereal 0.10.x up to 0.10.14 allow remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via the (1) ALCAP dissector, (2) Network Instruments file code, or (3) NetXray/Windows Sniffer file code.
Family: unix Class: vulnerability
Reference(s): CVE-2006-1934
Version: 5
Platform(s): Red Hat Enterprise Linux 3
CentOS Linux 3
Red Hat Enterprise Linux 4
CentOS Linux 4
Oracle Linux 4
Product(s):
Definition Synopsis:
Definition Id: oval:org.mitre.oval:def:10811
 
Oval ID: oval:org.mitre.oval:def:10811
Title: Buffer overflow in Ethereal 0.9.15 up to 0.10.14 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via the COPS dissector.
Description: Buffer overflow in Ethereal 0.9.15 up to 0.10.14 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via the COPS dissector.
Family: unix Class: vulnerability
Reference(s): CVE-2006-1935
Version: 5
Platform(s): Red Hat Enterprise Linux 3
CentOS Linux 3
Red Hat Enterprise Linux 4
CentOS Linux 4
Oracle Linux 4
Product(s):
Definition Synopsis:
Definition Id: oval:org.mitre.oval:def:10341
 
Oval ID: oval:org.mitre.oval:def:10341
Title: Buffer overflow in Ethereal 0.8.5 up to 0.10.14 allows remote attackers to execute arbitrary code via the telnet dissector.
Description: Buffer overflow in Ethereal 0.8.5 up to 0.10.14 allows remote attackers to execute arbitrary code via the telnet dissector.
Family: unix Class: vulnerability
Reference(s): CVE-2006-1936
Version: 5
Platform(s): Red Hat Enterprise Linux 3
CentOS Linux 3
Red Hat Enterprise Linux 4
CentOS Linux 4
Oracle Linux 4
Product(s):
Definition Synopsis:
Definition Id: oval:org.mitre.oval:def:10323
 
Oval ID: oval:org.mitre.oval:def:10323
Title: Multiple unspecified vulnerabilities in Ethereal 0.10.x up to 0.10.14 allow remote attackers to cause a denial of service (crash from null dereference) via (1) multiple vectors in H.248, and the (2) X.509if, (3) SRVLOC, (4) H.245, (5) AIM, and (6) general packet dissectors; and (7) the statistics counter.
Description: Multiple unspecified vulnerabilities in Ethereal 0.10.x up to 0.10.14 allow remote attackers to cause a denial of service (crash from null dereference) via (1) multiple vectors in H.248, and the (2) X.509if, (3) SRVLOC, (4) H.245, (5) AIM, and (6) general packet dissectors; and (7) the statistics counter.
Family: unix Class: vulnerability
Reference(s): CVE-2006-1937
Version: 5
Platform(s): Red Hat Enterprise Linux 3
CentOS Linux 3
Red Hat Enterprise Linux 4
CentOS Linux 4
Oracle Linux 4
Product(s):
Definition Synopsis:
Definition Id: oval:org.mitre.oval:def:9850
 
Oval ID: oval:org.mitre.oval:def:9850
Title: Multiple unspecified vulnerabilities in Ethereal 0.8.x up to 0.10.14 allow remote attackers to cause a denial of service (crash from null dereference) via the (1) Sniffer capture or (2) SMB PIPE dissector.
Description: Multiple unspecified vulnerabilities in Ethereal 0.8.x up to 0.10.14 allow remote attackers to cause a denial of service (crash from null dereference) via the (1) Sniffer capture or (2) SMB PIPE dissector.
Family: unix Class: vulnerability
Reference(s): CVE-2006-1938
Version: 5
Platform(s): Red Hat Enterprise Linux 3
CentOS Linux 3
Red Hat Enterprise Linux 4
CentOS Linux 4
Oracle Linux 4
Product(s):
Definition Synopsis:
Definition Id: oval:org.mitre.oval:def:11030
 
Oval ID: oval:org.mitre.oval:def:11030
Title: Multiple unspecified vulnerabilities in Ethereal 0.9.x up to 0.10.14 allow remote attackers to cause a denial of service (crash from null dereference) via (1) an invalid display filter, or the (2) GSM SMS, (3) ASN.1-based, (4) DCERPC NT, (5) PER, (6) RPC, (7) DCERPC, and (8) ASN.1 dissectors.
Description: Multiple unspecified vulnerabilities in Ethereal 0.9.x up to 0.10.14 allow remote attackers to cause a denial of service (crash from null dereference) via (1) an invalid display filter, or the (2) GSM SMS, (3) ASN.1-based, (4) DCERPC NT, (5) PER, (6) RPC, (7) DCERPC, and (8) ASN.1 dissectors.
Family: unix Class: vulnerability
Reference(s): CVE-2006-1939
Version: 5
Platform(s): Red Hat Enterprise Linux 3
CentOS Linux 3
Red Hat Enterprise Linux 4
CentOS Linux 4
Oracle Linux 4
Product(s):
Definition Synopsis:
Definition Id: oval:org.mitre.oval:def:9781
 
Oval ID: oval:org.mitre.oval:def:9781
Title: Unspecified vulnerability in Ethereal 0.10.4 up to 0.10.14 allows remote attackers to cause a denial of service (abort) via the SNDCP dissector.
Description: Unspecified vulnerability in Ethereal 0.10.4 up to 0.10.14 allows remote attackers to cause a denial of service (abort) via the SNDCP dissector.
Family: unix Class: vulnerability
Reference(s): CVE-2006-1940
Version: 5
Platform(s): Red Hat Enterprise Linux 3
CentOS Linux 3
Red Hat Enterprise Linux 4
CentOS Linux 4
Oracle Linux 4
Product(s):
Definition Synopsis:

CPE : Common Platform Enumeration

TypeDescriptionCount
Application54

OpenVAS Exploits

DateDescription
2008-09-24Name : Gentoo Security Advisory GLSA 200604-17 (Ethereal)
File : nvt/glsa_200604_17.nasl
2008-09-04Name : FreeBSD Ports: ethereal, ethereal-lite, tethereal, tethereal-lite
File : nvt/freebsd_ethereal7.nasl
2008-01-17Name : Debian Security Advisory DSA 1049-1 (ethereal)
File : nvt/deb_1049_1.nasl

Open Source Vulnerability Database (OSVDB)

idDescription
24933Ethereal H.248 Dissector Unspecified DoS
24932Ethereal ALCAP Dissector Overflow
24931Ethereal COPS Dissector Overflow
24930Ethereal OID Printing Routine Overflow
24929Ethereal H.245 Dissector Unspecified DoS
24928Ethereal SRVLOC Dissector Unspecified DoS
24927Ethereal X.509if Dissector Unspecified DoS
24926Ethereal UMA Dissector Infinite Loop DoS
24925Ethereal PER Dissector Unspecified DoS
24924Ethereal DCERPC NT Dissector Unspecified DoS
24923Ethereal H.248 Dissector Unspecified DoS
24922Ethereal ASN.1-based Dissectors Unspecified DoS
24921Ethereal telnet Dissector Unspecified Overflow
24920Ethereal ALCAP Dissector Unspecified Overflow
24919Ethereal GSM SMS Dissector Unspecified DoS
24918Ethereal NetXray/Windows Sniffer File Code Overflow
24917Ethereal Network Instruments File Code Overflow
24916Ethereal SNDCP Dissector Unspecified DoS
24915Ethereal BER Dissector Infinite Loop DoS
24914Ethereal SMB PIPE Dissector Unspecified DoS
24913Ethereal ASN.1 Dissector Unspecified DoS
24912Ethereal DCERPC Dissector Unspecified DoS
24911Ethereal RPC Dissector Unspecified DoS
24910Ethereal AIM Dissector Unspecified DoS
24909Ethereal General Packet Dissector Unspecified DoS
24908Ethereal Malformed Display Filter DoS
24907Ethereal Malformed Sniffer Capture Processing DoS
24906Ethereal Statistics Counter Unspecified DoS

Nessus® Vulnerability Scanner

DateDescription
2006-10-14Name : The remote Debian host is missing a security-related update.
File : debian_DSA-1049.nasl - Type : ACT_GATHER_INFO
2006-07-03Name : The remote CentOS host is missing one or more security updates.
File : centos_RHSA-2006-0420.nasl - Type : ACT_GATHER_INFO
2006-05-13Name : The remote Red Hat host is missing one or more security updates.
File : redhat-RHSA-2006-0420.nasl - Type : ACT_GATHER_INFO
2006-05-13Name : The remote FreeBSD host is missing one or more security-related updates.
File : freebsd_pkg_21c223f2d59611da809800123ffe8333.nasl - Type : ACT_GATHER_INFO
2006-04-28Name : The remote Gentoo host is missing one or more security-related patches.
File : gentoo_GLSA-200604-17.nasl - Type : ACT_GATHER_INFO
2006-04-28Name : The remote Fedora Core host is missing a security update.
File : fedora_2006-461.nasl - Type : ACT_GATHER_INFO
2006-04-26Name : The remote Fedora Core host is missing a security update.
File : fedora_2006-456.nasl - Type : ACT_GATHER_INFO
2006-04-26Name : The remote Mandrake Linux host is missing one or more security updates.
File : mandrake_MDKSA-2006-077.nasl - Type : ACT_GATHER_INFO

Alert History

If you want to see full details history, please login or register.
0
DateInformations
2014-02-17 11:50:00
  • Multiple Updates