Executive Summary

Summary
TitleVulnerability in .NET Framework Could Allow Denial of Service (2990931)
Informations
NameMS14-053First vendor Publication2014-09-09
VendorMicrosoftLast vendor Modification2014-09-17
Severity (Vendor) ImportantRevision1.1

Security-Database Scoring CVSS v2

Cvss vector : (AV:N/AC:L/Au:N/C:N/I:N/A:P)
Cvss Base Score5Attack RangeNetwork
Cvss Impact Score2.9Attack ComplexityLow
Cvss Expoit Score10AuthenticationNone Required
Calculate full CVSS 2.0 Vectors scores

Detail

Severity Rating: Important
Revision Note: V1.1 (September 17, 2014): V1.1 (September 17, 2014): Bulletin revised to clarify language in the Executive Summary, Mitigating Factors, and Vulnerability FAQ sections that describes the attack vector for CVE-2014-4072. This is an informational change only. Customers who have already successfully installed the update do not have to take any action.
Summary: This security update resolves one privately reported vulnerability in Microsoft .NET Framework. The vulnerability could allow denial of service if an attacker sends a small number of specially crafted requests to an affected .NET-enabled website. By default, ASP.NET is not installed when Microsoft .NET Framework is installed on any supported edition of Microsoft Windows. To be affected by the vulnerability, customers must manually install and enable ASP.NET by registering it with IIS.

Original Source

Url : https://technet.microsoft.com/en-us/library/security/MS14-053

CWE : Common Weakness Enumeration

%idName
100 %CWE-399Resource Management Errors

OVAL Definitions

Definition Id: oval:org.mitre.oval:def:26601
 
Oval ID: oval:org.mitre.oval:def:26601
Title: .NET framework denial of service vulnerability - CVE-2014-4072 (MS14-053)
Description: Microsoft .NET Framework 1.1 SP1, 2.0 SP2, 3.0 SP2, 3.5, 3.5.1, 4, 4.5, 4.5.1, and 4.5.2 does not properly use a hash table for request data, which allows remote attackers to cause a denial of service (resource consumption and ASP.NET performance degradation) via crafted requests, aka ".NET Framework Denial of Service Vulnerability."
Family: windows Class: vulnerability
Reference(s): CVE-2014-4072
Version: 4
Platform(s): Microsoft Windows 7
Microsoft Windows 8
Microsoft Windows Server 2003
Microsoft Windows Server 2008
Microsoft Windows Server 2008 R2
Microsoft Windows Server 2012
Microsoft Windows Vista
Microsoft Windows 8.1
Microsoft Windows Server 2012 R2
Product(s): Microsoft .NET Framework 1.1
Microsoft .NET Framework 2.0
Microsoft .NET Framework 3.0
Microsoft .NET Framework 3.5.1
Microsoft .NET Framework 4.0
Microsoft .NET Framework 4.5
Microsoft .NET Framework 4.5.1
Microsoft .NET Framework 4.5.2
Definition Synopsis:

CPE : Common Platform Enumeration

TypeDescriptionCount
Application9

Nessus® Vulnerability Scanner

DateDescription
2014-09-10Name : The version of the .NET Framework installed on the remote host is affected by...
File : smb_nt_ms14-053.nasl - Type : ACT_GATHER_INFO

Alert History

If you want to see full details history, please login or register.
0
1
2
3
4
5
6
DateInformations
2014-09-17 21:31:19
  • Multiple Updates
2014-09-17 21:16:58
  • Multiple Updates
2014-09-10 21:29:26
  • Multiple Updates
2014-09-10 13:26:25
  • Multiple Updates
2014-09-10 09:28:22
  • Multiple Updates
2014-09-09 21:30:14
  • Multiple Updates
2014-09-09 21:16:46
  • First insertion