Executive Summary

Summary
TitleVulnerabilities in Microsoft Word and Office Web Apps Could Allow Remote Code Execution (2949660)
Informations
NameMS14-017First vendor Publication2014-04-08
VendorMicrosoftLast vendor Modification2014-04-08
Severity (Vendor) CriticalRevision1.0

Security-Database Scoring CVSS v2

Cvss vector : (AV:N/AC:M/Au:N/C:C/I:C/A:C)
Cvss Base Score9.3Attack RangeNetwork
Cvss Impact Score10Attack ComplexityMedium
Cvss Expoit Score8.6AuthenticationNone Required
Calculate full CVSS 2.0 Vectors scores

Detail

Revision Note: V1.0 (April 8, 2014): Bulletin published.

Summary: This security update resolves one publicly disclosed vulnerability and two privately reported vulnerabilities in Microsoft Office. The most severe of these vulnerabilities could allow remote code execution if a specially crafted file is opened or previewed in an affected version of Microsoft Office software. An attacker who successfully exploited these vulnerabilities could gain the same user rights as the current user. Customers whose accounts are configured to have fewer user rights on the system could be less impacted than those who operate with administrative user rights.

Original Source

Url : http://technet.microsoft.com/en-us/security/bulletin/ms14-017

CWE : Common Weakness Enumeration

%idName
100 %CWE-119Failure to Constrain Operations within the Bounds of a Memory Buffer

OVAL Definitions

Definition Id: oval:org.mitre.oval:def:24358
 
Oval ID: oval:org.mitre.oval:def:24358
Title: Microsoft Word stack overflow vulnerability (CVE-2014-1758) - MS14-017
Description: Stack-based buffer overflow in Microsoft Word 2003 SP3 allows remote attackers to execute arbitrary code via a crafted document, aka "Microsoft Word Stack Overflow Vulnerability."
Family: windows Class: vulnerability
Reference(s): CVE-2014-1758
Version: 5
Platform(s): Microsoft Windows 2000
Microsoft Windows 7
Microsoft Windows 8
Microsoft Windows Server 2003
Microsoft Windows Server 2008
Microsoft Windows Server 2008 R2
Microsoft Windows Server 2012
Microsoft Windows Vista
Microsoft Windows XP
Microsoft Windows 8.1
Microsoft Windows Server 2012 R2
Product(s): Microsoft Word 2003
Definition Synopsis:
Definition Id: oval:org.mitre.oval:def:24318
 
Oval ID: oval:org.mitre.oval:def:24318
Title: Microsoft Office file format converter vulnerability (CVE-2014-1757) - MS14-017
Description: Microsoft Word 2007 SP3 and 2010 SP1 and SP2, and Office Compatibility Pack SP3, allocates memory incorrectly for file conversions from a binary (aka .doc) format to a newer format, which allows remote attackers to execute arbitrary code via a crafted document, aka "Microsoft Office File Format Converter Vulnerability."
Family: windows Class: vulnerability
Reference(s): CVE-2014-1757
Version: 7
Platform(s): Microsoft Windows 7
Microsoft Windows 8
Microsoft Windows 8.1
Microsoft Windows Server 2003
Microsoft Windows Server 2008
Microsoft Windows Server 2008 R2
Microsoft Windows Server 2012
Microsoft Windows Server 2012 R2
Microsoft Windows Vista
Microsoft Windows XP
Product(s): Microsoft Office Compatibility Pack
Microsoft Word 2007
Microsoft Word 2010
Definition Synopsis:
Definition Id: oval:org.mitre.oval:def:24472
 
Oval ID: oval:org.mitre.oval:def:24472
Title: Vulnerabilities in Microsoft Word could allow remote code execution (CVE-2014-1761) - MS14-017
Description: Microsoft Word 2003 SP3, 2007 SP3, 2010 SP1 and SP2, 2013, and 2013 RT; Word Viewer; Office Compatibility Pack SP3; Office for Mac 2011; Word Automation Services on SharePoint Server 2010 SP1 and SP2 and 2013; Office Web Apps 2010 SP1 and SP2; and Office Web Apps Server 2013 allow remote attackers to execute arbitrary code or cause a denial of service (memory corruption) via crafted RTF data, as exploited in the wild in March 2014.
Family: macos Class: vulnerability
Reference(s): CVE-2014-1761
Version: 3
Platform(s): Apple Mac OS X
Apple Mac OS X Server
Product(s): Microsoft Office 2011 for Mac
Definition Synopsis:
Definition Id: oval:org.mitre.oval:def:23983
 
Oval ID: oval:org.mitre.oval:def:23983
Title: Word RTF memory corruption vulnerability (CVE-2014-1761) - MS14-017
Description: Microsoft Word 2003 SP3, 2007 SP3, 2010 SP1 and SP2, 2013, and 2013 RT; Word Viewer; Office Compatibility Pack SP3; Office for Mac 2011; Word Automation Services on SharePoint Server 2010 SP1 and SP2 and 2013; Office Web Apps 2010 SP1 and SP2; and Office Web Apps Server 2013 allow remote attackers to execute arbitrary code or cause a denial of service (memory corruption) via crafted RTF data, as exploited in the wild in March 2014.
Family: windows Class: vulnerability
Reference(s): CVE-2014-1761
Version: 5
Platform(s): Microsoft Windows 2000
Microsoft Windows 7
Microsoft Windows 8
Microsoft Windows 8.1
Microsoft Windows Server 2003
Microsoft Windows Server 2008
Microsoft Windows Server 2008 R2
Microsoft Windows Server 2012
Microsoft Windows Server 2012 R2
Microsoft Windows Vista
Microsoft Windows XP
Product(s): Microsoft Office Compatibility Pack
Microsoft Word 2003
Microsoft Word 2007
Microsoft Word 2010
Microsoft Word 2013
Microsoft Word Viewer
Microsoft Office Web Apps 2010
Microsoft Office Web Apps Server 2013
Microsoft SharePoint Server 2010
Microsoft SharePoint Server 2013
Definition Synopsis:

CPE : Common Platform Enumeration

TypeDescriptionCount
Application1
Application1
Application2
Application1
Application3
Application9
Application1

SAINT Exploits

DescriptionLink
Microsoft Word RTF Object ConfusionMore info here

ExploitDB Exploits

idDescription
2014-04-10MS14-017 Microsoft Word RTF Object Confusion

Information Assurance Vulnerability Management (IAVM)

DateDescription
2014-04-10IAVM : 2014-A-0049 - Multiple Vulnerabilities in Microsoft Office
Severity : Category II - VMSKEY : V0048675

Snort® IPS/IDS

DateDescription
2014-01-10Microsoft Office Word rtf invalid listoverridecount value attempt
RuleID : 24975 - Revision : 12 - Type : FILE-OFFICE
2014-01-10Microsoft Office Word rtf invalid listoverridecount value attempt
RuleID : 24974 - Revision : 12 - Type : FILE-OFFICE

Metasploit Database

idDescription
2014-04-01 MS14-017 Microsoft Word RTF Object Confusion

Nessus® Vulnerability Scanner

DateDescription
2014-10-15Name : The remote host is affected by a remote code execution vulnerability.
File : smb_nt_ms14-061.nasl - Type : ACT_GATHER_INFO
2014-04-08Name : An application installed on the remote Mac OS X host is affected by a remote ...
File : macosx_ms14-017.nasl - Type : ACT_GATHER_INFO
2014-04-08Name : The remote host is affected by multiple memory corruption vulnerabilities.
File : smb_nt_ms14-017.nasl - Type : ACT_GATHER_INFO
2014-03-24Name : The remote Windows host is affected by a remote code execution vulnerability.
File : smb_kb2953095.nasl - Type : ACT_GATHER_INFO

Alert History

If you want to see full details history, please login or register.
0
1
2
3
4
5
6
7
8
DateInformations
2016-04-27 02:04:19
  • Multiple Updates
2014-10-16 13:25:47
  • Multiple Updates
2014-04-12 13:26:50
  • Multiple Updates
2014-04-11 21:21:47
  • Multiple Updates
2014-04-11 17:19:59
  • Multiple Updates
2014-04-09 13:26:28
  • Multiple Updates
2014-04-09 13:22:25
  • Multiple Updates
2014-04-09 05:20:08
  • Multiple Updates
2014-04-08 21:16:42
  • First insertion