Executive Summary

Informations
NameMDVSA-2015:204First vendor Publication2015-04-27
VendorMandrivaLast vendor Modification2015-04-27
Severity (Vendor) N/ARevisionN/A

Security-Database Scoring CVSS v2

Cvss vector : (AV:N/AC:M/Au:N/C:N/I:P/A:P)
Cvss Base Score5.8Attack RangeNetwork
Cvss Impact Score4.9Attack ComplexityMedium
Cvss Expoit Score8.6AuthenticationNone Required
Calculate full CVSS 2.0 Vectors scores

Detail

Updated librsync packages fix security vulnerability:

librsync before 1.0.0 used a truncated MD4 strong check sum to match blocks. However, MD4 is not cryptographically strong. It's possible that an attacker who can control the contents of one part of a file could use it to control other regions of the file, if it's transferred using librsync/rdiff (CVE-2014-8242).

The change to fix this is not backward compatible with older versions of librsync. Backward compatibility can be obtained using the new rdiff sig --hash=md4 option or through specifying the signature magic in the API, but this should not be used when either the old or new file contain untrusted data.

Also, any applications that use the librsync library will need to be recompiled against the updated library. The rdiff-backup packages have been rebuilt for this reason.

Original Source

Url : http://www.mandriva.com/security/advisories?name=MDVSA-2015:204

CWE : Common Weakness Enumeration

%idName
100 %CWE-310Cryptographic Issues

CPE : Common Platform Enumeration

TypeDescriptionCount
Application1

Nessus® Vulnerability Scanner

DateDescription
2016-05-31Name : The remote Gentoo host is missing one or more security-related patches.
File : gentoo_GLSA-201605-04.nasl - Type : ACT_GATHER_INFO
2016-01-20Name : The remote SUSE host is missing one or more security updates.
File : suse_SU-2016-0173-1.nasl - Type : ACT_GATHER_INFO
2016-01-20Name : The remote SUSE host is missing one or more security updates.
File : suse_SU-2016-0176-1.nasl - Type : ACT_GATHER_INFO
2016-01-11Name : The remote FreeBSD host is missing a security-related update.
File : freebsd_pkg_b22b016bb63311e583ef14dae9d210b8.nasl - Type : ACT_GATHER_INFO
2015-10-15Name : The remote openSUSE host is missing a security update.
File : openSUSE-2015-659.nasl - Type : ACT_GATHER_INFO
2015-04-28Name : The remote Mandriva Linux host is missing one or more security updates.
File : mandriva_MDVSA-2015-204.nasl - Type : ACT_GATHER_INFO
2015-03-20Name : The remote Fedora host is missing one or more security updates.
File : fedora_2015-3366.nasl - Type : ACT_GATHER_INFO
2015-03-20Name : The remote Fedora host is missing one or more security updates.
File : fedora_2015-3497.nasl - Type : ACT_GATHER_INFO
2015-03-10Name : The remote Fedora host is missing one or more security updates.
File : fedora_2015-2923.nasl - Type : ACT_GATHER_INFO

Alert History

If you want to see full details history, please login or register.
0
1
2
3
DateInformations
2015-10-28 09:28:00
  • Multiple Updates
2015-10-26 21:27:37
  • Multiple Updates
2015-04-29 13:28:48
  • Multiple Updates
2015-04-27 09:24:51
  • First insertion