Executive Summary

Summary
TitleZsh: Privilege escalation
Informations
NameGLSA-202003-55First vendor Publication2020-03-25
VendorGentooLast vendor Modification2020-03-25
Severity (Vendor) N/ARevisionN/A

Security-Database Scoring CVSS v2

Cvss vector :
Cvss Base ScoreN/AAttack RangeN/A
Cvss Impact ScoreN/AAttack ComplexityN/A
Cvss Expoit ScoreN/AAuthenticationN/A
Calculate full CVSS 2.0 Vectors scores

Detail

Synopsis

A vulnerability in Zsh might allow an attacker to escalate privileges.

Background

A shell designed for interactive use, although it is also a powerful scripting language.

Description

It was discovered that Zsh was insecure dropping privileges when unsetting PRIVILEGED option.

Impact

An attacker could escalate privileges.

Workaround

There is no known workaround at this time.

Resolution

All Zsh users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose ">=app-shells/zsh-5.8"

References

[ 1 ] CVE-2019-20044 : https://nvd.nist.gov/vuln/detail/CVE-2019-20044

Availability

This GLSA and any updates to it are available for viewing at the Gentoo Security Website:

https://security.gentoo.org/glsa/202003-55

Original Source

Url : http://security.gentoo.org/glsa/glsa-202003-55.xml

Alert History

If you want to see full details history, please login or register.
0
DateInformations
2020-03-26 00:17:52
  • First insertion