Executive Summary

Summary
TitleOniguruma: Multiple vulnerabilities
Informations
NameGLSA-201911-03First vendor Publication2019-11-07
VendorGentooLast vendor Modification2019-11-07
Severity (Vendor) N/ARevisionN/A

Security-Database Scoring CVSS v2

Cvss vector : (AV:N/AC:L/Au:N/C:P/I:P/A:P)
Cvss Base Score7.5Attack RangeNetwork
Cvss Impact Score6.4Attack ComplexityLow
Cvss Expoit Score10AuthenticationNone Required
Calculate full CVSS 2.0 Vectors scores

Detail

Synopsis

Multiple vulnerabilities have been found in Oniguruma, the worst of which could result in the arbitrary execution of code.

Background

Oniguruma is a regular expression library.

Description

Multiple vulnerabilities have been discovered in Oniguruma. Please review the CVE identifiers referenced below for details.

Impact

A remote attacker, by enticing a user to process a specially crafted string using an application linked against Oniguruma, could possibly execute arbitrary code with the privileges of the process or cause a Denial of Service condition.

Workaround

There is no known workaround at this time.

Resolution

All Oniguruma users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-libs/oniguruma-6.9.3"

References

[ 1 ] CVE-2019-13224 : https://nvd.nist.gov/vuln/detail/CVE-2019-13224
[ 2 ] CVE-2019-13225 : https://nvd.nist.gov/vuln/detail/CVE-2019-13225

Availability

This GLSA and any updates to it are available for viewing at the Gentoo Security Website:

https://security.gentoo.org/glsa/201911-03

Original Source

Url : http://security.gentoo.org/glsa/glsa-201911-03.xml

CWE : Common Weakness Enumeration

%idName
50 %CWE-476NULL Pointer Dereference
50 %CWE-416Use After Free

CPE : Common Platform Enumeration

TypeDescriptionCount
Application1

Alert History

If you want to see full details history, please login or register.
0
DateInformations
2019-11-07 21:18:33
  • First insertion