Executive Summary

Summary
TitleGNOME desktop library: Security bypass
Informations
NameGLSA-201908-28First vendor Publication2019-08-31
VendorGentooLast vendor Modification2019-08-31
Severity (Vendor) N/ARevisionN/A

Security-Database Scoring CVSS v2

Cvss vector : (AV:N/AC:M/Au:N/C:P/I:P/A:P)
Cvss Base Score6.8Attack RangeNetwork
Cvss Impact Score6.4Attack ComplexityMedium
Cvss Expoit Score8.6AuthenticationNone Required
Calculate full CVSS 2.0 Vectors scores

Detail

Synopsis

A vulnerability in the GNOME desktop library may allow attackers to escape the sandbox.

Background

Library with common API for various GNOME modules.

Description

A vulnerability was discovered in the GNOME desktop library which allows an attacker to escape the sandbox.

Impact

A local attacker could possibly bypass sandbox protection.

Workaround

There is no known workaround at this time.

Resolution

All GNOME desktop library users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot -v ">=gnome-base/gnome-desktop-3.30.2.3"

References

[ 1 ] CVE-2019-11460 : https://nvd.nist.gov/vuln/detail/CVE-2019-11460

Availability

This GLSA and any updates to it are available for viewing at the Gentoo Security Website:

https://security.gentoo.org/glsa/201908-28

Original Source

Url : http://security.gentoo.org/glsa/glsa-201908-28.xml

CWE : Common Weakness Enumeration

%idName
100 %CWE-20Improper Input Validation

CPE : Common Platform Enumeration

TypeDescriptionCount
Application8

Alert History

If you want to see full details history, please login or register.
0
DateInformations
2019-09-01 00:18:44
  • First insertion