Executive Summary

Summary
TitleKDE KConfig: User-assisted execution of arbitrary code
Informations
NameGLSA-201908-07First vendor Publication2019-08-15
VendorGentooLast vendor Modification2019-08-15
Severity (Vendor) N/ARevisionN/A

Security-Database Scoring CVSS v2

Cvss vector : (AV:N/AC:H/Au:N/C:P/I:P/A:P)
Cvss Base Score5.1Attack RangeNetwork
Cvss Impact Score6.4Attack ComplexityHigh
Cvss Expoit Score4.9AuthenticationNone Required
Calculate full CVSS 2.0 Vectors scores

Detail

Synopsis

A vulnerablity has been found in KDE KConfig that could allow a remote attacker to execute arbitrary code.

Background

Provides an advanced configuration system.

Description

A vulnerability was discovered in KDE KConfig's handling of .desktop and .directory files.

Impact

An attacker could entice a user to execute a specially crafted .desktop or .directory file possibly resulting in execution of arbitrary code with the privileges of the process.

Workaround

There is no known workaround at this time.

Resolution

All KConfig users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot -v ">=kde-frameworks/kconfig-5.60.0-r1"

References

[ 1 ] CVE-2019-14744 : https://nvd.nist.gov/vuln/detail/CVE-2019-14744

Availability

This GLSA and any updates to it are available for viewing at the Gentoo Security Website:

https://security.gentoo.org/glsa/201908-07

Original Source

Url : http://security.gentoo.org/glsa/glsa-201908-07.xml

CWE : Common Weakness Enumeration

%idName
100 %CWE-77Improper Sanitization of Special Elements used in a Command ('Command Injection')

CPE : Common Platform Enumeration

TypeDescriptionCount
Application139
Os2

Alert History

If you want to see full details history, please login or register.
0
DateInformations
2019-08-15 21:18:41
  • First insertion