Executive Summary



This Alert is flagged as TOP 25 Common Weakness Enumeration from CWE/SANS. For more information, you can read this.
Summary
TitleMing: Multiple vulnerabilities
Informations
NameGLSA-201904-24First vendor Publication2019-04-24
VendorGentooLast vendor Modification2019-04-24
Severity (Vendor) N/ARevisionN/A

Security-Database Scoring CVSS v2

Cvss vector : (AV:N/AC:M/Au:N/C:P/I:P/A:P)
Cvss Base Score6.8Attack RangeNetwork
Cvss Impact Score6.4Attack ComplexityMedium
Cvss Expoit Score8.6AuthenticationNone Required
Calculate full CVSS 2.0 Vectors scores

Detail

Synopsis

Multiple vulnerabilities have been found in Ming, the worst of which could result in a Denial of Service condition.

Background

A library for generating Macromedia Flash files.

Description

Multiple vulnerabilities have been discovered in Ming. Please review the CVE identifiers referenced below for details.

Impact

Please review the referenced CVE identifiers for details.

Workaround

There is no known workaround at this time.

Resolution

All Ming users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose ">=media-libs/ming-0.20181112"

References

[ 1 ] CVE-2017-11728 : https://nvd.nist.gov/vuln/detail/CVE-2017-11728
[ 2 ] CVE-2017-11729 : https://nvd.nist.gov/vuln/detail/CVE-2017-11729
[ 3 ] CVE-2017-11730 : https://nvd.nist.gov/vuln/detail/CVE-2017-11730
[ 4 ] CVE-2017-11731 : https://nvd.nist.gov/vuln/detail/CVE-2017-11731
[ 5 ] CVE-2017-11732 : https://nvd.nist.gov/vuln/detail/CVE-2017-11732
[ 6 ] CVE-2017-11733 : https://nvd.nist.gov/vuln/detail/CVE-2017-11733
[ 7 ] CVE-2017-11734 : https://nvd.nist.gov/vuln/detail/CVE-2017-11734
[ 8 ] CVE-2017-9988 : https://nvd.nist.gov/vuln/detail/CVE-2017-9988
[ 9 ] CVE-2017-9989 : https://nvd.nist.gov/vuln/detail/CVE-2017-9989
[ 10 ] CVE-2018-5251 : https://nvd.nist.gov/vuln/detail/CVE-2018-5251
[ 11 ] CVE-2018-5294 : https://nvd.nist.gov/vuln/detail/CVE-2018-5294
[ 12 ] CVE-2018-6315 : https://nvd.nist.gov/vuln/detail/CVE-2018-6315
[ 13 ] CVE-2018-6358 : https://nvd.nist.gov/vuln/detail/CVE-2018-6358
[ 14 ] CVE-2018-6359 : https://nvd.nist.gov/vuln/detail/CVE-2018-6359

Availability

This GLSA and any updates to it are available for viewing at the Gentoo Security Website:

https://security.gentoo.org/glsa/201904-24

Original Source

Url : http://security.gentoo.org/glsa/glsa-201904-24.xml

CWE : Common Weakness Enumeration

%idName
40 %CWE-119Failure to Constrain Operations within the Bounds of a Memory Buffer
20 %CWE-476NULL Pointer Dereference
13 %CWE-190Integer Overflow or Wraparound (CWE/SANS Top 25)
13 %CWE-125Out-of-bounds Read
7 %CWE-416Use After Free
7 %CWE-189Numeric Errors (CWE/SANS Top 25)

CPE : Common Platform Enumeration

TypeDescriptionCount
Application2
Application1
Os1

Nessus® Vulnerability Scanner

DateDescription
2019-01-03Name : The remote Fedora host is missing a security update.
File : fedora_2018-5f31e1002a.nasl - Type : ACT_GATHER_INFO
2018-04-10Name : The remote Debian host is missing a security update.
File : debian_DLA-1343.nasl - Type : ACT_GATHER_INFO
2018-03-21Name : The remote Fedora host is missing a security update.
File : fedora_2018-38a0e1e6f5.nasl - Type : ACT_GATHER_INFO
2018-03-21Name : The remote Fedora host is missing a security update.
File : fedora_2018-8be89d9ad6.nasl - Type : ACT_GATHER_INFO
2018-03-12Name : The remote Debian host is missing a security update.
File : debian_DLA-1305.nasl - Type : ACT_GATHER_INFO
2018-01-12Name : The remote Debian host is missing a security update.
File : debian_DLA-1240.nasl - Type : ACT_GATHER_INFO
2017-11-20Name : The remote Debian host is missing a security update.
File : debian_DLA-1176.nasl - Type : ACT_GATHER_INFO
2017-10-23Name : The remote Debian host is missing a security update.
File : debian_DLA-1133.nasl - Type : ACT_GATHER_INFO

Alert History

If you want to see full details history, please login or register.
0
DateInformations
2019-04-25 05:18:38
  • First insertion