Executive Summary



This Alert is flagged as TOP 25 Common Weakness Enumeration from CWE/SANS. For more information, you can read this.
Summary
TitlecURL: Multiple vulnerabilities
Informations
NameGLSA-201903-03First vendor Publication2019-03-10
VendorGentooLast vendor Modification2019-03-10
Severity (Vendor) N/ARevisionN/A

Security-Database Scoring CVSS v2

Cvss vector : (AV:N/AC:L/Au:N/C:C/I:C/A:C)
Cvss Base Score10Attack RangeNetwork
Cvss Impact Score10Attack ComplexityLow
Cvss Expoit Score10AuthenticationNone Required
Calculate full CVSS 2.0 Vectors scores

Detail

Synopsis

Multiple vulnerabilities have been found in cURL, the worst of which could result in a Denial of Service condition.

Background

A command line tool and library for transferring data with URLs.

Description

Multiple vulnerabilities have been discovered in cURL. Please review the CVE identifiers referenced below for details.

Impact

Remote attackers could cause a Denial of Service condition.

Workaround

There is no known workaround at this time.

Resolution

All cURL users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose ">=net-misc/curl-7.64.0"

References

[ 1 ] CVE-2018-14618 : https://nvd.nist.gov/vuln/detail/CVE-2018-14618
[ 2 ] CVE-2018-16839 : https://nvd.nist.gov/vuln/detail/CVE-2018-16839
[ 3 ] CVE-2018-16840 : https://nvd.nist.gov/vuln/detail/CVE-2018-16840
[ 4 ] CVE-2018-16842 : https://nvd.nist.gov/vuln/detail/CVE-2018-16842
[ 5 ] CVE-2019-3822 : https://nvd.nist.gov/vuln/detail/CVE-2019-3822
[ 6 ] CVE-2019-3823 : https://nvd.nist.gov/vuln/detail/CVE-2019-3823

Availability

This GLSA and any updates to it are available for viewing at the Gentoo Security Website:

https://security.gentoo.org/glsa/201903-03

Original Source

Url : http://security.gentoo.org/glsa/glsa-201903-03.xml

CWE : Common Weakness Enumeration

%idName
33 %CWE-125Out-of-bounds Read
33 %CWE-119Failure to Constrain Operations within the Bounds of a Memory Buffer
17 %CWE-416Use After Free
17 %CWE-190Integer Overflow or Wraparound (CWE/SANS Top 25)

CPE : Common Platform Enumeration

TypeDescriptionCount
Application90
Application152
Application2
Application1
Application1
Application1
Os5
Os2
Os1
Os5

Nessus® Vulnerability Scanner

DateDescription
2019-01-03Name : The remote Fedora host is missing a security update.
File : fedora_2018-fdc4ca8675.nasl - Type : ACT_GATHER_INFO
2019-01-03Name : The remote Fedora host is missing a security update.
File : fedora_2018-69bac0f51c.nasl - Type : ACT_GATHER_INFO
2019-01-03Name : The remote Fedora host is missing a security update.
File : fedora_2018-111044d435.nasl - Type : ACT_GATHER_INFO
2019-01-03Name : The remote Fedora host is missing a security update.
File : fedora_2018-7785911c9e.nasl - Type : ACT_GATHER_INFO
2019-01-03Name : The remote Fedora host is missing a security update.
File : fedora_2018-7f83032de6.nasl - Type : ACT_GATHER_INFO
2019-01-03Name : The remote Fedora host is missing a security update.
File : fedora_2018-298a3d2923.nasl - Type : ACT_GATHER_INFO
2018-12-20Name : The remote Amazon Linux 2 host is missing a security update.
File : al2_ALAS-2018-1135.nasl - Type : ACT_GATHER_INFO
2018-12-07Name : The remote Amazon Linux AMI host is missing a security update.
File : ala_ALAS-2018-1112.nasl - Type : ACT_GATHER_INFO
2018-11-07Name : The remote Debian host is missing a security update.
File : debian_DLA-1568.nasl - Type : ACT_GATHER_INFO
2018-11-05Name : The remote Debian host is missing a security-related update.
File : debian_DSA-4331.nasl - Type : ACT_GATHER_INFO
2018-11-02Name : The remote FreeBSD host is missing a security-related update.
File : freebsd_pkg_e0ab177307c146c691704c5e81c00927.nasl - Type : ACT_GATHER_INFO
2018-11-01Name : The remote Slackware host is missing a security update.
File : Slackware_SSA_2018-304-01.nasl - Type : ACT_GATHER_INFO
2018-09-21Name : The remote Fedora host is missing a security update.
File : fedora_2018-ba443bcb6d.nasl - Type : ACT_GATHER_INFO
2018-09-10Name : The remote Debian host is missing a security update.
File : debian_DLA-1498.nasl - Type : ACT_GATHER_INFO
2018-09-06Name : The remote Slackware host is missing a security update.
File : Slackware_SSA_2018-249-01.nasl - Type : ACT_GATHER_INFO
2018-09-06Name : The remote Debian host is missing a security-related update.
File : debian_DSA-4286.nasl - Type : ACT_GATHER_INFO
2018-09-06Name : The remote FreeBSD host is missing a security-related update.
File : freebsd_pkg_f4d638b9e6e54dbe8c70571dbc116174.nasl - Type : ACT_GATHER_INFO

Alert History

If you want to see full details history, please login or register.
0
DateInformations
2019-03-10 21:18:50
  • First insertion